0

OLED SSD1351 Rogue Blue Line
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

OLED SSD1351 Rogue Blue Line

by vicbotnik on Wed Jan 20, 2016 3:53 am

Hi,

I've recently purchased the OLED SSD1351 breakout board and after I wired it up, there seems to be a blue vertical line that I can't get rid of. Powering it off is the only way I can get rid of it.

I'm wondering if there's anything else I can do to get rid of it. Any ideas are welcome. I've done txt.fillScreen(BLACK); and still shows the blue line.

Thanks!

Here's some pics and a video.
Image
Image
Image

vicbotnik
 
Posts: 7
Joined: Thu Jan 23, 2014 12:36 am

Re: OLED SSD1351 Rogue Blue Line

by adafruit_support_rick on Wed Jan 20, 2016 2:10 pm

You should re-do your solders. They don't look so good. If that doesn't help, Please email support@adafruit.com with a link to this thread for a replacement display

adafruit_support_rick
 
Posts: 34836
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: OLED SSD1351 Rogue Blue Line

by vicbotnik on Wed Jan 20, 2016 2:17 pm

Thanks for the reply. I'll redo them tonight and see what happens.

Thanks again!

vicbotnik
 
Posts: 7
Joined: Thu Jan 23, 2014 12:36 am

Re: OLED SSD1351 Rogue Blue Line

by vicbotnik on Wed Jan 20, 2016 8:43 pm

OK, I've cleaned up my solder joints and the blue line is still hanging around. Sorry for the glare.
Image
I'll email support like you suggested. Thanks for trying!

vicbotnik
 
Posts: 7
Joined: Thu Jan 23, 2014 12:36 am

Re: OLED SSD1351 Rogue Blue Line

by adafruit_support_rick on Thu Jan 21, 2016 10:48 am

Solder looks much better, thanks!
Interesting that it's not as wide now. But it still looks like a defect. Please email support@adafruit.com with a link to this thread for a replacement OLED

adafruit_support_rick
 
Posts: 34836
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: OLED SSD1351 Rogue Blue Line

by g3d on Sun Nov 12, 2017 1:22 am

Hello, name is george. i have kinda the same issue. i have 2 tft's workfine. and 2 oled's one of which show a blue line. solder is okay, ribbon cable looks good and no damage that i can see. this is the 1 out of four that dont work 100% correctly. heres 2 pics. one with acrilyc half ball is the good one.
https://photos.app.goo.gl/iLxkpy8igao6RXyX2
https://photos.app.goo.gl/jgd719O6t2tJdc8j2
Last edited by g3d on Tue Nov 14, 2017 2:06 am, edited 2 times in total.

g3d
 
Posts: 3
Joined: Fri Jan 01, 2016 5:25 am

Re: OLED SSD1351 Rogue Blue Line

by adafruit_support_rick on Sun Nov 12, 2017 5:08 pm

Hi, george. Unfortunately, both of those picture urls are 404.

adafruit_support_rick
 
Posts: 34836
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: OLED SSD1351 Rogue Blue Line

by g3d on Tue Nov 14, 2017 11:14 pm

i have fixed the links.

please also see that i was told by support to put it in a seperate post.

regards,
George.

g3d
 
Posts: 3
Joined: Fri Jan 01, 2016 5:25 am

Re: OLED SSD1351 Rogue Blue Line

by adafruit_support_rick on Wed Nov 15, 2017 10:46 am

Yeah - separate posts are good. I responded on your other thread:
viewtopic.php?f=47&t=126499&p=631271#p630917

adafruit_support_rick
 
Posts: 34836
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Please be positive and constructive with your questions and comments.