0

Jupyer nb/CP kernel/CLUE board connection issues
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Jupyer nb/CP kernel/CLUE board connection issues

by jhhender on Tue Sep 07, 2021 1:22 pm

Hello, I'm looking for help with an issue related to Jupyter Notebook, Circuitpython Kernel, and the CLUE board. I'm running a class, and a subset of students are having issues like the one pasted below. The thing they all seem to share is that they had previous installations of Anaconda on their laptops before they installed the Circuitpython Kernel. Many have tried to uninstall/reinstall Anaconda, the CP kernel, and the CLUE software and libraries from scratch but without luck. Most are Windows 10 machines.

I'm wondering if there are known issues related to doing a CP kernel install on a machine with a pre-existing Anaconda install, or tips on doing a clean enough uninstall/reinstall to get things working.

Thanks for any guidance!

[I 12:42:37.932 NotebookApp] Kernel started: 05c859df-1a6e-44b6-bff4-74ecfe2ecd79, name: circuitpython
DEBUG:asyncio:Using selector: SelectSelector
DEBUG:asyncio:Using selector: SelectSelector
DEBUG:circuitpython_kernel.kernel:circuitpython_kernel version 0.3.0.dev
DEBUG:circuitpython_kernel.board:COM5
DEBUG:circuitpython_kernel.board:CircuitPython Board Found at: COM5
DEBUG:circuitpython_kernel.board:Connected? False
DEBUG:circuitpython_kernel.board:connect: open COM5
DEBUG:circuitpython_kernel.kernel:no connection failed to access COM5
DEBUG:circuitpython_kernel.kernel:Error: 'No connection to CiruitPython VM: failed to access COM5'

jhhender
 
Posts: 8
Joined: Mon Jun 10, 2019 9:09 pm

Re: Jupyer nb/CP kernel/CLUE board connection issues

by brubell on Wed Sep 08, 2021 12:00 pm

If you look in Device Manager, does the device show up under "USB Serial Device" as COM5?

brubell
 
Posts: 1533
Joined: Fri Jul 17, 2015 10:33 pm

Re: Jupyer nb/CP kernel/CLUE board connection issues

by jhhender on Thu Sep 23, 2021 1:32 pm

Thanks for following up. Sorry for not responding sooner, I just saw this today. Let me look into it with one of the students who was having the problem (I can't reproduce the issue on my machine). I'll follow up here after I do (in the meantime, I've moved the students having issues to using a combo of Jupyter and Mu. It adds one more cut/paste step for them, but it's working...)

jhhender
 
Posts: 8
Joined: Mon Jun 10, 2019 9:09 pm

Please be positive and constructive with your questions and comments.