0

Circuit Playground Accelerometer Issues
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Circuit Playground Accelerometer Issues

by smcelwrath on Tue May 21, 2019 8:51 am

As a teacher, I received a Circuit Playground kit for myself last summer (July 2018) from my Code.org Professional Development. When testing the Unit 6 lessons on Code.org and using my Circuit Playground, I've had no issues. Today my students are working on the Accelerometer lesson and the entire class code did not work. As I investigated this issue further, their accelerometers were measuring the wrong things. Pitch was being measured with left and right movement. Roll was being measured with forward to backward movement and it was all opposite of the way that mine works and the directions in Code.org. It's as if the accelerometers were put in upside down and backwards. The Circuit Playground kit I ordered for my class is brand new and was received in February of this year. Not one of them that I received has the accelerometer working properly. (I was certain it was just me at first!) HELP!

smcelwrath
 
Posts: 3
Joined: Tue May 21, 2019 8:44 am

Re: Circuit Playground Accelerometer Issues

by franklin97355 on Tue May 21, 2019 9:02 am

I'll check with the production team.

franklin97355
 
Posts: 21105
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Circuit Playground Accelerometer Issues

by adafruit2 on Tue May 21, 2019 1:09 pm

smcel, can you tell me if the back says Circuit Playground Classic or Express?

adafruit2
Site Admin
 
Posts: 18666
Joined: Fri Mar 11, 2005 7:36 pm

Re: Circuit Playground Accelerometer Issues

by smcelwrath on Tue May 21, 2019 1:14 pm

My teacher board that I received at Code.org training says "Classic" the boards my students have say "express"

smcelwrath
 
Posts: 3
Joined: Tue May 21, 2019 8:44 am

Re: Circuit Playground Accelerometer Issues

by adafruit2 on Tue May 21, 2019 1:18 pm

OK - we did a big upgrade from classic to express but one of the changes is that the accelerometer rotated 90 degrees. if you look on the board, in the middle find the XYZ orientation notes.
the boards work fine but they need to be 'turned' in the hand 90 degrees clockwise. does that work?

adafruit2
Site Admin
 
Posts: 18666
Joined: Fri Mar 11, 2005 7:36 pm

Re: Circuit Playground Accelerometer Issues

by smcelwrath on Tue May 21, 2019 1:29 pm

YES!! I'll email Code.org and ask that they add that information to their Accelerometer lesson!! Thank you so much!

smcelwrath
 
Posts: 3
Joined: Tue May 21, 2019 8:44 am

Re: Circuit Playground Accelerometer Issues

by adafruit2 on Tue May 21, 2019 1:32 pm

thank you! team work makes the dream work :)

adafruit2
Site Admin
 
Posts: 18666
Joined: Fri Mar 11, 2005 7:36 pm

Please be positive and constructive with your questions and comments.