0

Chromebook issues with seeing cplayboot
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Chromebook issues with seeing cplayboot

by ColdFormed on Tue Oct 20, 2020 3:35 pm

I have been using the circuit playground and makecode for 2 years. Great success on PCs and even chromium on raspberry pi..

My current crop of 5th graders have up to date Dell chrome books and about 1/2 of the time the circuit playground will not recognize in Files. This happens for about 1/2 of my 15 kids. Also for some cplayboot will show after 3-5 disconnects then will stop showing.

Restarting chrome books sometimes fixes it for awhile. Resetting chromebook seems to always fix it for at least awhile. All of this IT support is over Zoom for me so it is not so easy to diagnose in person.

Anyone else have this issue? Have any suggestions for things I might try to sleuth out the issue?

I really love the physical computing possibilities with the CP - just trying to get over this hump with chrome!

ColdFormed
 
Posts: 3
Joined: Tue Oct 20, 2020 3:30 pm

Re: Chromebook issues with seeing cplayboot

by mikeysklar on Wed Oct 21, 2020 3:42 pm

@ColdFormed,

Since you are seeing a 50% failure rate I would suggest employing the following two strategies:

1) Maintain strict Chromebook / CPX releases
2) Order of operations for CPX connect --> Chromebook

If every Chromebook is on the same release and every CPX is running the current bootloader you can at least rule out differences in each students setup.

When attaching the CPX to the Chromebook what is the ideal time to plug it into the USB port? On power up, after MakeCode is loaded and running, later? Do the students always need to hit reset on the CPX? Figuring out the dance to get the device mounted is often related to the timing of plugging in the device and hitting reset. We have had massive forum threads on how everything breaks when the plugs are connected too slowly!

mikeysklar
 
Posts: 5504
Joined: Mon Aug 01, 2016 8:10 pm

Re: Chromebook issues with seeing cplayboot

by ColdFormed on Wed Oct 21, 2020 3:48 pm

Thanks for the tips. I will see if I can figure out the order of operations that provides success and failure.

I am somewhat relieved to know others have faced this challenge, so at least I am not totally alone in my struggles.

ColdFormed
 
Posts: 3
Joined: Tue Oct 20, 2020 3:30 pm

Re: Chromebook issues with seeing cplayboot

by aelesher on Fri Oct 30, 2020 4:02 pm

I taught online summer school and the CPX downloaded perfectly on Chromebooks Hewelett Packard. I have been teaching lessons this month with the CPX and they ONLY work on the Dell Chromebook and laptops. The majority of students in our district have been issued HP Chromebooks. Can you help?

aelesher
 
Posts: 2
Joined: Fri Oct 30, 2020 3:58 pm

Re: Chromebook issues with seeing cplayboot

by mikeysklar on Fri Oct 30, 2020 4:29 pm

@aelesher,

Please start a new thread and provide the details of the CPX bootloader, coding environment (arduino, CPX or MakeCode) along with specifics of the Dell Chromebook release versions that are not working. Do not respond again on this thread.

mikeysklar
 
Posts: 5504
Joined: Mon Aug 01, 2016 8:10 pm

Re: Chromebook issues with seeing cplayboot

by MrsBrabant on Fri Nov 06, 2020 11:56 am

HI there! I am a middle school engineering teacher who is teaching remotely. My students are currently getting started with the Adafruit Circuit Playground Express at home. They are using their own devices - Windows, Mac, Chromebook. My Chromebook students had issues seeing CPLAYBOOT and getting programs to download to their Adafruit CPX from their Chromebook device. These 2 things seemed to solve 98% of the problems.
1. Restart the Chromebook
2. Install this Chromebook App from Code.org:
https://chrome.google.com/webstore/detail/codeorg-serial-connector/ncmmhcpckfejllekofcacodljhdhibkg?hl=en
It will run in the background. I don't know the "magic" behind it, but this seems to help my Ss get connected. There was lots of cheering over Zoom when we figured this out.
I hop this helps you!

MrsBrabant
 
Posts: 1
Joined: Fri Nov 06, 2020 11:51 am

Re: Chromebook issues with seeing cplayboot

by mikeysklar on Sun Nov 08, 2020 12:40 pm

Thank you for the suggestion. Really glad this worked for your Chromebook mount issues.

mikeysklar
 
Posts: 5504
Joined: Mon Aug 01, 2016 8:10 pm

Please be positive and constructive with your questions and comments.