0

HARDWARE/WRITING ISSUES WITH GEMMA M0
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: HARDWARE/WRITING ISSUES WITH GEMMA M0

by adafruit2 on Mon Mar 15, 2021 10:13 pm

@steamtruck hiya - please let us know if we can help debug more - also another thing that could help is if you know anything about the chromebook. I wonder if some 'book models are not working (then we could at least try to replicate the issue!)

also if you can post a photo of what the wiring looks like - then we could check that the strip is connected the right way. of course sometimes the strips have the wires flipped around!

adafruit2
Site Admin
 
Posts: 20100
Joined: Fri Mar 11, 2005 7:36 pm

Re: HARDWARE/WRITING ISSUES WITH GEMMA M0

by steamtruck on Tue Mar 16, 2021 3:17 pm

led_strips_13_gemma.jpg
led_strips_13_gemma.jpg (81.08 KiB) Viewed 3367 times

This is the example image shared in the instructions for the students (though they are mechanically connecting the LED wires via your bolt kit). We pre-stripped and labeled the wires for the students, confirming beforehand that the labeled end was the correct for data transfer. If the wrong end had been connected, would it even be possible for one LED to light?

I can ask our staff to determine the chromebook model/s the students have, but this may vary, depending on what the school issued to them.

steamtruck
 
Posts: 12
Joined: Wed Dec 30, 2020 1:50 pm

Re: HARDWARE/WRITING ISSUES WITH GEMMA M0

by adafruit2 on Tue Mar 16, 2021 5:16 pm

thanks, that does look good. i think there's two issues - one is the 'delay in getting into the bootloader' and one is the 'LEDs dont light up'
for the 'LEDs don't light up' theres a risk they didnt tighten the bolts or they miswired, even with 'foolproof' instructions ... foolishness can occur :)
if ya can find a student that has one of these issues and can come by, we could have them attempt a few things!

adafruit2
Site Admin
 
Posts: 20100
Joined: Fri Mar 11, 2005 7:36 pm

Re: HARDWARE/WRITING ISSUES WITH GEMMA M0

by steamtruck on Tue Mar 16, 2021 6:37 pm

Thanks for the reply! We would definitely be interested in the troubleshooting steps we might have the students try.
I will pass along the feedback about double checking the bolted connections; we may go with alligator clips moving forward to see if that streamlines things.

Any thoughts on the 'delay getting into the bootloader'? I experienced this in testing with a chromebook but it resolved when I switched to different USB ports....

steamtruck
 
Posts: 12
Joined: Wed Dec 30, 2020 1:50 pm

Re: HARDWARE/WRITING ISSUES WITH GEMMA M0

by adafruit2 on Tue Mar 16, 2021 7:35 pm

we havent heard that one on chromebook. odd because it works, just takes a while.
if they try different USB ports or different USB cables, does it help?

adafruit2
Site Admin
 
Posts: 20100
Joined: Fri Mar 11, 2005 7:36 pm

Re: HARDWARE/WRITING ISSUES WITH GEMMA M0

by steamtruck on Tue Mar 16, 2021 8:16 pm

it worked for me testing before we rolled out to our staff; but not hearing that it's working as well in the field with students.

Are there specific strategies (as referenced) you would recommend for students experiencing the 'LEDs don't light up' that we could try??

steamtruck
 
Posts: 12
Joined: Wed Dec 30, 2020 1:50 pm

Re: HARDWARE/WRITING ISSUES WITH GEMMA M0

by adafruit2 on Tue Mar 16, 2021 10:21 pm

are you using makecode or circuitpython?

adafruit2
Site Admin
 
Posts: 20100
Joined: Fri Mar 11, 2005 7:36 pm

Re: HARDWARE/WRITING ISSUES WITH GEMMA M0

by steamtruck on Wed Mar 17, 2021 9:20 am

makecode. The code the students are using in posted earlier in this thread.

steamtruck
 
Posts: 12
Joined: Wed Dec 30, 2020 1:50 pm

Re: HARDWARE/WRITING ISSUES WITH GEMMA M0

by adafruit2 on Wed Mar 17, 2021 11:09 am

what if you distribute a UF2 that makes the onboard RGB LED twinkle/light that way you could at least tell if its an external neopixel issue :)

adafruit2
Site Admin
 
Posts: 20100
Joined: Fri Mar 11, 2005 7:36 pm

Re: HARDWARE/WRITING ISSUES WITH GEMMA M0

by kevinjwalters on Sat Mar 20, 2021 11:08 am

This is probably too simple but the code mentioned in this thread was Set Strip to WS2812 stip on D0 with 120 pixels but that photo shows wires going to D1, not D0.

kevinjwalters
 
Posts: 963
Joined: Sun Oct 01, 2017 3:15 pm

Please be positive and constructive with your questions and comments.