0

[SOLVED] BLACK Wireless + DHT22 = not working...again?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

[SOLVED] BLACK Wireless + DHT22 = not working...again?

by Gorghino on Wed Mar 08, 2017 12:00 pm

Hi everyone. New board here. a brand new Beaglebone BLACK Wireless this time.

I expected no problem with this board, but I spoke too soon.

Same scenario (viewtopic.php?f=49&t=111784&p=559590#p559590): AM2302 (dht22), plugged with 5V and GND and data to P8_11

Image on SD card: bone-debian-8.7-iot-armhf-2017-03-07-4gb.img
uname -a: Linux beaglebone 4.4.52-ti-r91 #1 SMP Fri Mar 3 22:39:33 UTC 2017 armv7l GNU/Linux
/boot/uEnv.txt: http://pastebin.com/LDmCRvZj
/uEnv.txt : http://pastebin.com/WPL3DaXj
Boot: http://pastebin.com/egq1k0DX
Dmesg: http://pastebin.com/6AAz6Byj

The cape is loaded:

Code: Select all | TOGGLE FULL SIZE
debian@beaglebone:~$ cat /sys/devices/platform/bone_capemgr/slots
 0: PF----  -1
 1: PF----  -1
 2: PF----  -1
 3: PF----  -1
 4: P-O-L-   0 Override Board Name,00A0,Override Manuf,cape-universaln


I can query the gpio:

Code: Select all | TOGGLE FULL SIZE
debian@beaglebone:~$ config-pin -q p8.11
P8_11 Mode: default Direction: in Value: 0


I tried also to:
- Decomment dtb=am335x-boneblack-hdmi-overlay.dtb (it boots but no gpio response)
- Decomment dtb=am335x-boneblack-wl1835mod.dtb (doesn't load wifi)

- Put
enable_uboot_overlays=1
disable_uboot_overlay_video=1
(it boots but no gpio response)

What's the problem this time? :/

Thank you!
Last edited by Gorghino on Thu Mar 09, 2017 1:22 pm, edited 1 time in total.

Gorghino
 
Posts: 8
Joined: Mon Feb 13, 2017 11:42 am

Re: BLACK Wireless + DHT22 = not working...again?

by drewfustini on Wed Mar 08, 2017 5:42 pm

What error message do you get when reading the DHT22 sensor?

drewfustini
 
Posts: 623
Joined: Sat Dec 26, 2015 1:19 pm

Re: BLACK Wireless + DHT22 = not working...again?

by Gorghino on Thu Mar 09, 2017 12:51 pm

False alarm.
This type it was the sensor's fault: It is dead :/
With a new DHT22, it works. Lucky me.

Gorghino
 
Posts: 8
Joined: Mon Feb 13, 2017 11:42 am

Re: [SOLVED] BLACK Wireless + DHT22 = not working...again?

by drewfustini on Thu Mar 09, 2017 2:05 pm

Thanks for following up.

drewfustini
 
Posts: 623
Joined: Sat Dec 26, 2015 1:19 pm

Please be positive and constructive with your questions and comments.