0

BeagleBoneBlack Enable USB WFI on boot
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

BeagleBoneBlack Enable USB WFI on boot

by elcuartomago on Sun Jul 11, 2021 6:14 pm

Hi all.
Apologies if this has already been asked/answered. I cannot seem to find an answer after MUCH googling and searching.
I just upgraded my BBB to buster using the iot image.

Everything good so far with one exception.

After a boot/reboot, the (ourlink) wifi stick in the USB is off. An ifconfig shows that wlan0 has no assignment. All I have to do it unplug the wifi stick and plug it back in to get the 'green light'. After that, ifconfig shows wlan0 has the correct assignment and I can then access the BBB over wireless.

My question is what must I configure and how so as to eliminate the unplug/plug step? I want to be able to reboot remotely w/o having to re-seat the USB wifi.

Thanks in advance.

elcuartomago
 
Posts: 1
Joined: Sun Jul 11, 2021 5:57 pm

Re: BeagleBoneBlack Enable USB WFI on boot

by adafruit_support_mike on Tue Jul 13, 2021 11:07 pm

Check your file tree to see if there's a file named /etc/rc.local

If so, that should execute toward the end of the boot process, and provides space for modifications specific to that machine. You can write a shell script that brings up the Wifi connection and execute it from /etc/rc.local

adafruit_support_mike
 
Posts: 63716
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.