Adafruit Industries, Essential service and business: NYC – Executive Order 202.6 - Read more.
0

Cloud9 IDE doesn't find worker.js and hangs
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Cloud9 IDE doesn't find worker.js and hangs

by dgruv1 on Tue Aug 16, 2016 4:42 pm

After powering up my BBB after 6 months of inactivity I wanted to edit some files in cloud9 IDE and found the splash screen comes up for Cloud9 but nothing else happens - C9 just hangs there ( Loading your workspace ... is displayed forever). Googled around and found various issues with the directory /var/lib/cloud9 missing (mine is present), the C9 cloud9.service and cloud9.socket not enabled (mine is), etc. Looked thru other hits on forums and nothing seemed to match my issue. The SSH service at 192.168.7.2 works fine and I can see all the BBB webpages. The examples for the flashing LEDs works. Everything else seems to work but the C9 IDE functionality disappeared. At the point of trying the latest Debian Jessie when I started looking at the debug output of Firefox and found a reference to http://192.168.7.2:3000/static/lib/ace/ ... /worker.js that it can't find (404 error). Using find -name w*.js -print I don't see a hit (I was in root/). Can't even tell if I'm on the right track here. Any help would be appreciated.

dgruv1
 
Posts: 6
Joined: Tue Aug 16, 2016 4:19 pm

Re: Cloud9 IDE doesn't find worker.js and hangs

by drewfustini on Thu Aug 18, 2016 5:25 am

Please paste the output of:

uname -a

cat /etc/debian_version

cat /etc/dogtag

dpkg -l c9-core-installer

dpkg -L c9-core-installer

systemctl status cloud9


On my BeagleBone running Debian 8.5 (2016-06-05) image, there is no worker.js. There is:
Code: Select all | TOGGLE FULL SIZE
debian@beaglebone:~$ find /var/lib/cloud9/ | grep js$ |grep worker
/var/lib/cloud9/static/third_party/ace/src/worker-lua.js
/var/lib/cloud9/static/third_party/ace/src/worker-php.js
/var/lib/cloud9/static/third_party/ace/src/worker-json.js
/var/lib/cloud9/static/third_party/ace/src/worker-xml.js
/var/lib/cloud9/static/third_party/ace/src/worker-html.js
/var/lib/cloud9/static/third_party/ace/src/worker-javascript.js
/var/lib/cloud9/static/third_party/ace/src/worker-xquery.js
/var/lib/cloud9/static/third_party/ace/src/worker-coffee.js
/var/lib/cloud9/static/third_party/ace/src/worker-css.js
/var/lib/cloud9/bone101/static/third_party/ace/src/worker-lua.js
/var/lib/cloud9/bone101/static/third_party/ace/src/worker-php.js
/var/lib/cloud9/bone101/static/third_party/ace/src/worker-json.js
/var/lib/cloud9/bone101/static/third_party/ace/src/worker-xml.js
/var/lib/cloud9/bone101/static/third_party/ace/src/worker-html.js
/var/lib/cloud9/bone101/static/third_party/ace/src/worker-javascript.js
/var/lib/cloud9/bone101/static/third_party/ace/src/worker-xquery.js
/var/lib/cloud9/bone101/static/third_party/ace/src/worker-coffee.js
/var/lib/cloud9/bone101/static/third_party/ace/src/worker-css.js

drewfustini
 
Posts: 920
Joined: Sat Dec 26, 2015 1:19 pm

Re: Cloud9 IDE doesn't find worker.js and hangs

by dgruv1 on Fri Aug 19, 2016 11:35 am

Here's the output of the requested commands:

root@beaglebone:~# uname -a
Linux beaglebone 3.8.13-bone80 #1 SMP Wed Jun 15 17:03:55 UTC 2016 armv7l GNU/Linux

root@beaglebone:~# cat /etc/debian_version
7.4

root@beaglebone:~# cat /etc/dogtag
BeagleBoard.org BeagleBone Debian Image 2014-04-23

root@beaglebone:~# dpkg -l c9-core-installer
dpkg-query: no packages found matching c9-core-installer
root@beaglebone:~# dpkg -L c9-core-installer
dpkg-query: package 'c9-core-installer' is not installed
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.

root@beaglebone:~# systemctl status cloud9
Failed to issue method call: Unit name cloud9 is not valid.

Thanks for your response & help.

dgruv1
 
Posts: 6
Joined: Tue Aug 16, 2016 4:19 pm

Re: Cloud9 IDE doesn't find worker.js and hangs

by dgruv1 on Fri Aug 19, 2016 11:39 am

And my version of
root@beaglebone:~# find /var/lib/cloud9/ | grep js$ |grep worker
/var/lib/cloud9/static/ajaxorg-ace-builds-c2f3abb/worker-coffee.js
/var/lib/cloud9/static/ajaxorg-ace-builds-c2f3abb/worker-javascript.js
/var/lib/cloud9/static/ajaxorg-ace-builds-c2f3abb/worker-css.js
/var/lib/cloud9/static/ajaxorg-ace-builds-c2f3abb/worker-xquery.js
/var/lib/cloud9/static/ajaxorg-ace-builds-c2f3abb/worker-json.js

dgruv1
 
Posts: 6
Joined: Tue Aug 16, 2016 4:19 pm

Re: Cloud9 IDE doesn't find worker.js and hangs

by drewfustini on Fri Aug 19, 2016 9:05 pm

If you have a spare microSD card, then please try the most recent Debian Wheezy standalone microSD card image on BeagleBoard.org:

Debian 7.11 2015-06-15 4GB SD LXDE image

If cloud9 is working correctly for you, then you can copy over any data you may need from the previous installation.

drewfustini
 
Posts: 920
Joined: Sat Dec 26, 2015 1:19 pm

Re: Cloud9 IDE doesn't find worker.js and hangs

by dgruv1 on Tue Aug 23, 2016 8:35 pm

Thanks for the help! The new Debian image is up and running and cloud9 is back. Just a matter of getting my old files and setting up my wireless.

dgruv1
 
Posts: 6
Joined: Tue Aug 16, 2016 4:19 pm

Re: Cloud9 IDE doesn't find worker.js and hangs

by dgruv1 on Mon Sep 05, 2016 12:35 pm

After getting cloud9 up and working with the latest Debian release, I followed the instructions to install the Wifi from https://learn.adafruit.com/setting-up-w ... bone-black. This went well and I had WiFi back working. I rebooted and my time got updated ~16 sec later and set the time zone with dpkg‐reconfigure tzdata. So far so good. I went to my browser and typed in 192.168.7.2 and no response. No cloud9 and no SSH access anymore. Only thing that works is the Gadget Serial (COM4). I went to my Windows7 machine's command line and pinged 192.168.7.2 and no response! Seems now I'm worse off.

Again any help would be appreciated.

dgruv1
 
Posts: 6
Joined: Tue Aug 16, 2016 4:19 pm

Re: Cloud9 IDE doesn't find worker.js and hangs

by drewfustini on Tue Sep 06, 2016 4:11 am

Is the WiFi still working? Have you tried to access the IP of the WiFi adapter?

It sounds like you have command line access via the Gadget Serial. Could you run this command and paste the output here?

systemctl

drewfustini
 
Posts: 920
Joined: Sat Dec 26, 2015 1:19 pm

Re: Cloud9 IDE doesn't find worker.js and hangs

by dgruv1 on Wed Sep 07, 2016 11:45 pm

There seems to be an issue with my Windows7 drivers. I unloaded and reloaded them to get BBB to work with the Gadget SIO and the web server as they both stopped completely. The only way to get them both to work is to unload the W7 drivers, reboot Windows, reload. I reloaded the new W7 drivers from the new OS image you gave me. Once the W7 drivers are reloaded then both parts of the USB SIO/Web Site ( http://192.168.7.2)/works. If I reboot the BBB the WS disappears and this is the systemctl after the reboot using the Gadget SIO. Some strange interaction with the Windows drivers appears to be going on. Additionally the COM port assignment keeps on changing. It started as COM4 and has moved up to COM9 (i've been thru the unload/reload process several times to try to get things to work). All ports are showing up as "in use" and unavailable but the device manager says there's only COM9 in use. Showing all the hidden devices still doesn't show the other "in use" ports.

Thanks for your patience.

Here's the dump.
root@beaglebone:~# systemctl
UNIT LOAD ACTIVE SUB JOB DESCRIPTION
proc-sys...misc.automount loaded active waiting Arbitrary Executable File
sys-devi...y-ttyO0.device loaded active plugged /sys/devices/ocp.3/44e0900
sys-devi...et-usb0.device loaded active plugged /sys/devices/ocp.3/4740000
sys-devi...-ttyGS0.device loaded active plugged /sys/devices/ocp.3/4740000
sys-devi...t-wlan0.device loaded active plugged RTL8188CUS 802.11n WLAN Ad
sys-devi...et-eth0.device loaded active plugged /sys/devices/ocp.3/4a10000
sys-devi...k1boot0.device loaded active plugged /sys/devices/ocp.3/mmc.11/
sys-devi...k1boot1.device loaded active plugged /sys/devices/ocp.3/mmc.11/
sys-devi...cblk1p1.device loaded active plugged /sys/devices/ocp.3/mmc.11/
sys-devi...cblk1p2.device loaded active plugged /sys/devices/ocp.3/mmc.11/
sys-devi...mmcblk1.device loaded active plugged /sys/devices/ocp.3/mmc.11/
sys-devi...cblk0p1.device loaded active plugged /sys/devices/ocp.3/mmc.5/m
sys-devi...mmcblk0.device loaded active plugged /sys/devices/ocp.3/mmc.5/m
sys-devi...d-card0.device loaded active plugged /sys/devices/ocp.3/sound.1
sys-devi...y-ttyS0.device loaded active plugged /sys/devices/platform/seri
sys-devi...y-ttyS1.device loaded active plugged /sys/devices/platform/seri
sys-devi...y-ttyS2.device loaded active plugged /sys/devices/platform/seri
sys-devi...y-ttyS3.device loaded active plugged /sys/devices/platform/seri
sys-devi...ty-tty0.device loaded active plugged /sys/devices/virtual/tty/t
sys-devi...ty-tty1.device loaded active plugged /sys/devices/virtual/tty/t
sys-devi...y-tty10.device loaded active plugged /sys/devices/virtual/tty/t
sys-devi...y-tty11.device loaded active plugged /sys/devices/virtual/tty/t
sys-devi...y-tty12.device loaded active plugged /sys/devices/virtual/tty/t
sys-devi...ty-tty2.device loaded active plugged /sys/devices/virtual/tty/t
sys-devi...ty-tty3.device loaded active plugged /sys/devices/virtual/tty/t
sys-devi...ty-tty4.device loaded active plugged /sys/devices/virtual/tty/t
sys-devi...ty-tty5.device loaded active plugged /sys/devices/virtual/tty/t
sys-devi...ty-tty6.device loaded active plugged /sys/devices/virtual/tty/t
sys-devi...ty-tty7.device loaded active plugged /sys/devices/virtual/tty/t
sys-devi...ty-tty8.device loaded active plugged /sys/devices/virtual/tty/t
sys-devi...ty-tty9.device loaded active plugged /sys/devices/virtual/tty/t
sys-module-fuse.device loaded active plugged /sys/module/fuse
-.mount loaded active mounted /
dev-mqueue.mount loaded active mounted POSIX Message Queue File S
media-boot.mount loaded active mounted /media/boot
media-rootfs.mount loaded active mounted /media/rootfs
run-lock.mount loaded active mounted Lock Directory
run-user.mount loaded active mounted User Runtime Directory
sys-fs-f...nections.mount loaded active mounted FUSE Control File System
sys-kernel-debug.mount loaded active mounted Debug File System
sys-kernel-security.mount loaded active mounted Security File System
systemd-...d-console.path loaded active waiting Dispatch Password Requests
systemd-...word-wall.path loaded active waiting Forward Password Requests
acpid.service loaded active running ACPI event daemon
alsa-utils.service loaded active exited LSB: Restore and store ALS
apache2.service loaded active running LSB: Start/stop apache2 we
avahi-daemon.service loaded active running Avahi mDNS/DNS-SD Stack
bonescri...utorun.service loaded active running Bonescript autorun
bonescript.service loaded active running Bonescript server
bootlogs.service loaded active exited LSB: Log file handling to
capemgr.service loaded active exited LSB: Start daemon at boot
console-...daemon.service loaded active running Console Manager
console-...-start.service loaded active exited Console System Startup Log
console-setup.service loaded active exited LSB: Set console font and
cpufrequtils.service loaded active exited LSB: set CPUFreq kernel pa
cron.service loaded active running LSB: Regular background pr
dbus.service loaded active running D-Bus System Message Bus
generic-...script.service loaded active exited LSB: Start daemon at boot
getty@tty1.service loaded active running Getty on tty1
hdparm.service loaded active exited LSB: Tune IDE hard disks
hostapd.service loaded active exited LSB: Advanced IEEE 802.11
ifup@eth0.service loaded active exited ifup for eth0
ifup@usb0.service loaded active exited ifup for usb0
ifup@wlan0.service loaded active exited ifup for wlan0
jekyll-autorun.service loaded active running jekyll autorun
kbd.service loaded active exited LSB: Prepare console
keyboard-setup.service loaded active exited LSB: Set preliminary keyma
lightdm.service loaded active running LSB: Light Display Manager
loadcpufreq.service loaded active exited LSB: Load kernel modules n
motd.service loaded active exited LSB: Create dynamic part o
networking.service loaded active exited LSB: Raise network interfa
polkitd.service loaded active running Authenticate and Authorize
pppd-dns.service loaded active exited LSB: Restore resolv.conf i
rc.local.service loaded active exited LSB: Run /etc/rc.local if
remount-rootfs.service loaded active exited Remount Root FS
rsyslog.service loaded active running System Logging Service
saned.service loaded active exited LSB: SANE network scanner
screen-cleanup.service loaded active exited LSB: screen sessions clean
serial-g...ttyGS0.service loaded active running Serial Getty on ttyGS0
serial-g...@ttyO0.service loaded active running Serial Getty on ttyO0
ssh.service loaded active running LSB: OpenBSD Secure Shell
systemd-journald.service loaded active running Journal Service
systemd-logind.service loaded active running Login Service
systemd-...s-load.service loaded active exited Load Kernel Modules
systemd-...pi-vfs.service loaded active exited Remount API VFS
systemd-sysctl.service loaded active exited Apply Kernel Variables
systemd-...-setup.service loaded active exited Recreate Volatile Files an
systemd-...ssions.service loaded active exited Permit User Sessions
udev-trigger.service loaded active exited udev Coldplug all Devices
udev.service loaded active running udev Kernel Device Manager
udhcpd.service loaded active exited LSB: Start busybox udhcpd
udisks.service loaded active running Storage Daemon
upower.service loaded active running Daemon for power managemen
wicd.service loaded active running LSB: Starts and stops Wicd
wpa_supplicant.service loaded active running WPA supplicant
xrdp.service loaded active running LSB: Start xrdp and sesman
acpid.socket loaded active listening ACPID Listen Socket
avahi-daemon.socket loaded active listening Avahi mDNS/DNS-SD Stack Ac
bonescript.socket loaded active running bonescript.socket
cloud9.socket loaded active listening cloud9.socket
dbus.socket loaded active running D-Bus System Message Bus S
syslog.socket loaded active running Syslog Socket
systemd-initctl.socket loaded active listening /dev/initctl Compatibility
systemd-journald.socket loaded active running Journal Socket
systemd-shutdownd.socket loaded active listening Delayed Shutdown Socket
udev-control.socket loaded active listening udev Control Socket
udev-kernel.socket loaded active running udev Kernel Socket
basic.target loaded active active Basic System
cryptsetup.target loaded active active Encrypted Volumes
getty.target loaded active active Login Prompts
graphical.target loaded active active Graphical Interface
local-fs-pre.target loaded active active Local File Systems (Pre)
local-fs.target loaded active active Local File Systems
multi-user.target loaded active active Multi-User
remote-fs.target loaded active active Remote File Systems
sockets.target loaded active active Sockets
sound.target loaded active active Sound Card
swap.target loaded active active Swap
sysinit.target loaded active active System Initialization
syslog.target loaded active active Syslog
systemd-...es-clean.timer loaded active waiting Daily Cleanup of Temporary

LOAD = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB = The low-level unit activation state, values depend on unit type.
JOB = Pending job for the unit.

121 units listed. Pass --all to see inactive units, too.
(END)

dgruv1
 
Posts: 6
Joined: Tue Aug 16, 2016 4:19 pm

Re: Cloud9 IDE doesn't find worker.js and hangs

by drewfustini on Fri Sep 09, 2016 4:38 am

I've not encountered this issue before, but I'd suggest posting this on the BeagleBoard google group, which is the mailing list for BeagleBone and BeagleBoard:
https://groups.google.com/forum/#!forum/beagleboard

Hopefully someone has run into this issue too and determined the solution.

drewfustini
 
Posts: 920
Joined: Sat Dec 26, 2015 1:19 pm

Please be positive and constructive with your questions and comments.