Black Lives Matter - Action and Equality. ... Adafruit joins the Stop Hate for Profit campaign.
0

how to upgrade nodejs version on debian
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

how to upgrade nodejs version on debian

by Juu on Thu Aug 18, 2016 11:24 am

Hello,
I need to use the NFC sensor on adafruit pn532 purchased for use with the uart interface in nodejs.
I have to go through the following library ( https://www.npmjs.com/package/pn532 ) .
However it requires a version of nodejs using ecma6 therefore node> 4.0 or not to use the module "n" I used my usual , no binary packages are , or the build by sources .

Thank you for your help and good day

Juu
 
Posts: 18
Joined: Wed Apr 27, 2016 6:19 am

Re: how to upgrade nodejs version on debian

by drewfustini on Thu Aug 18, 2016 3:46 pm

I'd like to know what system software you have. Please post the output of:

uname -a

cat /etc/debian_version

cat /etc/dogtag


You may want to try the latest Debian 8.5 image:
http://elinux.org/Beagleboard:BeagleBon ... e_Green.29

drewfustini
 
Posts: 928
Joined: Sat Dec 26, 2015 1:19 pm

Re: how to upgrade nodejs version on debian

by Juu on Fri Aug 19, 2016 3:58 am

drewfustini wrote:I'd like to know what system software you have. Please post the output of:

uname -a

cat /etc/debian_version

cat /etc/dogtag


You may want to try the latest Debian 8.5 image:
http://elinux.org/Beagleboard:BeagleBon ... e_Green.29



Hello,
Here are the results of commands that you asked me , I have to use the old version of debian because of it is that you advised me to use to run my screen.
(viewtopic.php?f=49&t=95309&p=509376#p509376)

root@beaglebone:/var/lib/cloud9# uname -a
Linux beaglebone 3.8.13-bone50 #1 SMP Tue May 13 13:24:52 UTC 2014 armv7l GNU/Linux
root@beaglebone:/var/lib/cloud9# cat /etc/debian_version
7.5
root@beaglebone:/var/lib/cloud9# cat /etc/dogtag
BeagleBoard.org BeagleBone Debian Image 2014-05-14

Juu
 
Posts: 18
Joined: Wed Apr 27, 2016 6:19 am

Re: how to upgrade nodejs version on debian

by drewfustini on Sat Aug 20, 2016 6:25 am

Ah, yes, that is a tricky one since we are on a pretty old image where fbtft works with that 2.8" LCD display [PID 2009].

I'm hoping the solution here would be to go to a newer image. However, I'm still trying to work out problem with fbtft and that LCD on newer images: Debian 7.11 (2016-06-15) with 4.1.29-bone22

I just a posted a question to notro, who is the creatot of fbtft:
https://github.com/notro/fbtft/issues/400

Hopefully he will have some advice.

drewfustini
 
Posts: 928
Joined: Sat Dec 26, 2015 1:19 pm

Re: how to upgrade nodejs version on debian

by Juu on Fri Aug 26, 2016 5:33 am

drewfustini wrote:Ah, yes, that is a tricky one since we are on a pretty old image where fbtft works with that 2.8" LCD display [PID 2009].

I'm hoping the solution here would be to go to a newer image. However, I'm still trying to work out problem with fbtft and that LCD on newer images: Debian 7.11 (2016-06-15) with 4.1.29-bone22

I just a posted a question to notro, who is the creatot of fbtft:
https://github.com/notro/fbtft/issues/400

Hopefully he will have some advice.



Hi ,
I'm now triying to build fbtft driver for the last debian image .
Can you give me any advice or link that i can follow?
Thanks for all

Juu
 
Posts: 18
Joined: Wed Apr 27, 2016 6:19 am

Re: how to upgrade nodejs version on debian

by drewfustini on Fri Aug 26, 2016 11:37 pm

You don't need to build fbtft as it is included in the 4.1+ kernels.

However, I've noticed a problem wherein the SPI1 ends up as /dev/spidev2.x instead of /dev/spidev1.x. This seems to prevent fbtft from working. I'm still investigating the issue.

Linux 4.1.14-bone17 is OK. Linux 4.4.15-bone11 is not. I'm trying to determine the difference.

My notes so far:
https://gist.github.com/pdp7/df367e27d9 ... 6b91328b06

drewfustini
 
Posts: 928
Joined: Sat Dec 26, 2015 1:19 pm

Re: how to upgrade nodejs version on debian

by Juu on Sat Aug 27, 2016 4:58 am

drewfustini wrote:You don't need to build fbtft as it is included in the 4.1+ kernels.

However, I've noticed a problem wherein the SPI1 ends up as /dev/spidev2.x instead of /dev/spidev1.x. This seems to prevent fbtft from working. I'm still investigating the issue.

Linux 4.1.14-bone17 is OK. Linux 4.4.15-bone11 is not. I'm trying to determine the difference.

My notes so far:
https://gist.github.com/pdp7/df367e27d9 ... 6b91328b06



OK j'ai lu tes notes et si j'ai bien compris tu arrives à faire fonctionner l'écran avec la version Linux 4.1.14-bone17 ?
avec ce linux as tu la version 4.8 de gcc ?
j'ai juste besoin de ça pour mon projet.

Regards

Juu
 
Posts: 18
Joined: Wed Apr 27, 2016 6:19 am

Re: how to upgrade nodejs version on debian

by drewfustini on Sat Aug 27, 2016 6:12 am

The different kernels are available as Debian packages so you don't need to compile. To list the options:

sudo apt-cache search linux-image

drewfustini
 
Posts: 928
Joined: Sat Dec 26, 2015 1:19 pm

Please be positive and constructive with your questions and comments.