Adafruit Industries, Essential service and business: NYC – Executive Order 202.6 - Read more.
0

Monochrome 1.3" 128x64 OLED graphic display bad visualizatio
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Monochrome 1.3" 128x64 OLED graphic display bad visualizatio

by a_power on Tue Sep 06, 2016 4:40 am

Dear all,
I am having some problems with the OLED screen used with a Beaglebone Black.
I have correctly followed the guide https://learn.adafruit.com/ssd1306-oled ... k/overview to wire and install everything on a Beaglebone booted by the flash (the result of uname -a is Linux beaglebone 3.8.13-bone47 #1 SMP Fri Apr 11 01:36:09 UTC 2014 armv7l GNU/Linux). When I try to run the shapes.py example, it works corretly.
Then I tried to boot the Beaglebone from SD card with another S.O. (uname -a is Linux gammastream 4.1.10-bone16 #1 Fri Oct 30 13:11:48 CET 2015 armv7l GNU/Linux), with the same hardware setup (same Beaglebone Black, same wiring) and with everything installed correctly. When I try to run the shapes.py example, I obtain the image attached. It looks like on the top-left corner there is something coming from the shape.py script, but as you can see, there is something wrong on the remaining part of the screen.
Do you have any idea about why it works like this? Is there a problem with the distribution on the SD card?
If you need more informations, just ask.
Thanks for your help.
Regards.
Alberto
Attachments
20160906_102332.jpg
20160906_102332.jpg (564.02 KiB) Viewed 269 times

a_power
 
Posts: 13
Joined: Mon Jun 22, 2015 7:01 am

Re: Monochrome 1.3" 128x64 OLED graphic display bad visualiz

by drewfustini on Wed Sep 07, 2016 12:03 am

#1 The solder joint for the GND pad seems have too much solder and is danger of coming into contact with Vin. You may want to clean up the excess solder with desoldering braid to ensure those pins don't get bridged.

#2 Please post a photo of how the display is wired to your BeagleBone

#3 Please try the latest image for Debian 7 (Wheezy) image: Debian 7.11 2015-06-15 4GB SD LXDE image

drewfustini
 
Posts: 920
Joined: Sat Dec 26, 2015 1:19 pm

Please be positive and constructive with your questions and comments.