0

Getting errors deploying device tree overlays to Beaglebone
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Getting errors deploying device tree overlays to Beaglebone

by pransome on Sun Sep 18, 2016 9:07 pm

I am working on learning how to use device tree overlays in my Beaglebone Black.

The Linux version is:
Linux version 4.1.18-ti-r52 (root@b1-omap5-uevm-2gb) (gcc version 4.9.2 (Debian 4.9.2-10) ) #1 SMP Thu Mar 10 00:41:28 UTC 2016

I am following the example at
https://github.com/jadonk/validation-sc ... /README.md. I have also worked through the examples in Derek Molloys' Exploring BeagleBone Black book chapter 6. In both of those cases I am running into the same errors when I deploy the overlay. The overlay appears to deploy properly, no errors are given when doing echo <overlay base name> > $SLOTS but when I look at the kernel messages using dmesg I get errors like what is shown below. What is shown below is from following the jadonk example.


[ 1053.452639] bone_capemgr bone_capemgr: Using override eeprom data at slot 5
[ 1053.452664] bone_capemgr bone_capemgr: slot #5: 'Override Board Name,00A0,Override Manuf,pinctrl-test-7'
[ 1053.455556] pinctrl-single 44e10800.pinmux: pin 44e10964.0 already requested by ocp:P9_42_pinmux; cannot claim for ocp:helper
[ 1053.467142] pinctrl-single 44e10800.pinmux: pin-89 (ocp:helper) status -22
[ 1053.474093] pinctrl-single 44e10800.pinmux: could not request pin 89 (44e10964.0) from group pinctrl_test_7_pins on device pinctrl-single
[ 1053.486626] bone-pinmux-helper ocp:helper: Error applying setting, reverse things back
[ 1053.495157] pinctrl-single 44e10800.pinmux: pin 44e10964.0 already requested by ocp:P9_42_pinmux; cannot claim for ocp:helper
[ 1053.506627] pinctrl-single 44e10800.pinmux: pin-89 (ocp:helper) status -22
[ 1053.513582] pinctrl-single 44e10800.pinmux: could not request pin 89 (44e10964.0) from group pinctrl_test_7_pins on device pinctrl-single
[ 1053.526118] bone-pinmux-helper ocp:helper: Error applying setting, reverse things back
[ 1053.534109] bone-pinmux-helper ocp:helper: Failed to select default state


Before deploy I see:
root@beaglebone:/lib/firmware# cat $SLOTS
0: PF---- -1
1: PF---- -1
2: PF---- -1
3: PF---- -1
4: P-O-L- 0 Override Board Name,00A0,Override Manuf,cape-universaln

After deploy I see:
root@beaglebone:/lib/firmware# cat $SLOTS
0: PF---- -1
1: PF---- -1
2: PF---- -1
3: PF---- -1
4: P-O-L- 0 Override Board Name,00A0,Override Manuf,cape-universaln
5: P-O-L- 1 Override Board Name,00A0,Override Manuf,pinctrl-test-7

But dmesg shows the errors above.

Can you suggest what might be happening and/or how I might troubleshoot the problem?
Thanks.

pransome
 
Posts: 3
Joined: Wed Jun 27, 2012 9:53 am

Re: Getting errors deploying device tree overlays to Beagleb

by drewfustini on Mon Sep 19, 2016 2:54 am

I think the issue is that cape-universal is loaded. This tends to conflict with loading additional overlays.

beaglebone-universal-io
Device tree overlay and support scripts for using most available hardware I/O on the BeagleBone without editing dts files or rebuilding the kernel


Here is some history from Robert C. Nelson who maintains the Debian images for BeagleBone: cape-universal & 4.1.x = default

I'd suggest either:

1) Using config-pin utility (which leverages of cape-universal) instead of a device tree overlay to achieve the desired pin muxing

2) Disable cape-universal in /boot/uEnv.txt and use the device tree overlay that you've created

drewfustini
 
Posts: 695
Joined: Sat Dec 26, 2015 1:19 pm

Re: Getting errors deploying device tree overlays to Beagleb

by pransome on Mon Sep 19, 2016 5:55 am

Thank you drewfustini for the two suggested actions and the links to their background information. They look good. I'll try them out.

pransome
 
Posts: 3
Joined: Wed Jun 27, 2012 9:53 am

Re: Getting errors deploying device tree overlays to Beagleb

by pransome on Tue Sep 20, 2016 9:57 pm

I read the material at https://github.com/cdsteinkuehler/beaglebone-universal-io as suggested and experimented with config-pin and with using the capabilities provided by the cape-universaln overlay. Works great! Thanks.

pransome
 
Posts: 3
Joined: Wed Jun 27, 2012 9:53 am

Re: Getting errors deploying device tree overlays to Beagleb

by drewfustini on Thu Sep 22, 2016 12:21 am

Good to hear!

drewfustini
 
Posts: 695
Joined: Sat Dec 26, 2015 1:19 pm

Please be positive and constructive with your questions and comments.