0

All PWM Pins use issue in BeagleBone Black
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

All PWM Pins use issue in BeagleBone Black

by OnkarKulkarni on Sat Oct 21, 2017 8:21 am

Hello,
I am using BeagleBone Black with Debian image 2014-04-23.
I want to use all 14 (or at least 8) PWM pins of it at a time to run servo motors.
But I am able to generate PWM signal on only 4 pins at a time .
Please find details of pins as below,
Working Pins
p8 13
p9 14
p9 21
p9 42

Not Working Pins
p8 46
p8 36
p9 29
p9 28
p8 45
p8 34
p9 22 start channel error
p9 31 spike response
p9 16 start channel error
p8 19 start channel error

I am using Adafruit_BBIO.PWM library and Python scripting.
Could you please help me in this.

OnkarKulkarni
 
Posts: 1
Joined: Sat Oct 21, 2017 8:10 am

Re: All PWM Pins use issue in BeagleBone Black

by drewfustini on Tue Oct 24, 2017 12:17 am

Hello, there are 8 PWM outputs on the BeagleBone Black. Here are the PWM outputs and the pins they are available on:
Code: Select all | TOGGLE FULL SIZE
EHRPWM0A: P9.22,P9.31
EHRPWM0B: P9.21,P9.29
ECAPPWM0: P9.42
EHRPWM1A: P9.14,P8.36
EHRPWM1B: P9.16,P8.34
EHRPWM2A: P8.19,P8.45
EHRPWM2B: P8.13,P8.46
ECAPPWM2: P9.28

The Debian image you are using is quite old.

I would recommend downloading the current image on BeagleBoard.org such as the Stretch IoT (non-GUI) for BeagleBone

drewfustini
 
Posts: 944
Joined: Sat Dec 26, 2015 1:19 pm

Please be positive and constructive with your questions and comments.