Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Beagle bone Black - UART issue
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Beagle bone Black - UART issue

by suil0109 on Tue Aug 07, 2018 8:52 pm

Hey guys, I'm using Beaglebone Black with Angstrom not debian.

I follow this website
https://learn.adafruit.com/setting-up-i ... black/uart

when I run "minicom -b 9600 -D /dev/ttyO1" as stated on the website
I get "cannot create lock file for /dev/ttyO1: Operation not permitted"

I looked into /dev folder, there is no ttyO1. There should be ttyO1-5.
I have tty* instead.

If i type "minicom 'b 9600 /dev/tty1", a window pops up as it supposed to. But it doesn't give the the output "hello world!". I can't even type anything in the minicom window


How do I solve this problem? pleseeeee :)

suil0109
 
Posts: 1
Joined: Tue Aug 07, 2018 8:33 pm

Re: Beagle bone Black - UART issue

by drewfustini on Thu Aug 16, 2018 1:09 am

Hello, I would strongly recommend you switch to Debian as Angstrom is no longer supported. I would recommend trying the latest Debian image on BeagleBoard.org:

Stretch IoT (without graphical desktop) for BeagleBone and PocketBeagle via microSD card
Debian 9.4 2018-06-17 4GB SD IoT image

Once you have booted from the Debian image, it is important to know how the system software on your BeagleBone is configured. In particular, there will be problems with device tree overlays if the version of the u-boot bootloader on the eMMC is too old.

Please paste the output of this command:
Code: Select all | TOGGLE FULL SIZE
sudo /opt/scripts/tools/version.sh

drewfustini
 
Posts: 941
Joined: Sat Dec 26, 2015 1:19 pm

Please be positive and constructive with your questions and comments.