0

Pi Noir: mmal: mmal_vc_component_enable: failed to enable co
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/
Please be positive and constructive with your questions and comments.

Pi Noir: mmal: mmal_vc_component_enable: failed to enable co

by mpechner on Wed Aug 08, 2018 12:41 pm

Raspberry Pi NoIR Camera Board v2 - 8 Megapixels PID: 3100
I ordered both the standard and the IR Pi camera

The standard camera works like a champ. Sample images:
https://github.com/mpechner/Security-Ca ... les-Images

I tripled check the cable connection. Increased the GPU memory. Moved 1 wire to pin 18. Made sure the rpi-update was run, as well as dist-update.

Again, the standard camera is working.
I am wondering if the camera is bad.

Also tried a different Pi. Again standard works, IR does not.

Code: Select all | TOGGLE FULL SIZE
pi@raspberrypi:~ $ sudo raspistill -v -o x.jpg

raspistill Camera App v1.3.11



Width 3280, Height 2464, quality 85, filename x.jpg

Time delay 5000, Raw no

Thumbnail enabled Yes, width 64, height 48, quality 35

Link to latest frame enabled  no

Full resolution preview No

Capture method : Single capture



Preview Yes, Full screen Yes

Preview window 0,0,1024,768

Opacity 255

Sharpness 0, Contrast 0, Brightness 50

Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0

Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'

Flicker Avoid Mode 'off'

Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128

Rotation 0, hflip No, vflip No

ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000

mmal: mmal_vc_component_enable: failed to enable component: ENOSPC

mmal: camera component couldn't be enabled

mmal: main: Failed to create camera component

mmal: Failed to run camera app. Please check for firmware updates
mpechner
 
Posts: 19
Joined: Mon Sep 22, 2008 10:57 am

Re: Pi Noir: mmal: mmal_vc_component_enable: failed to enabl

by adafruit_support_carter on Thu Aug 09, 2018 1:10 pm

Moved 1 wire to pin 18.

What did you do here? Is this the onewire communication protocol, or like a physical wire?

Made sure the rpi-update was run,

Don't run rpi-update. It can break things. But your regular camera is still working, so this doesn't seem like the issue.

Check the little sunny connector on the camera module itself to see if it's solidly connected:
rpi_camera_sunny.jpg
rpi_camera_sunny.jpg (36.31 KiB) Viewed 83 times

It just pops up with a fingernail and can be pressed back down.

adafruit_support_carter
 
Posts: 5907
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pi Noir: mmal: mmal_vc_component_enable: failed to enabl

by mpechner on Thu Aug 09, 2018 2:02 pm

Moved 1 wire to pin 18. - was trying thing from another post.

rpi-update - seeing posts that say run this. Run the standard dist-upgrade. Post that say don't do one or the other. Very confusing. Glad the systems I support professionally I do not have this dichotomy how to update the OS.

That connector is on solid. Are you suggesting I reseat?
mpechner
 
Posts: 19
Joined: Mon Sep 22, 2008 10:57 am

Re: Pi Noir: mmal: mmal_vc_component_enable: failed to enabl

by adafruit_support_carter on Thu Aug 09, 2018 2:58 pm

rpi-update - seeing posts that say run this

It's an unfortunate historical leftover from early days of Pi. Now, all that is needed is:
Code: Select all | TOGGLE FULL SIZE
sudo apt-get update
sudo apt-get upgrade


Are you suggesting I reseat?

Probably won't help, but try that. It at least let's you know it got well seated.

adafruit_support_carter
 
Posts: 5907
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pi Noir: mmal: mmal_vc_component_enable: failed to enabl

by mpechner on Thu Aug 09, 2018 10:33 pm

ran
sudo apt-get update
sudo apt-get upgrade

reseated the connector.

Still:
Code: Select all | TOGGLE FULL SIZE
root@raspberrypi:~# raspistill -v -o xx.jpg

raspistill Camera App v1.3.11

Width 3280, Height 2464, quality 85, filename xx.jpg
Time delay 5000, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Link to latest frame enabled  no
Full resolution preview No
Capture method : Single capture

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Flicker Avoid Mode 'off'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates 
mpechner
 
Posts: 19
Joined: Mon Sep 22, 2008 10:57 am

Re: Pi Noir: mmal: mmal_vc_component_enable: failed to enabl

by mpechner on Thu Aug 09, 2018 10:51 pm

I am starting with a fresh copy of 2018-04-18-raspbian-stretch.img just in case.
Also, even though the 2 cameras are supposed to be the same with the exception of the filter, they are not.
The PCB colors are different. The X1 chip are 2 different parts. One is a can, one just standard black packaging.
They are both marked as version 2.1 of the camera.
mpechner
 
Posts: 19
Joined: Mon Sep 22, 2008 10:57 am

Re: Pi Noir: mmal: mmal_vc_component_enable: failed to enabl

by mpechner on Fri Aug 10, 2018 12:21 am

I went through the effort of building a new image.
raspistill -v -o xx.jpg ...
- first boot
- after running raspi-config to turn on the camera, ssh and set local to the US. Set GPU memory to 144M and rebooting
- after running apt-get update; apt-get upgrade
- then after rebooting

Any other tests?
mpechner
 
Posts: 19
Joined: Mon Sep 22, 2008 10:57 am

Re: Pi Noir: mmal: mmal_vc_component_enable: failed to enabl

by adafruit_support_carter on Fri Aug 10, 2018 12:33 pm

The PCB color difference is normal. No more tests. That's plenty. So it's still not working after all that in your last post?

adafruit_support_carter
 
Posts: 5907
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pi Noir: mmal: mmal_vc_component_enable: failed to enabl

by mpechner on Fri Aug 10, 2018 1:26 pm

Nope.
mpechner
 
Posts: 19
Joined: Mon Sep 22, 2008 10:57 am

Re: Pi Noir: mmal: mmal_vc_component_enable: failed to enabl

by adafruit_support_carter on Fri Aug 10, 2018 1:54 pm

OK. Let's replace it. Send an email to support@adafruit.com with a link to this thread and your order number and they can get you a replacement NoIR camera.

adafruit_support_carter
 
Posts: 5907
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pi Noir: mmal: mmal_vc_component_enable: failed to enabl

by mpechner on Fri Aug 10, 2018 2:10 pm

thanks
mpechner
 
Posts: 19
Joined: Mon Sep 22, 2008 10:57 am

Please be positive and constructive with your questions and comments.