0

NoIR Camera not responding??
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/
Please be positive and constructive with your questions and comments.

NoIR Camera not responding??

by sharprez on Wed Jan 06, 2021 6:51 pm

ORDER #2443710-1875863513
Raspberry Pi Zero W NoIR Camera Pack - Includes Pi Zero W PID: 3415

My Zero Pi seems to be working great and I love using it so far, but I am having problems with the NoIR Camera. Below is the output when I try the online tutorial. I did check the SUNNY connector, but I think this NoIR camera is different, but still checked. If you have a solution, I'd like to try it! Or, maybe it needs replaced?

Thanks,
-Dan

>>raspistill -v -o test.jpg

Code: Select all | TOGGLE FULL SIZE
"raspistill" Camera App (commit e432bc340040 Tainted)

Camera Name imx219
Width 3280, Height 2464, filename test.jpg
Using camera 0, sensor mode 0

GPS output Disabled

Quality 85, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Time delay 5000, Timelapse 0
Link to latest frame enabled  no
Full resolution preview No
Capture method : Single capture

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Flicker Avoid Mode 'off'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
Camera component done
Encoder component done
Starting component connection stage
Connecting camera preview port to video render.
Connecting camera stills port to encoder input port
Opening output file test.jpg
Enabling encoder output port
Starting capture -1
Camera control callback  cmd=0x4f525245mmal: No data received from sensor.Check all connections, including the Sunny one on the camera board
Attachments
20201230_142425.png
20201230_142425.png (372.22 KiB) Viewed 134 times
20201230_142404.png
20201230_142404.png (390.39 KiB) Viewed 134 times

sharprez
 
Posts: 6
Joined: Thu Dec 24, 2020 1:50 pm

Re: NoIR Camera not responding??

by mikeysklar on Fri Jan 08, 2021 3:58 pm

Hi Dan,

When did you purchase the camera (I cannot lookup the order numbers).

Have you tried removing and reconnecting the sunny connector (I saw you checked it), but I see many reports saying the SUNNY connector had actually be disconnected and re-connected.

https://stackoverflow.com/questions/313 ... rom-sensor

How is your power supply looking? What voltage / current is it? Did you see any "Under-voltage" detected in the dmesg output?

Are you running the current 2020-12 Pi OS with updates?

https://www.raspberrypi.org/software/operating-systems/

Anything from this:

Code: Select all | TOGGLE FULL SIZE
 vcgencmd get_camera

mikeysklar
 
Posts: 2901
Joined: Mon Aug 01, 2016 8:10 pm

Re: NoIR Camera not responding??

by sharprez on Fri Jan 08, 2021 9:16 pm

Okay tried everything above, results:

Camera Purchase: Dec 23, 2020

I did disconnect and reconnect SUNNY connector again x2 (& previously)
Read link: Checked all connectors, note: not aware of any red light on camera

I do not have a volt meter, power supply rated at 2.4A
No "Under-voltage" in dmesg

I loaded the latest OS full version late december, and with internet connection the OS made a massive OS update on first connection.
does this help?
cat /etc/os-release
Code: Select all | TOGGLE FULL SIZE
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian

vcgencmd get_camera;
supported=1 detected=1

So....whats next? I just want it to work.. ;-)

sharprez
 
Posts: 6
Joined: Thu Dec 24, 2020 1:50 pm

Re: NoIR Camera not responding??

by alphanumeric on Sat Jan 09, 2021 8:57 am

Version 2 cameras as far as I know don't have an LED on them. The V1 do but not the V2.

CSI enabled in raspi-config? I think you'd get a different error if it wasn't but I'll ask anyway.

alphanumeric
 
Posts: 512
Joined: Sun Sep 07, 2014 7:06 pm

Re: NoIR Camera not responding??

by sharprez on Sat Jan 09, 2021 7:32 pm

Yes, of course.
Have we exhausted all the options?
Can I get a replacement?

sharprez
 
Posts: 6
Joined: Thu Dec 24, 2020 1:50 pm

Re: NoIR Camera not responding??

by mikeysklar on Mon Jan 11, 2021 2:50 pm

@sharprez,

Thank you for getting back to me with your OS updates and command output. I am slightly concerned that the Pi Zero connector port has failed based on this thread. Do you happen to have another Pi Zero you can try or a Pi ribbon camera connector to try with a normal Pi? That would help isolate which end the failure is on (the Pi or the Camera).

https://www.raspberrypi.org/forums/view ... p?t=105100

Regardless let's start the process of getting you a replacement for your order. Please send an e-mail to support@adafruit.com with your original order number, link to this forum thread and the replacement request.

mikeysklar
 
Posts: 2901
Joined: Mon Aug 01, 2016 8:10 pm

Re: NoIR Camera not responding??

by sharprez on Mon Jan 11, 2021 8:07 pm

I have initiated the replacement order.
Unfortunately, I do not have another Pi of any kind.
I would offer that you send me a new ribbon cable to try first?
It's up to you, I'm not in a rush, but I do look forward to it working. :-)

sharprez
 
Posts: 6
Joined: Thu Dec 24, 2020 1:50 pm

Re: NoIR Camera not responding??

by mikeysklar on Tue Jan 12, 2021 2:49 pm

@sharprez,

Probably best to swap all the components you bought from us in this case as and you can let us know which part had failed.

mikeysklar
 
Posts: 2901
Joined: Mon Aug 01, 2016 8:10 pm

Re: NoIR Camera not responding??

by sharprez on Wed Jan 13, 2021 3:41 pm

I sent the requested information to support@adafruit.com.
How long should I wait before I expect a reply?
What is going to happen next?
Thank you! :-)

sharprez
 
Posts: 6
Joined: Thu Dec 24, 2020 1:50 pm

Re: NoIR Camera not responding??

by mikeysklar on Wed Jan 13, 2021 5:44 pm

You should hear back from support in 24 hours. They will probably set you up with a replacement for your Pi NoIR Camera order. It was part of a package with the Pi Zero then all of that will be replaced.

mikeysklar
 
Posts: 2901
Joined: Mon Aug 01, 2016 8:10 pm

Re: NoIR Camera not responding??

by sharprez on Sat Jan 23, 2021 12:04 pm

I'm still waiting for a response from Adafruit. No email, or replacement.
I sent this message on the 10th/11th, am I missing something?

Please replace my Raspberry Pi Zero W NoIR Camera.
Order Confirmation No: 2443710-1875863513
Forum link : viewtopic.php?f=50&t=173808

sharprez
 
Posts: 6
Joined: Thu Dec 24, 2020 1:50 pm

Re: NoIR Camera not responding??

by mikeysklar on Mon Jan 25, 2021 3:17 pm

That is strange that you did not see a response. Could it have gone into a junk/spam folder? Please contact support@adafruit.com again with your link / order#. We cannot issue the replacement through the forums but the email responders can.

mikeysklar
 
Posts: 2901
Joined: Mon Aug 01, 2016 8:10 pm

Please be positive and constructive with your questions and comments.