0

Internal error: Oops: 17 [#1] ARM
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/
Please be positive and constructive with your questions and comments.

Internal error: Oops: 17 [#1] ARM

by catpants on Thu Jul 29, 2021 2:22 am

I recently bought a new Pi Zero W.

Unfortunately, when running any cpu intensive task, I see the error
Code: Select all | TOGGLE FULL SIZE
Internal error: Oops: 17 [#1] ARM
and the system freezes seconds later. The only option is to pull the power plug.

I have tried four different sd card types with this board, sd cards that all work fine with various other Pis.

The problem is the board, 100%.

Can you RMA please?

catpants
 
Posts: 11
Joined: Fri Oct 08, 2010 3:47 pm

Re: Internal error: Oops: 17 [#1] ARM

by adafruit_support_carter on Mon Aug 02, 2021 4:11 pm

Where are you seeing that error?

What is an example of a task that throws the error?

Is the problem repeatable?

Are your other Pi's also Pi Zero Ws? Or is this your only Zero W?

adafruit_support_carter
 
Posts: 21065
Joined: Tue Nov 29, 2016 2:45 pm

Re: Internal error: Oops: 17 [#1] ARM

by catpants on Wed Aug 04, 2021 1:06 am

adafruit_support_carter wrote:Where are you seeing that error?


The kernel is printing these messages to stdout/stderr, ie:

https://superuser.com/questions/351387/ ... my-console

adafruit_support_carter wrote:What is an example of a task that throws the error?


raspivid, gstreamer with v4l2

adafruit_support_carter wrote:Is the problem repeatable?


Yes. Every time I run raspivid the system freezes in less than 5 seconds.

adafruit_support_carter wrote:Are your other Pi's also Pi Zero Ws? Or is this your only Zero W?


My test systems are:
* Additional Pi Zero W, works 100% perfectly with any of the four sd cards I've tried.
* Pi 3 B, works 100% perfectly with any of the four sd cards I've tried.
* Pi 4, works 100% perfectly with any of the four sd cards I've tried.

Unfortunately, the problem is the board itself is defective.

catpants
 
Posts: 11
Joined: Fri Oct 08, 2010 3:47 pm

Re: Internal error: Oops: 17 [#1] ARM

by adafruit_support_carter on Wed Aug 04, 2021 10:56 am

Thanks for the information. For the second Pi Zero W that is working - are you testing with the same hardware (pi camera?) and raspivid/gstreamer/v4l2 setup? Basic idea is to use that one to verify the issue is truly specific to the other Pi Zero W, and not something else (which could be anything at this point).

There's a chance this is power related as well. What are you using to power the Pi?

adafruit_support_carter
 
Posts: 21065
Joined: Tue Nov 29, 2016 2:45 pm

Re: Internal error: Oops: 17 [#1] ARM

by catpants on Wed Aug 04, 2021 5:47 pm

adafruit_support_carter wrote:Thanks for the information. For the second Pi Zero W that is working - are you testing with the same hardware (pi camera?) and raspivid/gstreamer/v4l2 setup? Basic idea is to use that one to verify the issue is truly specific to the other Pi Zero W, and not something else (which could be anything at this point).


Absolutely, using the exact same setup for each test, the only difference is the actual board. (or one of 4 different sd cards)

adafruit_support_carter wrote:What are you using to power the Pi?


Using Canakit 2.5A power supply for all Pis besides the Pi 4, which I use the supply from Adafruit.

catpants
 
Posts: 11
Joined: Fri Oct 08, 2010 3:47 pm

Re: Internal error: Oops: 17 [#1] ARM

by adafruit_support_carter on Thu Aug 05, 2021 1:51 pm

Are you doing anything non-standard? Like overclocking? Using something other than Raspberry Pi OS images?

You can get this problem with a fresh install of Raspberry Pi OS and then just running raspivid?

adafruit_support_carter
 
Posts: 21065
Joined: Tue Nov 29, 2016 2:45 pm

Re: Internal error: Oops: 17 [#1] ARM

by catpants on Thu Aug 05, 2021 5:42 pm

adafruit_support_carter wrote:Are you doing anything non-standard? Like overclocking? Using something other than Raspberry Pi OS images?


The board is fresh from the package, all I have done is installed the camera, sd card, and power. No overclocking or anything else. Standard rpi os image lite.

adafruit_support_carter wrote:You can get this problem with a fresh install of Raspberry Pi OS and then just running raspivid?


Unfortunately yes. I have tried both raspivid piped to cvlc and gstreamer pulling from v4l2 (/dev/video0). I can stream video for about 5 seconds then the pi hard locks and I'm forced to pull the plug.

The lower the camera resolution, the lower the cpu load and the slower the lock takes. 1080p at 30 fps causes the lock almost immediately. (Which sadly is my use case)

I've tried multiple camera modules also, I get the same problem each time.

I would bet good money on the board being defective.

catpants
 
Posts: 11
Joined: Fri Oct 08, 2010 3:47 pm

Re: Internal error: Oops: 17 [#1] ARM

by adafruit_support_carter on Thu Aug 05, 2021 5:52 pm

OK, thanks for the additional info. Let's just replace it. Send an email to support@adafruit.com with a link to this thread and your order number and they can send you a new Pi Zero W.

adafruit_support_carter
 
Posts: 21065
Joined: Tue Nov 29, 2016 2:45 pm

Re: Internal error: Oops: 17 [#1] ARM

by catpants on Fri Aug 06, 2021 7:34 pm

Thank you so much!

catpants
 
Posts: 11
Joined: Fri Oct 08, 2010 3:47 pm

Please be positive and constructive with your questions and comments.