0

RPi 4 Not Booting - SDRAM failure
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/
Please be positive and constructive with your questions and comments.

RPi 4 Not Booting - SDRAM failure

by ishimuzi on Mon Aug 23, 2021 1:23 pm

Hello- I purchased a RPi 4 along with an official 5v power supply from Adafruit in May. I've encountered a problem that seems others have fallen into as well. I've spent about 10 hours total in troubleshooting and reviewing threads online with no success. Here is the sequence I took originally:

1) Used RPi-imager to load Debian img file onto a class 1 Sandisk 32 GB SD card
2) Placed that in RPi 4, plugged into official power supply, booted successfully on HDMI monitor
3) Went through all the standard init steps (e.g. set timezone, new password, update, etc)
4)I've used it a few times since it arrived without issues even added some programs and worked with the HDMI and USB ports all was ok.
Yesterday it was sluggish so I turned it off thinking it the network might be the culprit.
5) However, today upon rebooting it went into the dreaded 8 blink (green LED) non-booting scenario.

I've been using RPi 3 for years on many projects so this problem was new to me.
After digging further I do see this can happen occasionally to new RPi 4's.

Here are some of the steps I've taken in troubleshooting:

1) Found the 8 blinks of green LED is 'SDRAM failure'
2) Confirmed on GPIO 5v and ground pins with multimeter that it is receiving over 5v
3) Went through the EEPROM bootloader update process using both Rpi-imager and balenaEtcher on separate SD cards including a 16, 32 and 64 GB (all using FAT32). In this process I'm receiving the green LED blinking continuously and a green screen on the HDMI monitor indicating successful update of EEPROM.
4) Attempted to load a new RaPi OS using RPi-imager and Etcher, using full, lite/headless versions, all result in the 8 blinks of green LED and no output to HDMI monitor. These cards all load successfully on a RPi 3B+.
5) Attempted to load old EEPROM bootloaders from RPi GitHub site, no luck there
6) As noted in some threads they say to plug in the RPi 4 without an SD card to see if the EEPROM is working as expected.
-When I do this, I still get the 8 green LED blinks, which I have not seen in other threads online, usually people get no blinks or 4 blinks.
7) Attempted to use the RPi-imager utility to boot from USB. Loaded that to EEPROM. Loaded Debian to 3.0 USB stick. Attempted to boot that way, through USB and without SD card but received the 8 green LED blinks as well.

Not sure what else to do, thinking this may be a defective unit.
I don't blame Adafruit at all, it seems like it is a problem that occurs with some of the RPi 4 units.

Thank you in advance for any advice or recommendation that you can offer!

ishimuzi
 
Posts: 9
Joined: Fri Jul 03, 2015 5:43 am

Re: RPi 4 Not Booting - SDRAM failure

by mikeysklar on Mon Aug 23, 2021 10:14 pm

@ishimuzi,

Good job verifying that your Pi 4 has suffered from a SDRAM failure. This is an excellent summary of troubleshooting you have provided.

Our warranty is limited to 30-days on all purchases. You can notify Raspberry Pi through their forums or contact form of the failure so they can look into the failure as being a part sourcing issue or design flaw.

https://www.raspberrypi.org/forums/
https://www.raspberrypi.org/contact/

mikeysklar
 
Posts: 5813
Joined: Mon Aug 01, 2016 8:10 pm

Re: RPi 4 Not Booting - SDRAM failure

by ishimuzi on Tue Aug 24, 2021 8:19 am

Hi,

Thanks for your prompt response.

I understand that basically I have a DOA RPi 4 and there is no remedy?

If so what good would contacting RPi do?

PS

It's pretty disappointing that a quality product such as the RPi is covered by such short warranty.

I wouldn't feel safe ordering them in the future (I've had RPi3 and Zero for several years without issue).

Thanks.

ishimuzi
 
Posts: 9
Joined: Fri Jul 03, 2015 5:43 am

Re: RPi 4 Not Booting - SDRAM failure

by mikeysklar on Tue Aug 24, 2021 5:04 pm

There are plenty of Pi4 SDRAM failure threads in their forums. I think there is value in the "me too" failure posts to encourage the Pi Engineers to update the memory component or stuffing process that is causing a shorter lifespan. If nothing else it could lead to a better Pi5.

mikeysklar
 
Posts: 5813
Joined: Mon Aug 01, 2016 8:10 pm

Re: RPi 4 Not Booting - SDRAM failure

by ishimuzi on Wed Aug 25, 2021 1:10 am

I appreciate your feedback.

So it gives me less confidence in the RPi 4.

As it does not seem to be related to a specific batch, working condition or setup,

It appears that it's just a matter of luck if your device fails or not.

ishimuzi
 
Posts: 9
Joined: Fri Jul 03, 2015 5:43 am

Re: RPi 4 Not Booting - SDRAM failure

by mikeysklar on Wed Aug 25, 2021 10:52 am

I can report this to the Pi Foundation on your behalf.

If you want to take a photo of the SDRAM chip your Pi has I'll pass it along to them. This is more likely a batch failure based on the component lasting for several months before becoming unusable. I'll persue this with them.

photo for reference of what I'm looking for:

45DFB435-4651-4B40-81FA-418E61CD090B.jpeg
45DFB435-4651-4B40-81FA-418E61CD090B.jpeg (55.52 KiB) Viewed 77 times

mikeysklar
 
Posts: 5813
Joined: Mon Aug 01, 2016 8:10 pm

Re: RPi 4 Not Booting - SDRAM failure

by ishimuzi on Sat Aug 28, 2021 2:24 pm

Hi I’d appreciate you reporting on my behalf.
As a side note- although it was in my possession for a couple of months, it was used only a few times.
Please find attached a picture as requested.
Attachments
60E5EA20-2F04-45D1-9DAF-E0DAA1904B00.jpeg
60E5EA20-2F04-45D1-9DAF-E0DAA1904B00.jpeg (494.99 KiB) Viewed 73 times

ishimuzi
 
Posts: 9
Joined: Fri Jul 03, 2015 5:43 am

Re: RPi 4 Not Booting - SDRAM failure

by mikeysklar on Sat Aug 28, 2021 5:21 pm

Thank you for the photo. I started a thread on the Pi forum and help troubleshoot this. It needs to be approved so I'm awaiting that.

mikeysklar
 
Posts: 5813
Joined: Mon Aug 01, 2016 8:10 pm

Re: RPi 4 Not Booting - SDRAM failure

by ishimuzi on Sun Aug 29, 2021 1:10 am

Thanks.

ishimuzi
 
Posts: 9
Joined: Fri Jul 03, 2015 5:43 am

Re: RPi 4 Not Booting - SDRAM failure

by mikeysklar on Mon Aug 30, 2021 6:01 pm


mikeysklar
 
Posts: 5813
Joined: Mon Aug 01, 2016 8:10 pm

Re: RPi 4 Not Booting - SDRAM failure

by ishimuzi on Tue Aug 31, 2021 4:18 am

Much appreciated.
I hope this is batch related.

ishimuzi
 
Posts: 9
Joined: Fri Jul 03, 2015 5:43 am

Re: RPi 4 Not Booting - SDRAM failure

by mikeysklar on Tue Aug 31, 2021 12:01 pm

Okay, we worked out a process to start following the failures. It is clumbsy, but better than nothing.

Can you post a photo of your QR code on your board? That is how the Raspberry Pi folks want to track these.

mikeysklar
 
Posts: 5813
Joined: Mon Aug 01, 2016 8:10 pm

Re: RPi 4 Not Booting - SDRAM failure

by ishimuzi on Wed Sep 01, 2021 1:41 am

Here you go.
Attachments
4AB80446-7A9C-4AFD-AF36-78362E54D95B.jpeg
4AB80446-7A9C-4AFD-AF36-78362E54D95B.jpeg (696.01 KiB) Viewed 50 times

ishimuzi
 
Posts: 9
Joined: Fri Jul 03, 2015 5:43 am

Re: RPi 4 Not Booting - SDRAM failure

by ishimuzi on Fri Sep 17, 2021 10:35 am

Hi,
Any news about this?

ishimuzi
 
Posts: 9
Joined: Fri Jul 03, 2015 5:43 am

Re: RPi 4 Not Booting - SDRAM failure

by mikeysklar on Fri Sep 17, 2021 12:05 pm

One other response on the Pi forum claiming the same issue and the Pi moderator suggesting they seek a refund from the reseller.

No new SDRAM cases in the Adafruit forums for the last two weeks.

mikeysklar
 
Posts: 5813
Joined: Mon Aug 01, 2016 8:10 pm

Please be positive and constructive with your questions and comments.