Due to high demand expect some shipping delays at this time, orders may not ship for 3-4 business days. On MLK Day no orders will be shipped.
0

voice bonnet alsamixer settings
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/
Please be positive and constructive with your questions and comments.

voice bonnet alsamixer settings

by Tony_H on Mon Nov 15, 2021 7:00 pm

Hi all. I am running into the Voice Bonnet - high pitched whining issue with my new Voice Bonnet for raspberry pi. (very new pi4 hardware, been through the setup instructions 3x, ...) This is not a problem when I play a test tone through the speakers (e.g., using "speaker-test -Dhw:3 -c2 -s1 -t sine -f 150"), but only when I try to stream- or record-from the on-board microphones.

I see that the particular thread I was following is no longer taking replies, but I did not see any posts in that thread discussing the *alsamixer* settings between the camps saying "I have no problem with mine" vs. those that say "I'm having this problem." I'm new to Linux audio schtuff, but there seem to be a LOT of settings options, and after checking out the chip's block diagram I can see the possibility for some wrong default settings potentially being the issue.
Just a thought; what do I know.

Could the adafruit testing department please post the list of alsamixer settings that they use to test the voice bonnet? Maybe folks more familiar with Rpi audio can rule this out a potential cause. Either chunk of information could be helpful.

And are there any potential insights into the source of the noise frequency? I saw posts that it was ~1.5 kHz - mine had a spike around 1.44khz and another one somewhere in the 4.something kHz range. Could that be tied somehow to the secondary LED/jst/servo control options on that board (as in, use/testing of those functions in a certain order alleviates the issue so it might not be caught in production testing?) Again, I don't know. Just thoughts.
Thanks!

Tony_H
 
Posts: 16
Joined: Wed Feb 12, 2020 7:30 pm

Re: voice bonnet alsamixer settings

by Tony_H on Wed Dec 01, 2021 7:32 pm

This product relies on a third-party driver, and from some other posts on this topic I gather that its operation seems to have broken somewhere prior to kernel 5.10 (I think that was the version). The adafruit Audio Setup instructions mention which branch of the HinTak driver to select based on the host kernel version ("If your kernel version is 5.10 or higher, use the following:") and 5.10 was the kernel version of pi OS lite when I was setting this up.
Can adafruit support tell us which kernel version the adafruit test station for these devices uses? [... and if 5.10 or higher, your list of alsamixer settings, please?]
Or maybe if another customer of this product is seeing this thread and was able to get the Audio Setup steps to work out fine with kernel v 5.10 (w/o experiencing the high-pitch noise when recording from the product's mic inputs), were there any work-arounds you figured out that you could share?
Thanks.

Tony_H
 
Posts: 16
Joined: Wed Feb 12, 2020 7:30 pm

Re: voice bonnet alsamixer settings

by Tony_H on Fri Dec 10, 2021 6:27 pm

*bump*
... willing to accept that my request might be a red-herring. If anyone is pretty confident of that please feel free to say so (and why, please).

Tony_H
 
Posts: 16
Joined: Wed Feb 12, 2020 7:30 pm

Re: voice bonnet alsamixer settings

by Tony_H on Tue Jan 11, 2022 6:24 pm

*crickets*
Well bye then.

Tony_H
 
Posts: 16
Joined: Wed Feb 12, 2020 7:30 pm

Please be positive and constructive with your questions and comments.