Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Adafruit 5" TFT HDMI image remains superimposed in backgroun
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/
Please be positive and constructive with your questions and comments.

Adafruit 5" TFT HDMI image remains superimposed in backgroun

by djblex on Sat Sep 23, 2017 6:51 am

Hello
I repost this issue because I did not have answers the last time so I decided to delete it. But now, It starts to become big problem. I test for a long time with three screens ; three rpi A+, and this is the same problem. Please could you help me. I Plan a big project but the issue screen stop it. I don‘t know what to do because I need to order a lot of screens.

Here my main hardware configuration for the issue (all is new)
Raspberry Pi A+
TFP401 HDMI Driver
5" TFT Display

I made the Super Game PI in following the entire tutorial. (https://learn.adafruit.com/super-game-pi/overview)
More i use the screens , more the the phenomeon appears. Is this a construct problem in particular serie production ? or just a setting that i missed ?


On the screen Adafruit 5”, if an image remains fixed for few seconds , and then this image is moved, You see this image in the background and remains several seconds. It's very embarrassing to play at Retropie or recalbox.
For example, I play to Mario Kart. from the start of the race, as soon as the kartings start, we can see the starting grid superimposed to the kartings running…
it reminds me of old CRT screens, they did the same thing.
Is there a way to fix this? A setting?

Thank you for the support
Attachments
04.jpg
here the grid superimposed
04.jpg (36.45 KiB) Viewed 737 times
02.jpg
here the superimposed image
02.jpg (21.72 KiB) Viewed 737 times
01.jpg
normal view before moving the image
01.jpg (22.42 KiB) Viewed 737 times

djblex
 
Posts: 55
Joined: Sat Jul 29, 2017 3:19 am

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by djblex on Sun Sep 24, 2017 4:55 pm

Then i tried a lot of setting : hdmi mode...,lcd_framerate...
I thought it was the screen framerate maybe ?
But no solutions.

Now when i reboot Retropie, appears images superimposed on the color image on boot.

Thank you

djblex
 
Posts: 55
Joined: Sat Jul 29, 2017 3:19 am

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by djblex on Thu Sep 28, 2017 9:32 am

Hello,

i installed RASPIAN and we can see the problem on the pics.
Thank you
Attachments
raspianminecraft 2.jpg
Back to main screen of Raspian : wee can see the title Minecraft superimposed.
raspianminecraft 2.jpg (136.09 KiB) Viewed 690 times
raspianminecraft1.jpg
Minecraft menu , all is good
raspianminecraft1.jpg (156.01 KiB) Viewed 690 times

djblex
 
Posts: 55
Joined: Sat Jul 29, 2017 3:19 am

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by djblex on Wed Oct 04, 2017 6:14 am

Hello,
I hope to have an answer :),
I bought again (the fourth) another Adafruit 5 inch Display without touch screen. (i need really to solve this problem)
Same issues :
Ghost effect (images remained fixed in background) and blue lines on the left and on the top.
I used another new TFP401 and new ruban cable.

So i think, after some researches , that is a problem of voltage (maybe not enough voltage :) for the display.

-Do The display need 3,3v or 5V in his input?

-On the TFP401, Are there settings on the EDID Rom to setup up ?
Or anothers settings to force the video rate, voltage?
For information, the new display screen was build on 20161026 like the others.

Please, an answer !
Thank you very much :)

djblex
 
Posts: 55
Joined: Sat Jul 29, 2017 3:19 am

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by adafruit2 on Wed Oct 04, 2017 2:03 pm

huh yah that is more noticable than we've seen.
the TFP401 does have EDID set but EDID doesnt affect anything with ghosting
the voltage does matter, 5V is ideal for the TFP+5" display

can you show your wiring/power setup?

adafruit2
Site Admin
 
Posts: 19383
Joined: Fri Mar 11, 2005 7:36 pm

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by djblex on Wed Oct 04, 2017 6:07 pm

Hello, thank you for the reply.
I ll show you later the wiring.
- I use exactly the same witing than the Super Game Pi Project from Adafruit : Ghost effect
-Then , i tested to plug the power supply between the computer USB and the TFP401 : Ghost effect
-Then , i used an USB external power supply for my cellphone in the TFP401 : Ghost effect
- I tested to link the +25ma jumper on the TFP401 to have more backlight : Ghost effect

Really , i tested many settings and really, i don't know what do to.
Last edited by djblex on Wed Oct 04, 2017 6:10 pm, edited 1 time in total.

djblex
 
Posts: 55
Joined: Sat Jul 29, 2017 3:19 am

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by adafruit2 on Wed Oct 04, 2017 6:10 pm

what happens if you use it with a normal computer?

adafruit2
Site Admin
 
Posts: 19383
Joined: Fri Mar 11, 2005 7:36 pm

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by djblex on Wed Oct 04, 2017 6:14 pm

Nothing works, i obtain black screen. It is really weird. i tried with 3 display.
It for that i asked you about tjhe EDID. i thoughtthat could be solved :)

i have Win 10 and it doesn't detect nothing when i plug them with HDMI, even when i force the resolution on Windows.

djblex
 
Posts: 55
Joined: Sat Jul 29, 2017 3:19 am

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by adafruit2 on Wed Oct 04, 2017 6:17 pm

hmm yeah i wonder if the EDID was not written. but still, that shouldnt affect anything. did you get the TFP401 and 5" display together?

adafruit2
Site Admin
 
Posts: 19383
Joined: Fri Mar 11, 2005 7:36 pm

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by djblex on Wed Oct 04, 2017 6:17 pm

Have you a same 5 inch display without touch with the identical build on 20161024 or 20161026 (ref in back) ?
If yes , could you try with a TFP401 and a Raspberry A+ 512 MB.

djblex
 
Posts: 55
Joined: Sat Jul 29, 2017 3:19 am

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by djblex on Wed Oct 04, 2017 6:22 pm

What do you mean by "did you get the TFP401 and 5" display together?"
i own 3 TFP401 . I bought Displays and TFP401 with two resellers: one in England , the other near to you :)
Last edited by djblex on Wed Oct 04, 2017 6:34 pm, edited 1 time in total.

djblex
 
Posts: 55
Joined: Sat Jul 29, 2017 3:19 am

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by djblex on Wed Oct 04, 2017 6:25 pm

Each one pièces come from the resellers, But it is exactly the same displays reference (20161024 as 20161026) which come from the two resellers.

djblex
 
Posts: 55
Joined: Sat Jul 29, 2017 3:19 am

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by djblex on Wed Oct 04, 2017 6:33 pm

If i understand, the EDID shows to a computer which screen resolution used automaticaly?
Normally, the TFP401 should have a 800*480 60 hz default resolution in its EPROM ?
In my case, as my displays obtain black screens when they are plugged on a computer, it let me think that the EDID does not work normaly
And i have the Blue lines, no mater the displays settings and it does it with all the displays.

djblex
 
Posts: 55
Joined: Sat Jul 29, 2017 3:19 am

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by djblex on Mon Oct 09, 2017 5:02 pm

Hello, i cameback
For an ultimate test of ghost effects, I purchased and received today an Adafruit 5.0 "40-pin TFT Display - 800x480 with touchscreen (https://www.adafruit.com/product/1596).
I tested it with 2 TFP401 and I obtain a really bad screen definition and colors. There are pixels and some strange green colors. However, the settings are the same than the other Adafruit 5 inch TFT screen - 800x480 without touch screen, which have a nice picture with ghost effects


Really really I do not understand what's going on. All these materials are expensive and so far, never works well.

Please, look at the photos and could you tell what is happening? Need a driver? With different settings?

The only positive: it seems there is no more ghost effects.

But I win a newline in the middle and the image is distorted between this line. And I keep the purple line on the left.


Here my config.txt :
hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=1
hdmi_mode=87
hdmi_cvt 800 480 60 6 0 0 0
arm_freq=900
core_freq=250
sdram_freq=450
over_voltage=2
avoid_safe_mode=1
gpu_mem=256
overscan=1

thank you
Attachments
20171009_220308.jpg
20171009_220308.jpg (213.65 KiB) Viewed 522 times
20171009_220212.jpg
20171009_220212.jpg (62.82 KiB) Viewed 522 times
20171009_220104.jpg
20171009_220104.jpg (133.52 KiB) Viewed 522 times

djblex
 
Posts: 55
Joined: Sat Jul 29, 2017 3:19 am

Re: Adafruit 5" TFT HDMI image remains superimposed in backg

by djblex on Mon Oct 23, 2017 9:07 am

Hello, as i describe in this topic (viewtopic.php?f=45&t=124040&p=626026#p626026),
i solved this problem of images remained superimposed in background :

i write what i wrote in the topic on the link above :

Today, i received a new TFP401. Just plugged and all works good, no lines anymore AND NO images remained superimposed in background . (See the pic )
But few days ago, with an arduino UNO, i flashed the EEPROM of my two another TFP401 and no changement, always blues lines. here the code i used (https://learn.adafruit.com/adafruit-tfp ... g-the-edid).

So please, is there a good process to flash the EEPROM ?
I followed exactly the tutorial here (https://learn.adafruit.com/adafruit-tfp ... g-the-edid).

If not, i would like to return my two another TFP401 for an exchange.
For the story , i bought 3 at Mouser including one died on arrival.

So they shipped me a new for replacement and this is this one that i received today and which works without lines on left and top .
And if i have to replace the two another TPF401, i suppose Mouser needs explanation ot proves that problems come from my two the TFP401.

This new TFP401 solved me 2 problems :
-No more blue lines as described in this topic.
-AND NO MORE IMAGES SUPERIMPOSED...

NOW Finally my Super GAME PI WORKS WELL :)

So please, i would like to replace my another two TPF401, (all were tested on them) : flash EEPROM without result, Ribbon cables changed, screens replaced.
Attachments
20171023_114608.jpg
20171023_114608.jpg (66.79 KiB) Viewed 471 times

djblex
 
Posts: 55
Joined: Sat Jul 29, 2017 3:19 am

Please be positive and constructive with your questions and comments.