0

2.8 PITFT r for pi3 error on software install
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/
Please be positive and constructive with your questions and comments.

2.8 PITFT r for pi3 error on software install

by 3DNDesign on Tue Mar 27, 2018 5:20 pm

I purchased the 2.8 screen and I keep getting an error when trying to load the Adafruit software to connect to pi 3. Help

pi@raspberrypi:~ $ curl -SLs https://apt.adafruit.com/add-pin | sudo bash
.`
-dMMs
+MMMMMo
.dMMMMMMN-
+NMMMMMMMMd`
`hMMMMMMMMMMMo
-mMMMMMMMMMMMMN.
dMMMMMMMMMMMMMMo
:hmmmmmmmmmmmmdhs/. `MMMMMMMMMMMMMMMh
sMMMMMMMMMMMMMMMMMMd+NMMMMMMMMMMMMMM+
/NMMMMMMMMMMMMMMMMMMMMMMMMs+NMMMMMm/+syyyso/-`
`hMMMMMMMMMMMMMMMMMMMMMMo hMMMMMMMMMMMMMMMMMNhs+:.
/NMMMMMMMMMMMNmmNMMMMN. `mMMMMMMMMMMMMMMMMMMMMMMMNh-
.hMMMMMMMMMMh` `-sNMMs-hMMMMMMMMMMMMMMMMMMMMMMMMMM+
/mMMMMMMMMMNy+-./MMMMMMy:....oMMMMMMMMMMMMMMMNo.
:ymMMMMMMMMMMMMMMMMMNy//oymMMMMMMMMMMMMMNy:
.yMMMMMMMms:oMMNhNMMMMMMMMMMMMMMMMNh/`
.yMMMMMMMN/ .dMMy `sMMMMMMMMMMMNmy/`
/NMMMMMMMM:`-sMMMMM: sMMMMMMs-..`
-NMMMMMMMMMNNMMMMMMMMs./MMMMMMMh`
mMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMs
sMMMMMMMMMMMMMMMMhMMMMMMMMMMMMMMMN
:MMMMMMMMMMMMMMMN+ hMMMMMMMMMMMMMMN.
`dMMMMMMMMMMMMNh/` `hMMMMMMMMMMMMMN.
/MMMMMMMMmhs+- /dMMMMMMMMMMMN.
.hmdys/- -sNMMMMMMMMN.
`:hNMMMMMN.
`+dMMMN`
./+-

adding apt.adafruit.com to /etc/apt/sources.list

adafruit repo already added to apt sources
/etc/apt/preferences.d/adafruit already exists - leaving alone
Get:1 http://apt.adafruit.com/raspbian wheezy InRelease [2,093 B]
Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Hit:3 http://archive.raspberrypi.org/debian stretch InRelease
Ign:1 http://apt.adafruit.com/raspbian wheezy InRelease
Fetched 2,093 B in 2s (802 B/s)
Reading package lists... Done
W: GPG error: http://apt.adafruit.com/raspbian wheezy InRelease: The following signatures were invalid: 58A1FE78D61C7C13E28B92A7C24E6D5378661FA5
W: The repository 'http://apt.adafruit.com/raspbian wheezy InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
pi@raspberrypi:~ $

3DNDesign
 
Posts: 3
Joined: Tue Feb 27, 2018 11:28 am

Re: 2.8 PITFT r for pi3 error on software install

by adafruit_support_mike on Wed Mar 28, 2018 2:34 am

It looks like you're trying to install PiTFT support on an SD card using Raspbian Wheezy.

Wheezy has been officially deprecated for at least a couple of years, and doesn't work with any of the code necessary to make the PiTFT run these days.

Try starting from a fresh copy of the latest Raspbian and see if that works:

https://www.raspberrypi.org/downloads/raspbian/

adafruit_support_mike
 
Posts: 56471
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.8 PITFT r for pi3 error on software install

by 3DNDesign on Wed Mar 28, 2018 10:48 am

Link to install screen?

3DNDesign
 
Posts: 3
Joined: Tue Feb 27, 2018 11:28 am

Re: 2.8 PITFT r for pi3 error on software install

by 3DNDesign on Wed Mar 28, 2018 11:54 am

I am new owner of a raspberry pi and can not seem to get this screen to install. The link on the page for the Raspberry pi Thermal camera to install the screen is not functioning.
How do I get an installation guide to install the screen? I have done a new installation of Raspian using Noops. But tried the adafruit-pitft.sh on GitHub and now screen come on with the last terminal but nothing else works??

3DNDesign
 
Posts: 3
Joined: Tue Feb 27, 2018 11:28 am

Re: 2.8 PITFT r for pi3 error on software install

by adafruit_support_mike on Thu Mar 29, 2018 1:03 am

The instructions to install PiTFT support on a fresh image of Raspbian are here:

https://learn.adafruit.com/adafruit-pit ... ler-script

They include the instructions in your first post, so I'd guess you've already seen them.

The specific configuration you choose will depend on whether you have a resistive or capacitive touchscreen.

adafruit_support_mike
 
Posts: 56471
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.8 PITFT r for pi3 error on software install

by brydenrh on Sun Apr 15, 2018 9:18 pm

I have a different problem than the OP but is mentioned in the github forum. But the fix there did not seem to resolve my issue.

The instructions on the adafruit site for the 2.8" Pi TFT (resistance touchscreen) get me to the last step and then it says...

"Missing Apt repo, please add deb http://mirrordirector.raspbian.org/raspbian/ stretch main contrib non-free rpi firmware to /etc/apt/sources.list.d/raspi.list"

Which might as well be in Chinese because I don't understand a word of it. I'm pretty new to Pi and linux.

I am using a brand new Raspberry Pi 3 B+ and the 2.8" TFT resistive touchscreen from Adafruit. The latest version of Raspbian was also used and updated and upgraded. I also tried it afterwards using a Raspberry Pi 2 v1.1 and had the same result.

Thanks for any help!

brydenrh
 
Posts: 9
Joined: Wed May 16, 2012 4:08 pm

Re: 2.8 PITFT r for pi3 error on software install

by adafruit_support_mike on Mon Apr 16, 2018 3:04 am

The error says the installer can't find the server with the information it needs to download.

Post the contents of the file /etc/apt/sources.list.d/raspi.list please.

adafruit_support_mike
 
Posts: 56471
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.8 PITFT r for pi3 error on software install

by brydenrh on Mon Apr 16, 2018 2:08 pm

Hi Mike,

Here are the contents of that file:
++++++++++++++++++++++
deb http://archive.raspberrypi.org/debian/ stretch main ui staging
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspberrypi.org/debian/ stretch main ui

+++++++++++++++++++++++++++++++++

Thanks

Ray

brydenrh
 
Posts: 9
Joined: Wed May 16, 2012 4:08 pm

Re: 2.8 PITFT r for pi3 error on software install

by adafruit_support_mike on Tue Apr 17, 2018 2:59 am

Copy this line into that file, above the second line of + signs:

Code: Select all | TOGGLE FULL SIZE
deb http://mirrordirector.raspbian.org/raspbian/ stretch main contrib non-free rpi firmware
then try running the installer again.

adafruit_support_mike
 
Posts: 56471
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.8 PITFT r for pi3 error on software install

by brydenrh on Tue Apr 17, 2018 6:02 pm

I am completely dispirited with my attempts to learn python on my pi and do some projects during vacation. It seems like even the first most basic steps are completely beyond hope. Everything prescribed in tutorials, installation sites, forums, support pages, etc. never works. The shocking thing is that this is all vanilla equipment (new R-Pi 3 B+, freshly formatted microSD card, new 2.4 amp power supply, usb keyboard, and the 2.8" TFT resistive touchscreen display), I don't know why it needs to be this difficult to get a simple little display working (actually two - I bought a 7" touchscreen Pi display from another site, and it also fails no matter how many hoops I jump through... but that's another story).

I edited the file as you described (not easy as it couldn't be saved as I didn't have permissions, so it took another project to learn how to go through the terminal based editor to make changes as a super user). I finally figured that out and it seemed happy and I rebooted for the 500th time in this odyssey and ran the scripts as shown in the TFT installation page, and then it seemed to be working away and at the end I got a giant wall of red text which started with:
"Exception:
Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main
status = self.run(options, args)
....
"
There are about 18 more such lines of errors and at the end of all that it says:

"TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'"

I give up... :(

brydenrh
 
Posts: 9
Joined: Wed May 16, 2012 4:08 pm

Re: 2.8 PITFT r for pi3 error on software install

by brydenrh on Tue Apr 17, 2018 6:23 pm

OK I figured out what was wrong. My edit contained two carriage returns (I couldn't figure out how to delete them - I had to look it up). Once I edited them out and retried the process it worked. The TFT is now functioning as advertised.

It only took 3.5 days to get to this point... lol. let's hope the next steps go smoother...

brydenrh
 
Posts: 9
Joined: Wed May 16, 2012 4:08 pm

Re: 2.8 PITFT r for pi3 error on software install

by adafruit_support_mike on Wed Apr 18, 2018 1:43 am

That's the nature of working with hardware: details matter, but you get as many chances to try as you're willing to take.

adafruit_support_mike
 
Posts: 56471
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.8 PITFT r for pi3 error on software install

by Farqhuit on Fri Apr 20, 2018 4:57 am

Brydenrh,

I share your frustration, well done for getting to the bottom of it. Where were the two carriage returns, in the little raspi.list file that the mod asked you to edit? How did you work out that this was the problem?

D

Farqhuit
 
Posts: 35
Joined: Sat Mar 17, 2018 6:04 pm

Please be positive and constructive with your questions and comments.