0

Pi400 - WiFi Thermal Failure
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/
Please be positive and constructive with your questions and comments.

Pi400 - WiFi Thermal Failure

by C855B on Mon May 03, 2021 8:39 am

G'morning!

I received a Pi400 from Adafruit three weeks ago that came up fine and is running Ubuntu Desktop 20.10. However, it wasn't but a couple of days before it would "lose" the WiFi. Not just the connection, but the whole shebang, as if the WiFi module didn't exist. Rebooting or cycling power would not immediately recover function. HOWever, shutting down and removing power completely for several hours, typically overnight, would restore full function for a few hours to a few days. Then the cycle would start over again.

I'm an experienced hardware tech. This has all the earmarks of a thermal failure, but I'm not going to void any warranty by cracking the case open to fish around with cold spray.

Repair or replace, what are the options here, and how do I go about it?

Adafruit order number was 2535283.

Thanks!

...mike

C855B
 
Posts: 3
Joined: Mon May 03, 2021 1:07 am

Re: Pi400 - WiFi Thermal Failure

by C855B on Fri May 07, 2021 11:33 am

Just to be clear, this 400 seems to be defective and I am looking to get an RMA for a warranty replacement. Sorry to clutter the request.

To answer the expected power supply question, this was a full kit, and I'm using the included Raspberry Pi 3.0A supply. Everything is box-stock.

C855B
 
Posts: 3
Joined: Mon May 03, 2021 1:07 am

Re: Pi400 - WiFi Thermal Failure

by adafruit_support_carter on Fri May 07, 2021 3:18 pm

Not just the connection, but the whole shebang, as if the WiFi module didn't exist.

Can you clarify what you mean by "didn't exist"? What was that based on?

adafruit_support_carter
 
Posts: 20301
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pi400 - WiFi Thermal Failure

by C855B on Sat May 08, 2021 8:30 am

adafruit_support_carter wrote:
Not just the connection, but the whole shebang, as if the WiFi module didn't exist.

Can you clarify what you mean by "didn't exist"? What was that based on?


The GUI OS controls for WiFi disappear. Bluetooth, too, IIRC, but since I don't use Bluetooth with this particular workstation I didn't drill down to further diagnose. Haven't messed with diagnosis at the command-line level. Remove power overnight, it boots fine, everything works, until it doesn't.

Let's put it this way - I have nearly a dozen other RPis - 3s, 4s and 2 other 400s, and this one's not right. :-/

C855B
 
Posts: 3
Joined: Mon May 03, 2021 1:07 am

Re: Pi400 - WiFi Thermal Failure

by adafruit2 on Mon May 10, 2021 11:15 am

this is kinda odd - and i think that the pi foundation (who make the hardware) would like to hear about it before replacing. is there any output from dmesg, please post it to the pi forums!

adafruit2
Site Admin
 
Posts: 20040
Joined: Fri Mar 11, 2005 7:36 pm

Please be positive and constructive with your questions and comments.