0

RGB Matrix Not showing Blue
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/
Please be positive and constructive with your questions and comments.

RGB Matrix Not showing Blue

by brokehomiekwan on Wed May 05, 2021 10:45 am

I recently ordered a rgb bonnet and a 32x64 matrix from adafruit to build/test some projects.

The issue is, Once I load up the software on my Raspberry pi 3, anything displayed with pure Blue doesn't show, or if mixed then it flickers random red colors. I can display green just fine, but once I mix in other colors, everything goes crazy. I also noticed that when I connect a power supply to my bonnet, the green light doesn't power-on. If I connect my Raspbery Pi via USB for power, then the pi and bonnet get power.

Demo command:

pi@raspberrypi:~/rpi-rgb-led-matrix/examples-api-use$ sudo ./demo -D 0 --led-cols=64 --led-slowdown-gpio=4

Any ideas?

brokehomiekwan
 
Posts: 1
Joined: Wed May 05, 2021 8:30 am

Re: RGB Matrix Not showing Blue

by adafruit_support_carter on Thu May 06, 2021 3:58 pm

I also noticed that when I connect a power supply to my bonnet, the green light doesn't power-on.

What power supply are you using here?

adafruit_support_carter
 
Posts: 20281
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.