Miniature WiFi (814)
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/
Please be positive and constructive with your questions and comments.

Miniature WiFi (814)

by Jeff009 on Fri Oct 12, 2012 6:33 am

I just purchased a Wifi adapter from Adafruit. I'm running the AdaFruit Occidentals distribution. Within Gnome, how do I now configure my Pi to connect to my wireless network. When I run Midori I'm just told that the browser is unable to connect. Can you point me to some instruction on how to now configure my system to connect to my wireless?


Posts: 36
Joined: Sun Jun 10, 2012 11:54 am

Re: Miniature WiFi (814)

by adafruit on Fri Oct 12, 2012 10:09 am

Posts: 12131
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: Miniature WiFi (814)

by cerocca on Fri Oct 12, 2012 1:55 pm

Hi there,
I am trying to have the Miniature WiFi (814) adapter working with my rpi and Occidentalis 0.2 installed, but without any success.
I followed a couple of tutorials but none of them solved my problem. (I have a WEP protection but the rpi seems not to scan any network)

So I come here for one question: can it be a power issue? I mean, do the Miniature WiFi work without a powered hub?
I think I saw a couple of images with the adapter inserted without hub, but I'm not so sure anymore...

Posts: 2
Joined: Tue Sep 18, 2012 6:26 am

Re: Miniature WiFi (814)

by tikka308 on Fri Oct 12, 2012 2:55 pm

Yes, you definitely should use a powered USB hub (at least while troubleshooting; possible required at all times for WiFi USB chip).

I did a short youtube video on getting my Pi to work with the Adafruit Wifi, which you may find helpful: http://www.youtube.com/watch?v=uj2m2UeP3bw

Posts: 11
Joined: Fri Mar 09, 2012 10:09 am

Re: Miniature WiFi (814)

by Jeff009 on Sun Oct 14, 2012 5:29 pm

adafruit wrote:http://learn.adafruit.com/adafruit-raspberry-pi-educational-linux-distro/occidentalis-v0-dot-1#wifi-support

Thanks, that's what I needed. I'm now have WifI access.


Posts: 36
Joined: Sun Jun 10, 2012 11:54 am

Re: Miniature WiFi (814)

by Jeff009 on Sun Oct 14, 2012 5:33 pm


If it helps, I followed the steps listed on the link above. I have my USB WiFi dongle attached in one of the USB slots on my RPi, and I have a USB hub connected to the other USB port. My mouse and keyboard are plugged into the USB hub.

With your USB WiFi, I suggest plugging it directly into your RPi.

Hope this helps,

Posts: 36
Joined: Sun Jun 10, 2012 11:54 am

Re: Miniature WiFi (814)

by cerocca on Mon Oct 15, 2012 6:40 am

problem solved!
after some (more) struggling, I managed to have the miniature wifi adapter working under both Occidentalis 0.2 and Xbian (XBMC distribution, installed on another SD card)
The adapter itself have some weird behaviour at beginning, but after one reboot it works fine, without any hub!

My problem was in the WEP protection... tested almost everything and it didn't work, switched to WPA2 and it worked like a charm.
It seems WEP have some big issues (at least from what I saw also in other forums)
Now I have wifi adapter in one USB slot, and I can plug my keyboard / a USB key in the other slot still without any hub.

Thanks to all for your replies!
Posts: 2
Joined: Tue Sep 18, 2012 6:26 am

Re: Miniature WiFi (814)

by Pavel on Fri Oct 19, 2012 12:01 am

The Occidentalis v0.2 kernel does not seem to be generating the wlan0 network interface. Command ifconfig -a shows ethernet and local network interfaces, but no wireless interface. Similarly, command lsusb does not indicate the presence of the WiFi adaptor.

Code: Select all | TOGGLE FULL SIZE
pi@raspberrypi:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr b8:27:eb:55:67:4b
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

My setup is Raspberry Pi powered by Adafruit 5V power supply (ID:501) to microB and running headless using HyperTerminal and the (ID:954) USB-TTL cable's three wires - gnd, rx, tx. Using ethernet on this setup works just fine.

Terminal logs and command dmesg indicate that the WiFi dongle is recognized:
[    3.108689] usb 1-1.3: new high speed USB device number 4 using dwc_otg
[    3.220578] usb 1-1.3: New USB device found, idVendor=0bda, idProduct=8176
[    3.230187] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3.240127] usb 1-1.3: Product: 802.11n WLAN Adapter
[ 3.247578] usb 1-1.3: Manufacturer: Realtek

I believe it is retrieving the firmware, among other positive signs:
[ 37.331827] ===> FirmwareDownload91C() fw:Rtl819XFwImageArray_UMC_B
[ 37.340603] FirmwareDownload92C accquire FW from embedded image
[ 37.349111] fw_ver=v80, fw_subver=0, sig=0x88c0
[ 37.393541] fw download ok!

But then things seem to fall apart:
[ 38.062484] reg 0xfe41, usb write 1 fail, status:-71 value=0x81, vendorreq_times:5
[ 38.075545] usb 1-1.3: USB disconnect, device number 4

Adding WiFi to my project only needs to happen at the end so I can work for quite awhile using just the ethernet cable, but at some point I'd like to generate a wireless network interface.

Thank you in advance for any kicks in the right direction you may be able to provide.
Posts: 2
Joined: Fri Oct 05, 2012 12:07 am

Occidentalis 0.2 WiFi Connect to Hidden SSID ** SOLVED **

by qbgroup on Sat Oct 27, 2012 10:47 am

Hi! I was having problems connecting my Miniature WiFi (product 814) to my wireless network. The problem I discovered is I intentionally configured my access point not to broadcase the router's SSID. I understand that this does not protect my network from accomplised hackers. BTW the router is configured to use WPA2 Personal encryption.

I found this post on Pinguy OS Forum (Many thanks!) The full link is http://forum.pinguyos.com/Thread-Setting-up-WiFi-with-WPA2-Personal-AES-with-no-ESSID-broadcasting .

I applied the following edits to the /etc/networking/interfaces file and after restarting the network the adapter connected to my network.
auto wlan0allow-hotplug wlan0
iface wlan0 inet dhcp
#add these additional lines
wpa-ap-scan 1
wpa-scan ssid 1
wpa-group CCMP
wpa-pairwise CCMP
wpa-ssid <your_essid>
wpa-psk <your_psk_key_in_ascii>

Special note, when you enter your essid and password do not enclose them in quote or brackets. Both the ESSID and the PSK (e.g. password) are case sensitive.

Hope this help. :D

Posts: 13
Joined: Sat Jan 29, 2011 9:50 pm

Re: Miniature WiFi (814)

by sdreher71 on Tue Dec 25, 2012 2:17 pm

I struggled for a bit to get my miniature wifi dongle to connect. After looking at the /etc/udev/rules.d/70-persistent-net.rules file and comparing the hardware addresses for wlan0 and wlan1 in that file with the address of the dongle according to ifconfig, I realized the dongle matched wlan1, not wlan0. After changing all instances of wlan0 to wlan1 in my /etc/network/interfaces file, and adding my SSID and passphrase, I rebooted, and it works like a charm.

Posts: 4
Joined: Tue Oct 23, 2012 9:57 pm

Re: Miniature WiFi (814)

by carldea on Sun Dec 30, 2012 9:24 pm

Hello all,
I have recently purchased the WiFi (814) adapterhttp://www.adafruit.com/products/814 from Adafruit for my RaspBerry Pi on the Wheezy Raspbian distribution of Linux at raspberrypi.org http://downloads.raspberrypi.org/images/raspbian/2012-10-28-wheezy-raspbian/2012-10-28-wheezy-raspbian.zip and happen to get WiFi to work successfully, however when I use the HDMI cable for my monitor and reboot the Pi the WiFi adapter stops working (conflicting). My intent is to create projects which uses Java 8 and JavaFX 8 on a Raspberry Pi having a WiFi adapter.

Below are my steps to get WiFi working:
1) Install or obtain Raspbian linux onto an SD card (link above).
2) Connect using Ethernet to your router and Pi.
3) Connect power 5v 1amp or 2amp mini usb to Rpi.
4) Follow Stephen Chin's steps: http://javafx.steveonjava.com/javafx-on ... asy-steps/ This will help you install Raspbian and Java8/JavaFX 8.
5) setup your network interface file settings like below.
On another machine on the network ssh into the Rpi and edit the interfaces file. (assuming you backed up the file)
* Note: To locate your raspberry pi on your home network go to your (gateway) router web admin interface and look at the computers connected on the network. You should see the raspberry pi and its ip address (w/ mac address). You may want to make the raspberry pi a static ip (reserved ip) on the router (via dhcp) so you won't have to look up the ip address in the later steps.
Once the ip is located ssh into the machine:

$ ssh -l pi
pi@'s password:
Linux raspberrypi 3.2.27+ #250 PREEMPT Thu Oct 18 19:03:02 BST 2012 armv6l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Mon Dec 17 06:29:51 2012

pi@raspberrypi ~ $ sudo nano /etc/network/interfaces

Next, enter the following into the file then save and exit.

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-scan-ssid 1
wpa-ssid mysid
wpa-psk passphrase

6) Unplug power supply, Unplug Ethernet
7) Plug in the WiFi adapter
8 ) Reconnect usb power (let it boot and wait for awhile 1-3 minutes).
9) Locate the ip and ssh into your Rpi.

Once confirmed that you can login the Pi, You should be ready to compile and run Java 8 applications!
The next steps is how to reproduce my problem when Wifi and the HDMI are plugged into the RaspBerryPi.

1) Unplug power supply
2) Connect usb keyboard, WiFi Adapter and hdmi cable to the Pi and monitor (hdmi to dvi adapter).
3) Select monitor to DVI-D to view the Rpi booting up.
4) Replug power supply to restart Rpi.
5) Observe messages relating to setting up and initializing the WiFi adapter.
6) Follow step 9 above on another computer on the same network (domain). Here is were I am unable to ssh into the Rpi.

I hope others can assist or have advice to give. Much is appreciated.


http://javafx.steveonjava.com/javafx-on ... asy-steps/
https://blogs.oracle.com/javajungle/ent ... rry_pi_for
http://harmoniccode.blogspot.de/2012/11 ... art-i.html
http://jdk8.java.net/fxarmpreview/javaf ... eview.html
http://www.savagehomeautomation.com/pro ... velop.html
http://jdk8.java.net/fxarmpreview/javaf ... eview.html
Posts: 1
Joined: Sun Dec 30, 2012 6:48 pm

Please be positive and constructive with your questions and comments.