USB to TTL Serial Cable - no keyboard or mouse input
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/
Please be positive and constructive with your questions and comments.

USB to TTL Serial Cable - no keyboard or mouse input

by maglobal on Sun Apr 07, 2013 3:21 pm

Received my USB to TTL serial cable yesterday.

Connected it my PI.

Setup Putty as specified.... anc confirmed COM10 in my control Panel on Windows XP,
115200 8 N 1 No Flow Control.

Have it plugged in correctly to PI.

The terminal window opens up and I get a cursor....session is open...only problem is I get no response from my keyboard...hitting return key does nothing.

When I click with my mouse...the line gets grey but no action.

When I shutdown and restart, however, the console routine...lot of lines... starts-up displays but still no response to keyboard and/or mouseclick.

I am using a wireless usb mouse and keyboard on my pc...could that be the issue?

the PI startup script shows:

[ 0.000000] Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708.boardrev=0xf bcm2708.serial=0xbdc4fbb6 smsc95xx.macaddr=B8:27:EB:C4:FB:B6 sdhci-bcm2708.emmc_clock_freq=100000000 vc_mem.mem_base=0x1c000000 vc_mem.mem_size=0x20000000 dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait

Windows Device manager Prolific USB to Serial Version Date 2/5/2013

Help! I have had the console working with a usb mouse and tv plugged into the PI...not desireable for me because oflocation of TV....this would be a great solution...but...??? could it be my cable?
Posts: 1
Joined: Mon Apr 01, 2013 9:21 am

Re: USB to TTL Serial Cable - no keyboard or mouse input

by cstratton on Mon Apr 08, 2013 10:06 am

First you should not expect the mouse to work over the serial terminal session. When you use this, you are basically following the in the tradition of using a mechanical paper-printing teletype to connect to a remove computer, and those didn't exactly have mice or GUIs.

Of more concern is the non-response to keystrokes. There are three general issues to look into there:

1) The baud rate might be set incorrectly, however the printing of boot messages hints that this is likely not the case

2) You may have connected to the pi's serial output, but not connected to the wire to its serial input (perhaps you connected it elsewhere by mistake)

3) The PC may not be actually sending characters, if it is expecting hardware control signals to be set by the remote system first. Check in the settings of your serial program. You may also want to try disconnecting the USB serial cable from the pi, and holding a jumper between it's transmit and receive pins - when you do that, anything you type in the terminal program should loop back and display.

4) Finally, if you get characters echoed by the pi but no response to commands, you may not have a suitable mapping of the return key to a line ending recognized by the pi - it may be expecting a newline character. Try both control-J and control-M as an experimental alternative, and see if either gets you a response. If so, try changing your carriage return / line feed mapping.

Posts: 284
Joined: Wed Sep 29, 2010 3:52 pm

Re: USB to TTL Serial Cable - no keyboard or mouse input

by pmussman on Sat Apr 20, 2013 10:28 am

Excellent response.....

I did the jumper test and it was successful using the CTRL J and CTRL M.

I then carefully checked to make sure I had the cable connected to the PI correctly and rebooted.

I replaced my wireless keyboard with a standard DELL usb keyboard.

Same result.
....I got the startup script but at the end it hangs up after

[ 2.999742] smsc95xx v1.0.4
[ 3.078620] smsc95xx 1-1.1:1.0: eth0: register 'smsc95xx' at usb-bcm2708_usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:c4:fb:b6
[ 3.869495] udevd[137]: starting version 175
[ 16.221795] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[ 16.702811] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[ 17.483432] bcm2835 ALSA card created!
[ 17.489692] bcm2835 ALSA chip created!
[ 17.510345] bcm2835 ALSA chip created!
[ 17.520571] bcm2835 ALSA chip created!
[ 17.528708] bcm2835 ALSA chip created!
[ 17.536738] bcm2835 ALSA chip created!
[ 17.544629] bcm2835 ALSA chip created!
[ 17.552341] bcm2835 ALSA chip created!

So it appears my keyboard sends CR and LF with the CTRL J M options when jumpered but not when pi connected.

More frustration....I must be missing something obvious? Thank you for your support.
Posts: 1
Joined: Sun Apr 07, 2013 3:00 pm

Please be positive and constructive with your questions and comments.