0

FLORA: USB device not recognized
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

FLORA: USB device not recognized

by mkuschaefer on Sat Jan 06, 2018 8:39 am

Heya,

I got myself a FLORA v3 for Christmas and was finally able to give it a try. As some who's still at the beginning, it is fun to work with.
So I followed the instructions of the 'Getting started with FLORA' page and successfully tried some of the examples. I also experimented with some of my own sketches using the onboard LED and NeoPixel and it worked fine.

However, all of a sudden the FLORA was no longer recognised by my OS. I'm using Windows 10 by the way. The onboard power LED is turned on and glowing green, no other onboard LED is reacting.
The error message 'USB device not recognized' is appearing and in the device manager the item 'Unknown USB Device (Device Descriptor Request Failed)' is shown under the Universal Serial Bus controllers.
The outcome does not change if I'm resetting the device or using another USB cable or computer to hook it up with. In all those cases the device is still not recognised.

I attached a photo of the FLORA in question in it's pink baggy home:
20180106_132450.jpg
20180106_132450.jpg (252.57 KiB) Viewed 119 times


The support forum has a thread with what appears to be a similar problem, which concluded that the hardware was faulty (see link here: https://forums.adafruit.com/viewtopic.php?f=51&t=124523&p=623811&hilit=not+recognized#p621668), but I hope of course that this is not the case and that there's a fix that I just do not know of.

So, how can I fix this issue? Unfortunately, even after consulting the support forum and googling the issue I have not found a solution that worked for me yet.

Thank you very much for your help!

Cheers

mkuschaefer
 
Posts: 4
Joined: Sat Jan 06, 2018 7:59 am

Re: FLORA: USB device not recognized

by adafruit_support_carter on Fri Jan 12, 2018 3:47 pm

That's a bummer that it was working and then stopped working. Can you correlate that to anything? Like what was the program you last uploaded that worked?

adafruit_support_carter
 
Posts: 3605
Joined: Tue Nov 29, 2016 2:45 pm

Re: FLORA: USB device not recognized

by mkuschaefer on Fri Jan 12, 2018 4:31 pm

Yeah, it is. But I am confident that we can fix it.

No, unfortunately I am not sure what might have caused it. Let me try to remember the last few things that I tried to do with the device in that particular session:
- Adapted a sketch for letting the NeoPixel fade and altered it while watching the changes with the serial plotter,
- Letting the NeoPixel flash in different patterns using the delay function,
- Tried to upload the last sketch before it stoped working and was wondering why the Arduino IDE changed the serial port,
- Switched the serial port back to the correct one and received the error message mentioned in my former post.

Apart from this I cannot remember anything special.
Any idea out of experience what it might be?

Thank you very much for our help!

mkuschaefer
 
Posts: 4
Joined: Sat Jan 06, 2018 7:59 am

Re: FLORA: USB device not recognized

by adafruit_support_carter on Fri Jan 12, 2018 4:57 pm

- Tried to upload the last sketch before it stoped working and was wondering why the Arduino IDE changed the serial port,

This can happen when the Serial Monitor is still open and the FLORA get's assigned a new port after uploading a new sketch.

The outcome does not change if I'm resetting the device or using another USB cable or computer to hook it up with. In all those cases the device is still not recognised.

This sounds like the problem is more than just the software getting a little wrapped around the axle. USB cables and even USB ports (USB 2.0 ports work better) can all cause issues. Let's go back to what seemed to work before though. Same cable, computer, port, etc.

What version of the Arduino IDE are you running? And you've gone through all this setup the drivers and board support packages, etc?
https://learn.adafruit.com/getting-star ... a/overview

Can you post a screen shot of your Device Manager with the FLORA plugged in?

adafruit_support_carter
 
Posts: 3605
Joined: Tue Nov 29, 2016 2:45 pm

Re: FLORA: USB device not recognized

by mkuschaefer on Fri Jan 12, 2018 5:33 pm

It is Arduino IDE Version 1.8.5. I have gone through all this setup the drivers and board support packages, and all. Even gone through it once more.

Here is the screenshot you have asked for:
Capture.JPG
Capture.JPG (84.02 KiB) Viewed 71 times

mkuschaefer
 
Posts: 4
Joined: Sat Jan 06, 2018 7:59 am

Re: FLORA: USB device not recognized

by adafruit_support_carter on Fri Jan 12, 2018 6:38 pm

Hmmm. Try this little dance and see if it works / helps: Press and hold the reset button on the FLORA. Click on the upload button. After it compiles and as soon as it says Uploading..., release the reset button.

Use the blink example sketch for uploading:
https://learn.adafruit.com/getting-star ... nboard-led

adafruit_support_carter
 
Posts: 3605
Joined: Tue Nov 29, 2016 2:45 pm

Re: FLORA: USB device not recognized

by mkuschaefer on Fri Jan 12, 2018 7:14 pm

It worked! Than you very much!
I have tested it with a few quick sketches controlling the onboard LED and NeoPixel, but apart from one time when Arduino IDE told me once that the device is not available it went without a problem.

What do you think caused this problem then?

Thanks again!

mkuschaefer
 
Posts: 4
Joined: Sat Jan 06, 2018 7:59 am

Re: FLORA: USB device not recognized

by adafruit_support_carter on Fri Jan 12, 2018 7:19 pm

What do you think caused this problem then?

Just a "feature" of the 32u4 and Windows. Glad that trick worked!

adafruit_support_carter
 
Posts: 3605
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.