0

GEMMA M0 turns off when connecting circuit - color touch pen
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

GEMMA M0 turns off when connecting circuit - color touch pen

by usafmx on Tue Dec 04, 2018 12:13 pm

Hi, I've searched the forum for my issue but no luck.

I am assembling the Gemma color touch pendant project. https://learn.adafruit.com/pages/11928/ ... 3/download
I uploaded the sketch successfully and am connecting the circuit with alligator clip leads (1 foot long).
As soon as i connect either the V or Gnd at the Gemma, the board shuts down with a quick flash of both leds.

I can monitor the serial output through the IDE up until i connect the circuit.
The same result for a second board, so board seems fine. I have subbed in a second set of neopixel rings with same result.
same result with USB or Battery power.

Have triple checked the circuit arrangement and applied some logic as well...the only thing I can think of is the leads are too long.

my next step is to solder the project up and give it a go with the proscribed shorter leads.

Am I on track to solving this?
Thanks!
- Paul

usafmx
 
Posts: 12
Joined: Sat Dec 10, 2011 3:05 pm
Location: Florida

Re: GEMMA M0 turns off when connecting circuit - color touch

by adafruit_support_carter on Tue Dec 04, 2018 2:41 pm

Sounds like you are working on this guide:
https://learn.adafruit.com/gemma-color- ... troduction

Can you post a photo of your setup showing how you are trying to connect everything.

adafruit_support_carter
 
Posts: 7676
Joined: Tue Nov 29, 2016 2:45 pm

Re: GEMMA M0 turns off when connecting circuit - color touch

by usafmx on Thu Dec 06, 2018 11:36 am

from the layout...same but with alligator leads
[imgfile:///C:/Users/Paul/Desktop/gemma%20pen/pendantcircuit.JPG][/img]

usafmx
 
Posts: 12
Joined: Sat Dec 10, 2011 3:05 pm
Location: Florida

Re: GEMMA M0 turns off when connecting circuit - color touch

by usafmx on Thu Dec 06, 2018 11:37 am

better image of circuit from the learning site
https://learn.adafruit.com/gemma-color- ... ng-diagram

usafmx
 
Posts: 12
Joined: Sat Dec 10, 2011 3:05 pm
Location: Florida

Re: GEMMA M0 turns off when connecting circuit - color touch

by adafruit_support_carter on Thu Dec 06, 2018 12:22 pm

Your photo didn't attach for some reason. Please try again and let me know if uploading isn't working for some reason. Seeing what your specific setup looks like will help us see if there are any issues.

adafruit_support_carter
 
Posts: 7676
Joined: Tue Nov 29, 2016 2:45 pm

Re: GEMMA M0 turns off when connecting circuit - color touch

by usafmx on Thu Dec 06, 2018 12:59 pm

the image is the same as the fritzing diagram from the guide.
https://learn.adafruit.com/gemma-color- ... ng-diagram

I have verified it is wired per the diagram

my major concern is about using the longer alligator clips for prototyping, and it's effect on the board / circuit.

thanks!

usafmx
 
Posts: 12
Joined: Sat Dec 10, 2011 3:05 pm
Location: Florida

Re: GEMMA M0 turns off when connecting circuit - color touch

by adafruit_support_carter on Thu Dec 06, 2018 1:00 pm

I need to see your actual setup.

adafruit_support_carter
 
Posts: 7676
Joined: Tue Nov 29, 2016 2:45 pm

Re: GEMMA M0 turns off when connecting circuit - color touch

by usafmx on Sun Dec 09, 2018 7:03 pm

Update: after wiring/soldering with short leads, the Gemma powered up.
it appears the long alligator clip test leads created far too much voltage drop to power the circuit.
thanks.

usafmx
 
Posts: 12
Joined: Sat Dec 10, 2011 3:05 pm
Location: Florida

Please be positive and constructive with your questions and comments.