Black Lives Matter - Action and Equality. ... Adafruit is open and shipping.
0

Neopixel Jewel not lighting up?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Neopixel Jewel not lighting up?

by miezukuri on Tue Mar 10, 2020 1:30 am

Hi there! I'm really, really, super new at this, and I don't know what I'm doing. That disclaimer out of the way, I bought a neopixel jewel and a gemma M0 microcontroller. I connected them using this wiring diagram: https://learn.adafruit.com/10-minute-ne ... e/assembly

I plugged it into power, and the have a steady green light on the Gemma M0, but absolutely nothing on the Jewel. I tried updating to the latest version of Circuit Python, and the corresponding libraries, but still no life from my Jewel. I tried running some simple test code on it, and still nothing. It just won't light up at all.

Poking around some more, I found a different wiring diagram here, and tried it using the corresponding code: https://learn.adafruit.com/gemma-m0-she ... it-diagram

Still nothing. Is my jewel broken?

miezukuri
 
Posts: 5
Joined: Tue Mar 10, 2020 1:24 am

Re: Neopixel Jewel not lighting up?

by adafruit_support_bill on Tue Mar 10, 2020 6:30 am

Please post a photo or two showing your soldering and connections.

adafruit_support_bill
 
Posts: 77951
Joined: Sat Feb 07, 2009 10:11 am

Re: Neopixel Jewel not lighting up?

by miezukuri on Tue Mar 10, 2020 3:35 pm

Image
Image
Image

miezukuri
 
Posts: 5
Joined: Tue Mar 10, 2020 1:24 am

Re: Neopixel Jewel not lighting up?

by adafruit_support_bill on Tue Mar 10, 2020 3:59 pm

The connections look correct. The second ground wire is not necessary, but it doesn't hurt anything either.
Do you have a battery for it? If so, try powering with the battery instead of the USB.

adafruit_support_bill
 
Posts: 77951
Joined: Sat Feb 07, 2009 10:11 am

Re: Neopixel Jewel not lighting up?

by caitlinsdad on Tue Mar 10, 2020 5:38 pm

Also to note, the on/off switch needs to be in the ON position. On my Gemma M0, it seems to turn the whole board on or off, including supplying power through the Vout pin. Although, switching it off also turns off the green light so I'm not sure if you tried that already and saw the green power light. On a Flora board, an on/off switch only controls the board when on battery power. Good luck.

caitlinsdad
 
Posts: 600
Joined: Fri Feb 24, 2012 4:23 pm

Re: Neopixel Jewel not lighting up?

by miezukuri on Tue Mar 10, 2020 9:13 pm

Oh, no, the switch is definitely on when I'm saying the Jewel doesn't light up -- and the Gemma does. It's just in the off position because I turn it off when it's not connected to a power source.

miezukuri
 
Posts: 5
Joined: Tue Mar 10, 2020 1:24 am

Re: Neopixel Jewel not lighting up?

by miezukuri on Tue Mar 10, 2020 9:26 pm

adafruit_support_bill wrote:The connections look correct. The second ground wire is not necessary, but it doesn't hurt anything either.
Do you have a battery for it? If so, try powering with the battery instead of the USB.


Just tried that, and I get a solid green light on the Gemma, but nothing from the Jewel.

miezukuri
 
Posts: 5
Joined: Tue Mar 10, 2020 1:24 am

Re: Neopixel Jewel not lighting up?

by adafruit_support_bill on Wed Mar 11, 2020 6:08 am

OK. We can try replacing the Jewel.
Please contact support@adafruit.com with a link to this thread.

adafruit_support_bill
 
Posts: 77951
Joined: Sat Feb 07, 2009 10:11 am

Re: Neopixel Jewel not lighting up?

by miezukuri on Mon Mar 16, 2020 10:25 pm

The new one works perfectly! Thank you so much!

miezukuri
 
Posts: 5
Joined: Tue Mar 10, 2020 1:24 am

Re: Neopixel Jewel not lighting up?

by adafruit_support_bill on Tue Mar 17, 2020 6:25 am

Good to hear. Thanks for the update!

adafruit_support_bill
 
Posts: 77951
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.