0

Windows Gemma-ified Arduino - Expected 4 got 5 errors
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Windows Gemma-ified Arduino - Expected 4 got 5 errors

by bristolfashion on Thu Mar 13, 2014 6:13 am

We have been preparing lots of Windows devices (Vista, XP, Win7) to run Gemma as part of a series of workshops. Gemma is really great and inexpensive for teaching code etc.

We use the Adafruit Gemma-ified download of Arduino. The installations go pretty smoothly, but we almost always have to do the Chip Erase Delay fix in avrdude.conf or we get Expected 4 got 5 errors when trying to upload. Making that change provides an instant fix.

So, the question is, would it be a good idea to make that change in Adafruit's Gemmified Arduino download, rather than some/many users having to do it every time? Or, would that then cause problems for other devices?

David

NB We keep a webpage recording some of our install issues and fixes, which I give below in case it is useful to others. :D

http://www.electronicfashion.co.uk/technical/gemmasuccessfulwindowsinstallations.htm
bristolfashion
 
Posts: 4
Joined: Fri Jan 31, 2014 3:23 pm

Re: Windows Gemma-ified Arduino - Expected 4 got 5 errors

by adafruit_support_bill on Thu Mar 13, 2014 6:34 am

Thanks for the suggestions and the link. I will pass them along to the team. :)

adafruit_support_bill
 
Posts: 68457
Joined: Sat Feb 07, 2009 10:11 am

Re: Windows Gemma-ified Arduino - Expected 4 got 5 errors

by adafruit on Thu Mar 13, 2014 1:42 pm

Thanks, can you test out our new 3/13/14 windows download here?
http://learn.adafruit.com/introducing-g ... rduino-ide
it should have that already in it :) let us know if it doesnt automatically work for you!

adafruit
 
Posts: 12147
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: Windows Gemma-ified Arduino - Expected 4 got 5 errors

by bristolfashion on Fri Mar 14, 2014 5:52 am

Brilliant. I will download and let you know how we get on.
bristolfashion
 
Posts: 4
Joined: Fri Jan 31, 2014 3:23 pm

Re: Windows Gemma-ified Arduino - Expected 4 got 5 errors

by bristolfashion on Fri Mar 14, 2014 3:41 pm

OK. So I downloaded the new version with yesterday's date. As far as I can see the avrdude.conf file still has the chip_erase_delay for attiny85 set at the old value of 90000. So we got the usual expected 4 got 5 problems until we changed it as below.

" .. go to a section called 'attiny85' then a few lines under that see 'chip erase delay = 90000' . Change the 9 to a 4. "

So, not quite there. Sorry. :(
bristolfashion
 
Posts: 4
Joined: Fri Jan 31, 2014 3:23 pm

Re: Windows Gemma-ified Arduino - Expected 4 got 5 errors

by adafruit on Sat Mar 15, 2014 10:01 pm

ooof of course did not save the file. can you try again? same download, i just replaced it!

adafruit
 
Posts: 12147
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: Windows Gemma-ified Arduino - Expected 4 got 5 errors

by bristolfashion on Mon Mar 17, 2014 11:17 am

Fantastic. Just tried it on a previously untouched PC (Win 7 Pro) and the install was flawless - no need for any changes. Gemma was uploaded to and blinking to order in a few minutes from starting. Many thanks. :D :D :D
bristolfashion
 
Posts: 4
Joined: Fri Jan 31, 2014 3:23 pm

Please be positive and constructive with your questions and comments.