0

Trinket M0 compile error
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Trinket M0 compile error

by garyhlucas on Wed Jan 30, 2019 6:44 pm

I have apparently messed things up in moving some files and I now get this error message:

Arduino: 1.8.8 (Windows 7), Board: "Arduino M0"

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\Gary\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\Gary\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Gary\Dropbox (ITP,LLC)\Engineering\R&D\Arduino\Sketches\libraries -fqbn=arduino:samd:mzero_bl -ide-version=10808 -build-path C:\Users\Gary\AppData\Local\Temp\arduino_build_427592 -warnings=all -build-cache C:\Users\Gary\AppData\Local\Temp\arduino_cache_989602 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Users\Gary\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.2.0 -prefs=runtime.tools.arduinoOTA-1.2.0.path=C:\Users\Gary\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.2.0 -prefs=runtime.tools.openocd.path=C:\Users\Gary\AppData\Local\Arduino15\packages\arduino\tools\openocd\0.9.0-arduino6-static -prefs=runtime.tools.openocd-0.9.0-arduino6-static.path=C:\Users\Gary\AppData\Local\Arduino15\packages\arduino\tools\openocd\0.9.0-arduino6-static -prefs=runtime.tools.bossac.path=C:\Users\Gary\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.7.0 -prefs=runtime.tools.bossac-1.7.0.path=C:\Users\Gary\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.7.0 -prefs=runtime.tools.arm-none-eabi-gcc.path=C:\Users\Gary\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.arm-none-eabi-gcc-4.8.3-2014q1.path=C:\Users\Gary\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.CMSIS.path=C:\Users\Gary\AppData\Local\Arduino15\packages\arduino\tools\CMSIS\4.5.0 -prefs=runtime.tools.CMSIS-4.5.0.path=C:\Users\Gary\AppData\Local\Arduino15\packages\arduino\tools\CMSIS\4.5.0 -prefs=runtime.tools.CMSIS-Atmel.path=C:\Users\Gary\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.1.0 -prefs=runtime.tools.CMSIS-Atmel-1.1.0.path=C:\Users\Gary\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.1.0 -verbose C:\Users\Gary\AppData\Local\Temp\arduino_modified_sketch_204119\ColorSensor_TrinketM0__013019.ino
open C:\Users\Gary\Dropbox (ITP: The system cannot find the file specified.

Error compiling for board Arduino M0.

So what file can't it find?

After all these years I still hate the person that wrote the "file not found" error message. So you went looking for the file someplace and couldn't find it and you had the file name and where you looked but you won't reveal that?

Thanks for any help. I got away from this project for awhile and my brain needs a reboot too.

garyhlucas
 
Posts: 17
Joined: Mon May 21, 2018 9:00 pm

Re: Trinket M0 compile error

by adafruit_support_carter on Wed Jan 30, 2019 6:49 pm

Looks like you've selected a different board. Go in to the boards menu and change the selection:
Tools -> Board -> Adafruit Trinket M0

adafruit_support_carter
 
Posts: 11090
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.