Black Lives Matter - Action and Equality. ... Adafruit is open and shipping.
0

Trinket 5V all NeoPixels light up
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Trinket 5V all NeoPixels light up

by sahteck on Wed May 06, 2020 3:29 am

I'm trying to test using a 5v Trinket with a NeoPixel strip.

The strip is 60 NeoPixels long, of the 30/m variety. I wired the appropriate things to ground, USB, and #0 or #1 (tried using different PWM pins) and running the simple code in the NeoPixel example, but for some reason the whole strip lights up either white or red when I move it a little bit. Sometimes only the first pixel will be green.

I haven't soldered anything, just made sure the wires made good contact with the appropriate pins on the Trinket and tried breadboarding (there's a few inches of wire between the strip and Trinket, if that's relevant, but it can be reduced). The code has it declared to be a strip of 16 pixels, and when I use it with my Arduino Uno it behaves properly.

Any suggestions are welcome.

sahteck
 
Posts: 4
Joined: Wed May 06, 2020 3:22 am

Re: Trinket 5V all NeoPixels light up

by dastels on Wed May 06, 2020 9:20 am

It does sound like a bad connection. Especially as it changes when things are moved.

I suggest you solder the connections.

Dave

dastels
 
Posts: 3023
Joined: Tue Oct 20, 2015 3:22 pm

Re: Trinket 5V all NeoPixels light up

by sahteck on Wed May 06, 2020 12:43 pm

Resolved once I added headers! Thanks for pointing out the connection issue.

sahteck
 
Posts: 4
Joined: Wed May 06, 2020 3:22 am

Please be positive and constructive with your questions and comments.