0

Removed ESP8266MOD from bad device
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Removed ESP8266MOD from bad device

by blakebr on Mon Sep 13, 2021 8:26 pm

Hello,

A pair of devices went bad so I took them apart. I always do that to learn how the pros do things and get parts. I found an ESP8266MOD in each; so I removed them. They are mounted to a board with pins. Only 5 pins are brought out. They are labeled 3.3V, GND, SW, LED, and PWM. Through continuity testing:
SW looks to be connected to MOSI/GPIO13.
LED looks to be connected to SDA/GPIO04.
PWM looks to be connected to MISO/GPIO12.
ENABLE looks to be connected to 3.3 Volts.
CS/TXD2/GPIO15 looks to be connected to GND.

Are these WiFi parts useable or have they been dedicated to their prior use and probably not reusable?

P.S. If I give them 3.3 volts they will hop on my WiFI network and grab an IP address. So they appear to be functioning.

Bruce

blakebr
 
Posts: 88
Joined: Tue Apr 17, 2012 6:23 pm

Re: Removed ESP8266MOD from bad device

by adafruit_support_mike on Tue Sep 14, 2021 8:37 pm

I don't know of any ESP8266 that's one-time programmable, so they should be usable.

adafruit_support_mike
 
Posts: 63701
Joined: Thu Feb 11, 2010 2:51 pm

Re: Removed ESP8266MOD from bad device

by blakebr on Tue Sep 14, 2021 8:58 pm

Thanks

blakebr
 
Posts: 88
Joined: Tue Apr 17, 2012 6:23 pm

Please be positive and constructive with your questions and comments.