Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

WINC1500 WiFi Shield Programmer not responding...
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

WINC1500 WiFi Shield Programmer not responding...

by Joelgene on Wed Feb 12, 2020 2:08 pm

I purchased the Adafruit WINC1500 WiFi Shield from Amazon a few weeks back. I am unable to run the WiFiSSLClient example from the WiFi101 library. The WiFiWebClient example works fine.

This site https://learn.adafruit.com/adafruit-winc1500-wifi-shield-for-arduino/updating-ssl-certificates says,
"If you're trying to connect to a computer or service via SSL and the connection is failing, you may need to update the certificates built into the WINC1500."

When I use the Firmware Updater tool in the 1.8.11 version of the Arduino IDE the test connection fails. "Programmer not responding"
I have tried this about a dozen times total and still get the same error. I have tried the Beta 1.9.0 IDE as well as versions 1.8.6 and 1.8.5 and still get the same "Programmer not responding".

My hardware is a Ruggeduino Mega with the WINC1500 WiFi Shield from Adafruit using default pins. I have also tried another brand of mega board. Still no success. My Shield is a 19.5.4 version using the version "B" WINC1500 chip.

What am I missing?
Perhaps a solder joint on the Shield that is used during the update but not during other communication?

Any help would be appreciated.

Joelgene
 
Posts: 2
Joined: Tue Feb 11, 2020 5:28 pm

Re: WINC1500 WiFi Shield Programmer not responding...

by Joelgene on Wed Feb 12, 2020 5:42 pm

It is working now. I just needed to try the correct combination. IDE version 1.8.6 worked when I used a different Arduino Mega. It may be an issue with the jumper on the Ruggedcircuits version of the Arduino Mega.

Joelgene
 
Posts: 2
Joined: Tue Feb 11, 2020 5:28 pm

Please be positive and constructive with your questions and comments.