Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Bluefruit LE UART Friend not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Bluefruit LE UART Friend not working

by meggert53150 on Thu Aug 13, 2020 1:30 pm

I recently purchased the subject module for a video series of learning to use the Arduino. When trying to get the module to work nothing happens after I power up the Arduino running a sketch that does a factory reset. When I mean nothing happens, I'm saying that either of the onboard LEDs of the module light up or blink, etc. The instructor points out that the module's red LED is blinking when he gives the Arduino power and says it's ready to connect.

I've checked power to the breadboard, I've switched to a different breadboard, and I've changed out the jumper wires I was using. I don't know what else to try. I think the module is dead.

Any help would be greatly appreciated!

meggert53150
 
Posts: 7
Joined: Tue Jul 21, 2020 11:02 am

Re: Bluefruit LE UART Friend not working

by meggert53150 on Thu Aug 13, 2020 7:19 pm

I just want to add that I have tried the module with a second Arduino and I have the same result.

Thanks,
Mark

meggert53150
 
Posts: 7
Joined: Tue Jul 21, 2020 11:02 am

Re: Bluefruit LE UART Friend not working

by meggert53150 on Fri Aug 21, 2020 7:26 pm

I am bumping this topic as it's been a week since I started it and I'd like to get the item replaced so I can finish my project.

Thank you,
Mark

meggert53150
 
Posts: 7
Joined: Tue Jul 21, 2020 11:02 am

Re: Bluefruit LE UART Friend not working

by meggert53150 on Fri Aug 28, 2020 6:09 pm

I am bumping this again as it's been another week without a response. I did order this item on July 18, 2020 and it has never worked for me. My order number is 2326617-7126611402. May I get some response so that I can get it replaced?

Thank you,
Mark

meggert53150
 
Posts: 7
Joined: Tue Jul 21, 2020 11:02 am

Re: Bluefruit LE UART Friend not working

by meggert53150 on Fri Sep 04, 2020 11:05 am

Another week has come and gone with no response from Adafruit support!

I do have something to report this time. I did purchase and receive another of the Bluefruit LE UART Friend module. And I have used it to complete my project for the class I am taking. Knowing that I have a good module and that my project is properly configured, I replaced the Friend module with the original one and it did not work. This tells me that the module is bad. May I please either have a replacement module or a refund for the bad module?

Thank you,
Mark

meggert53150
 
Posts: 7
Joined: Tue Jul 21, 2020 11:02 am

Re: Bluefruit LE UART Friend not working

by adafruit_support_carter on Fri Sep 04, 2020 3:04 pm

Hey. Sorry for missing this post and lagging in response.

Let's make sure there isn't something hardware related going on. Can you post a photo of the problematic BLE Friend showing how you have everything connected.

adafruit_support_carter
 
Posts: 16922
Joined: Tue Nov 29, 2016 2:45 pm

Re: Bluefruit LE UART Friend not working

by meggert53150 on Fri Sep 04, 2020 5:44 pm

Hello Carter,
Here is a photo of my circuit.
IMG_0132.jpg
IMG_0132.jpg (707.13 KiB) Viewed 37 times

Mark

meggert53150
 
Posts: 7
Joined: Tue Jul 21, 2020 11:02 am

Re: Bluefruit LE UART Friend not working

by adafruit_support_carter on Tue Sep 08, 2020 12:15 pm

Thanks. That all looks fine. Let's see if maybe the module can be recovered. Start by connecting the DFU pin to GND as described here:
https://learn.adafruit.com/introducing- ... tory-reset
Wait several seconds and see if the blue CONN LED will light up at all.

adafruit_support_carter
 
Posts: 16922
Joined: Tue Nov 29, 2016 2:45 pm

Re: Bluefruit LE UART Friend not working

by meggert53150 on Tue Sep 08, 2020 1:01 pm

Hello Carter,
I tried to do a factory reset by connecting the DFU pin to GND as explained in the article and the LEDs did not come on or flash. I also tried the reset with the working module to see what the results should be. And the LEDs did flash properly on the good module.

Thanks,
Mark

meggert53150
 
Posts: 7
Joined: Tue Jul 21, 2020 11:02 am

Re: Bluefruit LE UART Friend not working

by adafruit2 on Tue Sep 08, 2020 2:10 pm

yah lets replace it - email support@adafruit with a link to this trhead for a new UART friend!

adafruit2
Site Admin
 
Posts: 19371
Joined: Fri Mar 11, 2005 7:36 pm

Please be positive and constructive with your questions and comments.