0

Help! Two Bluefruit EZ-Links that will not show serial ports
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Help! Two Bluefruit EZ-Links that will not show serial ports

by sdtrent on Mon Sep 15, 2014 3:32 pm

Last week I ordered a USB 4.0 dongle and two Bluefruit EZ-Link modules to set up wireless programming of an Arduino Pro Mini on my Windows 7 Pro 64-bit PC. Everything went fine through pairing until I checked the property of the EZ-Link under "Devices and Printers". The Hardware tab shows no serial ports under Device Functions. There is nothing showing under Services either. I have tried multiple re-installs of both the USB dongle and the EZ-Link modules with the same results each time.

I decided to test them on a Mac Mini. Oddly enough, one module would pair and one never showed up. On the Mac the first module paired and I was able to program the Arduino Pro Mini. But the second EZ-Link module never showed up on the Mac's bluetooth even after multiple attempts of holding down the pairing button for 5 sec to reset the pairing. When I started testing I was using a Li-ion battery (18650) for power (final application will be battery powered) but switched to a regulated 3.3V supply when I began having trouble. I tried multiple PC restarts and installed the latest Windows updates.

Any suggestions on getting the modules to work on my Windows 7 PC? I want to write a program to provide a UI on the PC for controlling the Arduino outputs and would like to avoid the steep learning curve of learning programming on the Mac.

Thank you for your help,
Shane
Last edited by sdtrent on Tue Sep 16, 2014 5:29 pm, edited 1 time in total.

sdtrent
 
Posts: 3
Joined: Fri Dec 30, 2011 9:01 am

Re: A Tale of Two Bluefruit

by sdtrent on Tue Sep 16, 2014 11:02 am

Hello,

Still trying to get the Bluefruit EZ-Link to work on my Windows 7 PC. Is it possible to connect to the Bluefruit EZ-Link through a FTDI cable and initiate a pairing from the Bluefruit EZ-Link module? This has been suggested for pairing diagnostics on Windows 7.

Thanks,
Shane

sdtrent
 
Posts: 3
Joined: Fri Dec 30, 2011 9:01 am

Re: Help! Two Bluefruit EZ-Links that will not show serial p

by sdtrent on Wed Sep 17, 2014 11:31 am

It appears the missing serial port on the Bluefruit EZ-link module is due to an issue with my Windows 7 desktop. Both EZ-link modules work fine on another Windows 7 PC. Would still appreciate any advice on fixing the Bluetooth on Windows 7 but suspect a clean install wold be required.

Thanks,
Shane

sdtrent
 
Posts: 3
Joined: Fri Dec 30, 2011 9:01 am

Please be positive and constructive with your questions and comments.