0

FONA 800 Not Detecting Confirmed 2G Network,
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

FONA 800 Not Detecting Confirmed 2G Network,

by ddshore on Fri May 19, 2017 8:49 pm

I have several FONA 800H, and I've been trying to connect to the TELCEL network in Mexico. I managed to do this 1 year ago without any trouble, TELCEL still has a 2G network (I called to confirm, and this is their websitehttp://www.telcel.com/mundo_telc ... -cobertura). However, whenever I add my sim and check

AT+COPS?
I get
+COPS: 0
OK


If I check

AT+CREG
The status will alternate between 0 and 2 (meaning, disconnected and searching).
+CREG: 0,0
+CREG: 0,2


If I try to get a listing of networks:
AT+COPS?
I get
+COPS: (1,"MOVISTAR GSM","MOSTAR","33403"),(2,"334050","334050","334050"),,(0-4),(0-2)

I can also get my SIM # without any trouble.

This is the most interesting part, as TELCEL does not appear here! If I get my android phone and connect only through 2G with the same SIM it works perfectly fine. I've tried the same experiment with other SIMs and have changed to different FONAs but the results are always the same. Telcel's network code is 334020, so it does not appear there (I have no clue what 0-4 and 0-2 are).

So:
    The 2G network exists because I can connect to it through android, and TELCEL confirmed it exists and that it is used heavily for machine-to-machine applications.
    The FONA has connected to this network before (although I was in a different part of town. But now I'm in a very populated area so I doubt it's a dead spot).
    The FONA does not detect the TELCEL network
    I've added a 4A USB adapter, in case it was a power problem (which I believe shouldn't make a difference since it is battery operated)

What can I do to debug this? I'm stuck at the moment, it should work fine with TELCEL but the network is nowhere to be found. Could this be a firmware problem? Is there a better way to list the networks that the FONA is finding? What are the (0-4) and (0-2) networks that are detected? Could one of those be TELCEL?

Any help would be greatly appreciated.
Last edited by ddshore on Sat May 20, 2017 6:44 pm, edited 1 time in total.

ddshore
 
Posts: 2
Joined: Mon Jun 22, 2015 5:20 pm

Re: FONA 800 Not Detecting Confirmed 2G Network,

by adafruit2 on Sat May 20, 2017 4:55 pm

hmm - no idea, its completely inside the module. if you have good antenna, right sim, and good battery you should be good to go. could always try to connect to those other networks, see if those work (with a SIM for them)

adafruit2
Site Admin
 
Posts: 14732
Joined: Fri Mar 11, 2005 7:36 pm

Re: FONA 800 Not Detecting Confirmed 2G Network,

by suzetheram on Sat Jun 03, 2017 8:35 pm

I have the exact same problem, and neither connecting to other networks worked.

suzetheram
 
Posts: 3
Joined: Sat Jun 03, 2017 8:29 pm

Please be positive and constructive with your questions and comments.