0

Can't Find FONA - Wired up like example but doesn't seem to
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Can't Find FONA - Wired up like example but doesn't seem to

by Lukino on Fri Nov 10, 2017 9:07 am

Hello,

I just purchased the FONA 3g. I wired it up according to the example. The only change I made to the example code was to switch to the 3g as per the instructions.

Here are photos of the connections. I am not sure what to do at this point. When I run serial it says "Couldn't find FONA" Thank you in advance.

FONA2.jpg
FONA2.jpg (187.96 KiB) Viewed 153 times
FONA3.jpg
FONA3.jpg (167.79 KiB) Viewed 153 times
FONA4.jpg
FONA4.jpg (205.97 KiB) Viewed 153 times

Lukino
 
Posts: 11
Joined: Fri Nov 10, 2017 9:02 am

Re: Can't Find FONA - Wired up like example but doesn't seem

by Lukino on Fri Nov 10, 2017 9:23 am

Hello,

I figured it out. I needed to run the auto baud sketch first. I sent that sketch and now the FONA is recognized. Now I can not get the sim card to be recognized.

Lukino
 
Posts: 11
Joined: Fri Nov 10, 2017 9:02 am

Re: Can't Find FONA - Wired up like example but doesn't seem

by smgs on Thu Nov 23, 2017 9:04 pm

Nice work, looks like nice clean wiring, what are you thinking of doing with your 3G?

smgs
 
Posts: 193
Joined: Thu Dec 10, 2015 7:25 am

Re: Can't Find FONA - Wired up like example but doesn't seem

by Lukino on Wed Dec 06, 2017 7:49 am

Planning on using it to make an interactive LED matrix to display SMS messages. I have the display working with an Arduino, SMS and SD card to save SMSs but now need to get it to work with a Raspberry Pi so I can use MySQL. I can't get a response from the FONA with the Pi but will hopefully figure it out eventually.

Lukino
 
Posts: 11
Joined: Fri Nov 10, 2017 9:02 am

Re: Can't Find FONA - Wired up like example but doesn't seem

by smgs on Wed Dec 06, 2017 7:27 pm

There are a few different version of Pi, which one are you using? Happy to have a look at your setup if you want to try and work through it via the forums.

One of the guys in this thread:
https://forums.adafruit.com/viewtopic.php?f=54&t=109601

Uses an Arduino with a FONA 3G to make MySQL calls, a guy called "m4rtinmp" on page 3 of that thread shows the MySQL code he used.

Cheers

smgs
 
Posts: 193
Joined: Thu Dec 10, 2015 7:25 am

Re: Can't Find FONA - Wired up like example but doesn't seem

by Lukino on Wed Dec 06, 2017 8:30 pm

smgs wrote:There are a few different version of Pi, which one are you using?


I am using a Raspberry Pi 3 with the most recent build of Raspbian called version November 2017 released 2017-11-29 Kernel 4.9

I made the following changes so far:

sudo nano /boot/config.txt

then added the following at the bottom of the file
enable_uart=1
dtoverlay=pi3-disable-bt


sudo nano /boot/cmdline.txt

removed console=serial0,115200

I also ran sudo raspi-config Selected Interfacing Options / Serial then specified NO Serial console and then YES to Serial Port hardware enabled.


To test if I could recieve a serial signal I hooked up my Arduino to the Pi via direct USB. This worked fine.

Then to test the GPIO pins receiving a serial signal I hooked up the Pi to an unpowered Arduino via the GPIO pins as shown.
Pi 3.3v --> Arduino 5v
Pi GND --> Arduino GND
Pi TX --> Arduino RX
Pi RX --> Arduino TX
Those connections get serial data to and from the Arduino.

Hooking up the FONA to the Pi Rx and Tx gets no data from the serial. The FONA works with my Arduino. I can send and receive SMS messages. The Pi works with the Arduino Serial but it does not currently work with the FONA. I must be doing something obvious but don't know.

Thank you for the offer to troubleshoot and thank you for the link to the other thread.

Any suggestions of what to try next are appreciated.

Lukino
 
Posts: 11
Joined: Fri Nov 10, 2017 9:02 am

Re: Can't Find FONA - Wired up like example but doesn't seem

by adafruit_support_mike on Tue Dec 12, 2017 12:31 am

Post a photo showing your hardware and connections when the FONA is connected to the RasPi please. Let's make sure those connections are doing what they should.

adafruit_support_mike
 
Posts: 45954
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.