0

Fona Reliability
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Fona Reliability

by daAdi on Thu Mar 14, 2019 12:52 pm

Hi all,

I have been trying to use a Fona 800 uFL version, and I have been struggling to use it with my arduino nano, it works and it works great, like I use it to transfer data to a server, that I collected from a sensor, but my problem is that it almost never works, one of my recent problems has been that when I connect my system (arduino, fona, and sensor) to power source (my laptop for now), and run the FONAtest example from the FONA library, my Nano says that it can not find the FONA, and that is my issue, since it works on some days, but other days I feel like breaking it.

The sensor I am using a JSN- SR04T, and that is not the problem since I have used it with the arduino only and it works.
I am also nervous to buy another FONA because I think it might be the same, and I have a limited budget for this project.
I am using an Elegoo made Arduino Nano so that might be causing problems, but I highly doubt it.

Also, another problem with my FONA is that, when I connect the GND, and RX,TX, and RST pins (for software serial), the FONA powers on, and works even though the power pin is not connected at all.

Has anyone had similar problems or can someone give me a solution?

Regards,
Adi

daAdi
 
Posts: 3
Joined: Mon Nov 19, 2018 4:48 pm

Re: Fona Reliability

by adafruit_support_mike on Fri Mar 15, 2019 2:02 am

Post a photo showing your hardware and connections and we'll take a look. 800x600 images usually work best.

adafruit_support_mike
 
Posts: 57106
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.