0

fona shield will not work with mega
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: fona shield will not work with mega

by davidsi on Tue Sep 10, 2019 7:28 pm

and I just got the following message:


FONA> N
---> AT+CMGF=1
<--- AT+CMGF=1
Could not read # SMS
FONA> ERROR

+CPIN: READY
UNDER-VOLTAGE POWER DOWN

davidsi
 
Posts: 68
Joined: Tue Oct 01, 2013 8:46 pm

Re: fona shield will not work with mega

by adafruit_support_mike on Tue Sep 10, 2019 8:05 pm

That means the FONA isn't getting enough power from the Lipo. What voltage do you see on the Vio pin?

adafruit_support_mike
 
Posts: 58856
Joined: Thu Feb 11, 2010 2:51 pm

Re: fona shield will not work with mega

by davidsi on Tue Sep 10, 2019 9:35 pm

Vba - Gnd -- 3,3V (by battery)
Vin - Gnd - 4.3V (side pins next to Chrg/Run button)

davidsi
 
Posts: 68
Joined: Tue Oct 01, 2013 8:46 pm

Re: fona shield will not work with mega

by adafruit_support_mike on Wed Sep 11, 2019 11:40 am

Hmm.. post a photo showing your hardware and connections please. 800x600 images usually work best.

adafruit_support_mike
 
Posts: 58856
Joined: Thu Feb 11, 2010 2:51 pm

Re: fona shield will not work with mega

by jwallis on Wed Sep 11, 2019 5:37 pm

I was trying to get my FONA shield working with my mega 2560 and after beating my head on the wall, trying everything I could think of for 3-4 hours, I put the shield on an Uno my friend just happened to give me, and it worked immediately. Strongly suggest you use an Uno unless necessary.

jwallis
 
Posts: 8
Joined: Mon Aug 26, 2019 3:31 am

Re: fona shield will not work with mega

by davidsi on Wed Sep 11, 2019 5:39 pm

been trying that as well and it didn't help

davidsi
 
Posts: 68
Joined: Tue Oct 01, 2013 8:46 pm

Re: fona shield will not work with mega

by davidsi on Thu Sep 12, 2019 2:52 pm

IMG_0286 copy.jpg
IMG_0286 copy.jpg (215.43 KiB) Viewed 70 times

IMG_0286 copy.jpg
IMG_0286 copy.jpg (215.43 KiB) Viewed 70 times
Attachments
IMG_0287 copy.jpg
IMG_0287 copy.jpg (119.1 KiB) Viewed 70 times

davidsi
 
Posts: 68
Joined: Tue Oct 01, 2013 8:46 pm

Re: fona shield will not work with mega

by adafruit_support_mike on Fri Sep 13, 2019 12:52 am

Check your Serial connections. In the photo, it looks like you have TX connected to TX and RX to RX.

Serial connections go TX-to-RX both ways. TX talks, RX listens.

adafruit_support_mike
 
Posts: 58856
Joined: Thu Feb 11, 2010 2:51 pm

Re: fona shield will not work with mega

by davidsi on Fri Sep 13, 2019 1:13 am

no, it's correct. If I turn them around I get no response at all.

davidsi
 
Posts: 68
Joined: Tue Oct 01, 2013 8:46 pm

Re: fona shield will not work with mega

by adafruit_support_mike on Sat Sep 14, 2019 11:32 pm

Okay.

The low power warning has to be related to the LiPo. If you're only seeing 3.3V between the Vbat pin and GND, the LiPo should be almost completely discharged. Let it charge until you see at least 3.7V, or ideally 4.2V.

adafruit_support_mike
 
Posts: 58856
Joined: Thu Feb 11, 2010 2:51 pm

Re: fona shield will not work with mega

by davidsi on Sun Sep 15, 2019 8:48 pm

yup! waiting until 4.2V fixed it. Now I can send an SMS

Thanks for your help

davidsi
 
Posts: 68
Joined: Tue Oct 01, 2013 8:46 pm

Re: fona shield will not work with mega

by adafruit_support_mike on Tue Sep 17, 2019 12:51 am

Glad to hear it's working for you. Happy hacking!

adafruit_support_mike
 
Posts: 58856
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.