Black Lives Matter - Action and Equality. ... Adafruit is open and shipping.
0

Problem getting a fix with FONA 3G
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Problem getting a fix with FONA 3G

by aoumeitounao on Tue Jun 09, 2020 4:06 am

Hi,
I have soldered the 'bias' and connected my fona 3g with an antenna active (https://www.adafruit.com/product/960) ant I did a direct USB connection .
With a command 'at+cgpsinfo' I got this information:

+CGPSINFO
+CGPSINFO:,,,,,,,,
AmpI/AmpQ: 57970/1199
OK

When I typed 'at+CGPSINFOCFG', I found 16 satellites but couldn't get a fix available.

$GPGSV,4,1,16,01,,,,32,,,,24,,,,29,,,*76
$GPGSV,4,2,16,05,,,,18,,,,22,,,,04,,,*70
$GPGSV,4,3,16,11,,,,17,,,,03,,,,12,,,*7F
$GPGSV,4,4,16,30,,,,23,,,,15,,,,27,,,*7D
$GPGGA,,,,,,0,,,,,,,,*66
$GPVTG,,T,,M,,N,,K,N*2C
$GPRMC,,V,,,,,,,,,,N*53
$GPGSA,A,1,,,,,,,,,,,,,,,*1E

I can't get a GPS data even if I took the device to an open field.
Could anyone tell me what I have to do to solve this problem please?

aoumeitounao
 
Posts: 2
Joined: Mon Jun 08, 2020 5:48 am

Re: Problem getting a fix with FONA 3G

by dherrada on Tue Jun 09, 2020 10:48 am

Hey,

So you've discovered the absolute joy that working with GPSes is. Awesome when it works, but when it doesn't, you often have absolutely no clue why.

Now, this may seem like common sense, but here are a few general bits of advice that I've found to make using GPSes easier. First, if it doesn't work, just unplug it. Often a full power cycle with waiting a few seconds while it's off helps. Second, plug your antenna in before you turn it on. My GPS often doesn't see the antenna unless it's plugged in beforehand for whatever reason. Also, if you're using looping code, add a sleep in it, that will also sometimes help.

So, let's assume that those didn't help. I think it's unlikely they will, but every once in a while the issue is something super simple like that. In that case, there isn't a whole lot I can do to help you. GPSes are suuuper hard to debug, but there is some info I can give you that might help you.

Now it seems like you have a decent understanding of NMEA 0183, but I'll go over it anyway, in case it helps.

GPGSV: Satellites in view, the numbers currently on there are total number of messages, message number, satellites in view, and then satellite numbers, and then your checksum. Ideally, you'd want this sentence full.

GPGGA: This is the good one, it's got pretty much everything you need to position yourself, in this case, however, it only has the GPS quality indicator (0 - fix not available) and the checksum.

GPRMC: Recommended minimum navigation information. The second value is the status, V meaning 'Navigation receiver warning'

What I'd reccomend is to have the antenna in a visible spot, get it all setup, connect to power, then wait a few minutes before actually trying to get a read from the GPS module. After that, wait a few more minutes while the GPS is still transmitting the sentences to you. If that doesn't work, then post the code you're using. I know you said you're using direct USB, so maybe post your workflow, how you connect to it, etc. It could also be useful to look at the gps library's simpletest.

Let me know if you've got any more questions, and if this works. Sorry that I wasn't able to give you a more concrete answer.

Possibly useful links:
Person that seems to be having a similar issue https://stackoverflow.com/questions/48663880/gps-nmea-output-getting-valid-gpgsv-but-not-valid-gpgga-gprmc
NMEA 0183 protocol https://www.tronico.fi/OH6NT/docs/NMEA0183.pdf
gps library https://github.com/adafruit/adafruit_circuitpython_gps

dherrada
 
Posts: 73
Joined: Thu Jan 04, 2018 4:59 pm

Re: Problem getting a fix with FONA 3G

by aoumeitounao on Thu Jun 11, 2020 11:29 am

Many thanks for your response!
I tried all your advice but I still can't get a GPS.
Then I connected it with a USB-UART converter cable but the result was the same.
I attached a photo of my USB connection and I don't know if there is something wrong or not.
I think I will buy another active antenna for a second try.
Thanks again!
Attachments
connection.jpg
connection.jpg (407.27 KiB) Viewed 258 times

aoumeitounao
 
Posts: 2
Joined: Mon Jun 08, 2020 5:48 am

Re: Problem getting a fix with FONA 3G

by dherrada on Thu Jun 11, 2020 11:39 am

Ok. Good luck and if you're able to find the issue, definitely let me know because I'm quite interested in finding out what it was.

One more thing to try could be eliminating EMI by turning your phone on airplane mode, disconnecting the cell antenna from the breakout, and turning your laptop on airplane mode as well. Probably won't do anything, but worth a shot before buying a new antenna.

dherrada
 
Posts: 73
Joined: Thu Jan 04, 2018 4:59 pm

Re: Problem getting a fix with FONA 3G

by dherrada on Mon Jun 29, 2020 2:08 pm

Hey, were you able to find the issue? Another user was having the same problem.

dherrada
 
Posts: 73
Joined: Thu Jan 04, 2018 4:59 pm

Please be positive and constructive with your questions and comments.