"freeze" after CPIN-command
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

"freeze" after CPIN-command

by _mirk on Tue Jul 20, 2021 5:28 pm

Im trying to send a SMS with the FONA 3G and it already worked, but sometimes it just doesnt.
Im using a msp430 microcontoller to control the fona via tx and rx. the baudrate is 115200 (Ive also checked 57600 baud and the same error occurs / on 19200 baud nothing seems to work, which is also strange( I set the baudrate with the IPR command)

The first error I found occurs, after I send the CPIN command. After that, in some cases, the FONA wont react to the next (CMGF) command to set the text mode (I have also tried different commands, same behaviour)

The answer after CPIN is:

Then the NET led starts blinking, I wait for a little bit, and try to send the next command; but then I get no answer back

What am I missing here?? Without me changing any setting on the microcontroller or the FONA, sometimes it works and sometimes it doesnt. I am also trying to figure out if the issue is in the controller, but maybe somebody has an Idea why the FONA may behave like this.

Posts: 3
Joined: Wed May 19, 2021 5:11 am

Re: "freeze" after CPIN-command

by adafruit_support_mike on Thu Jul 22, 2021 5:38 am

That may be a sign of the connection to the tower dropping out. That can happen when the line of sight is obstructed, there's a lot of local traffic, or something between the FONA and the tower is generating interference.

Remember that RSSI measures how well the FONA can hear the tower, but says nothing about how well the tower can hear the FONA.

Posts: 63698
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.