0

Adafruit fona 3G american version no NET and PWR light
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Adafruit fona 3G american version no NET and PWR light

by MrAnonim on Fri Nov 29, 2019 11:53 am

I already made a post about this on Jan 7 2019, since then i purchased a second Fona 3G board which has been working great for a couple of months, but then suddenly died like the last board for no reason. Battery has the correct polarities i double checked that before plugging in the board first and the board powered up with no issues. The board has been wired up as per spec sheet
Vio to 5V - Took extra care to make sure its connected
GND to GND
Key to GND - Took extra care to make sure its connected
RX to Digital 2
TX to Digital 3
RST to Digital 4

After the board died, i measured most of the voltages from the board and they match with the voltages from the board schematic. The only issue i found was that on the 74VHCT125PW chip i am not getting anything on Pin2 (PWRSTAT) and Pin3 PWRSTAT_5V. The chip is getting 5V but does not output anything on those two pins. I could really use some help with this.
Thank you
Attachments
adafruit_fona_3G_schem.png
adafruit_fona_3G_schem.png (60.21 KiB) Viewed 180 times

MrAnonim
 
Posts: 8
Joined: Mon Jan 07, 2019 10:56 am

Re: Adafruit fona 3G american version no NET and PWR light

by adafruit_support_mike on Tue Dec 03, 2019 5:40 am

The 74VHCT125 is a 3.3V to 5V level shifter. Pin 2 is the 3.3V input from the SIM5320 module, and pin 3 is the 5V output.

The 3.3V input comes from the SIM5320's GPIO40 pin, and is a general status indicator. If the SIM5320 has power, that pin should go high. The fact that it's low is consistent with the FONA not working, but doesn't have a lot of diagnostic value beyond that.

The next place to check would be the voltages on the SIM5320's pins. You can find the relevant ones on the schematic:

https://cdn-learn.adafruit.com/assets/a ... 1440185454

Especially check the voltage on pin 20, the 1.8V supply for the SIM card. If that's dead, it will suggest a more general problem. Also look at the pins that should be connected to VBAT, and the 2.8V input on pin 44.

adafruit_support_mike
 
Posts: 63053
Joined: Thu Feb 11, 2010 2:51 pm

Re: Adafruit fona 3G american version no NET and PWR light

by MrAnonim on Wed Dec 04, 2019 2:15 pm

I measured the following pins
VBAT 3.7V
on the SIM3520A chip
Pins 38-39=> 2.8V
Pin 44 2.8V
Pin 20 240mV
I measured most of the voltages on the board and i am getting the right voltages except on pin 20 of the SIM3520A and pins 2,3 5 and 6 on the 74vhct125 chip

MrAnonim
 
Posts: 8
Joined: Mon Jan 07, 2019 10:56 am

Please be positive and constructive with your questions and comments.