0

FONA 3G Turning Off Repeatedly
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

FONA 3G Turning Off Repeatedly

by Gacrux on Mon Aug 17, 2020 8:24 am

Product Adafruit FONA 3G Cellular + GPS Breakout (EU Edition)
Ordered from Ebay UK seller rapidonline.

Please see photos attached of setup.
Picture1.jpg
Picture1.jpg (303.3 KiB) Viewed 114 times


The pins for the Fona are attached to soldered points on an e-Paper shield (electrical connectivity has been triple checked and is fine). Pins D2, D3, D4 are all straight passthrough on the eInk board.

I am using the FONAtest program after having run the 3G Baud Rate program.

Issues I am having:
- A lot of the time, timeout is occurring and the board is not being detected
- The red and green lights come on every minute or so but turn off after a few seconds.
- If it does happen to connect, the following will be shown on Serial (note that I tried to call the command b to see the battery voltage. At first it seems to fail but then shows the voltage):

Code: Select all | TOGGLE FULL SIZE
Initializing....(May take 3 seconds)
Attempting to open comm with ATs
   ---> AT
   <---
   ---> AT
   <---
   ---> AT
   <---
   ---> AT
   <---
   ---> AT
   <---
   ---> AT
   <---
   ---> AT
   <---
   ---> AT
   <--- HU*C⸮AT
   ---> AT
   <--- AT
   ---> AT
   <--- AT
   ---> ATE0
   <--- ATE0
   ---> ATE0
   <--- OK
   ---> AT+CVHU=0
   <--- OK
   ---> ATI
   <--- Manufacturer: SIMCOM INCORPORATED
Model: SIMCOM_SIM5320E
Revision: SIM5320E_V1.5
..................deleted for privacy
+GCAP: +CGSM,+FCLASS,+DS

OK

+CPIN: READY

SMS DONE

   ---> AT+CPMS="SM","SM","SM"
   <--- +CPMS: 6,20,6,20,6,20
FONA is OK
Found FONA 3G (European)
   ---> AT+GSN
   <--- 867057031304233
Module ..................deleted for privacy
-------------------------------------
[?] Print this menu
[a] read the ADC 2.8V max (FONA800 & 808)
[b] read the Battery V and % charged
[C] read the SIM CCID
[U] Unlock SIM with PIN code
[i] read RSSI
[n] get Network status
[v] set audio Volume
[V] get Volume
[H] set Headphone audio (FONA800 & 808)
[e] set External audio (FONA800 & 808)
[T] play audio Tone
[P] PWM/Buzzer out (FONA800 & 808)
[f] tune FM radio (FONA800)
[F] turn off FM (FONA800)
[m] set FM volume (FONA800)
[M] get FM volume (FONA800)
[q] get FM station signal level (FONA800)
[c] make phone Call
[A] get call status
[h] Hang up phone
[p] Pick up phone
[N] Number of SMSs
[r] Read SMS #
[R] Read All SMS
[d] Delete SMS #
[s] Send SMS
[u] Send USSD
[y] Enable network time sync (FONA 800 & 808)
[Y] Enable NTP time sync (GPRS FONA 800 & 808)
[t] Get network time
[G] Enable GPRS
[g] Disable GPRS
[l] Query GSMLOC (GPRS)
[w] Read webpage (GPRS)
[W] Post to website (GPRS)
[O] Turn GPS on (FONA 808 & 3G)
[o] Turn GPS off (FONA 808 & 3G)
[L] Query GPS location (FONA 808 & 3G)
[E] Raw NMEA out (FONA808)
[S] create Serial passthru tunnel
-------------------------------------

FONA>
PB DONE
b
   ---> AT+CBC
   <---
Failed to read Batt
   ---> AT+CBC
   <---
Failed to read Batt
FONA>
START

+STIN: 25

+CPIN: READY

SMS DONE

+VOICEMAIL: INIT_STATE, 0, 0

PB DONE
b
   ---> AT+CBC
   <--- AT+CBC
Failed to read Batt
   ---> AT+CBC
   <--- AT+CBC
Failed to read Batt
+CFONA> BC: 2,0,2.696V

OK


Basically, every time the lights flash on, the Serial prints out the following and then the lights go out:
Code: Select all | TOGGLE FULL SIZE
START

+STIN: 25

+CPIN: READY

SMS DONE

+VOICEMAIL: INIT_STATE, 0, 0

PB DONE


This has left the board unusable as I am unable to send commands to it before it turns off.

Please note that the Key pin has been grounded.

Please could I get help with this issue, is it simply that the battery voltage is too low?

Gacrux
 
Posts: 11
Joined: Fri Dec 14, 2018 11:38 am

Re: FONA 3G Turning Off Repeatedly

by Gacrux on Mon Aug 17, 2020 12:07 pm

Just to add to above:
I have found if I tie the 5V pin to the Vio pin I can get the module to remain on (not sure I should be doing that though)
With it on I can communicate with it so I tried to use the FONA_SMS_Reponse sketch - when I send a text, the module seems to detect it, however this happens:
Code: Select all | TOGGLE FULL SIZE
+CMTI: "SM",10
slot: 10
   ---> AT+CMGF=1
   <--- AT+CMGF=1
Didn't find SMS message in slot!
FROM: 867057031304233
   ---> AT+CMGF=1
   <--- AT+CMGF=1
Sending reponse...
   ---> AT+CMGF=1
   <--- AT+CMGF=1
Failed
   ---> AT+CMGF=1
   <--- AT+CMGF=1
Couldn't delete SMS in slot 10
OK
⸮AT+CMGD=?

+CMGD: (0,1,2,3,4,5,6,7,8,9,10),(0-4)

OK


Gacrux
 
Posts: 11
Joined: Fri Dec 14, 2018 11:38 am

Re: FONA 3G Turning Off Repeatedly

by rskup on Mon Aug 17, 2020 4:10 pm

As far as whether to connect the 5V pin to the Vio pin, on my setup the 5V pin on my Uno ties to the 5V pin on the FONA 3G. It's been working fine like that for a couple months now. Also note in Adafruit's FONA 3G tutorial, they have the 5V pin of the Metro tied to the 5V pin on the FONA 3G. So, I think all is fine with your setup concerning that.

However, I'm not familiar with the FONA_SMS_Response sketch and how to use it. In the past I've used X-CTU and the various AT commands from the big SIM5320 AT Command Set manual to read/delete text messages, that worked well for me.

rskup
 
Posts: 60
Joined: Sat Aug 01, 2020 9:04 pm

Please be positive and constructive with your questions and comments.