0

GPS errors when entering AT commands
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

GPS errors when entering AT commands

by mustang65 on Wed Sep 02, 2020 5:52 pm

Sending a text message from FONA works perfectly. GPS, well that is another story. I can not get the GPS to respond... see below error messages.
FONA: Charge light ok, Power light ok, Red light flashing SLOW. Ignore the jumper wires on the board. It has to be something dumb that I overlooked.

Project (Phase1 ): Send GPS and Sensor data from a remote RV via text msg using a Pi (working on)
Project (Phase2): Send GPS and Sensor data from a remote RV to home Pi HHD with text alerts (Future)

Equipment:
RPi 4 (2Gig)
FONA SIM5320A w/2000mAh battery
GPS Active Antenna 23dB gain
Powered by 12VDC RV batteries/SOLAR 24/7/365
Using USB for the FONA connection/Power (may change to Pi's GPIO pins)
Provider=Ting

Thanks in advance for any assistance

GPS Errors:
Code: Select all | TOGGLE FULL SIZE
pi@raspberrypi:~ $ sudo poff fona
/usr/bin/poff: No pppd is running.  None stopped.
pi@raspberrypi:~ $ sudo screen /dev/ttyUSB0 115200

AT+COPS?
+COPS: 0,0,"Ting",0
OK

AT+CGNSPWR?
ERROR

AT+CGNSPWR=1
ERROR

mustang65
 
Posts: 51
Joined: Sat Jan 26, 2013 9:29 pm

Re: GPS errors when entering AT commands

by rskup on Wed Sep 02, 2020 6:56 pm

Not an expert here, but is that a good command for the 5320?

Not seeing CGNSPWR in Simcom's 5320 manual:

https://simcom.ee/documents/SIM5320/SIM ... _V2.05.pdf

rskup
 
Posts: 60
Joined: Sat Aug 01, 2020 9:04 pm

Re: GPS errors when entering AT commands

by mustang65 on Wed Sep 02, 2020 8:04 pm

rskup wrote:Not an expert here, but is that a good command for the 5320?

Not seeing CGNSPWR in Simcom's 5320 manual:

https://simcom.ee/documents/SIM5320/SIM ... _V2.05.pdf



Thanks,
I was using the incorrect command chart that I found. Still have a bunch of commands that the FONA does not like,but I am working with them

mustang65
 
Posts: 51
Joined: Sat Jan 26, 2013 9:29 pm

Re: GPS errors when entering AT commands

by mustang65 on Sat Sep 05, 2020 10:46 am

OK, I am using the correct command sheet for the FONA SIM5320A. Getting more info now.
I am able to text my phone from the FONA, but can not get GPS data. I took the equipment outside yesterday and set it up on my work bench with the active GPS antenna in a clear area in the yard. No obstructions to the sky. AT+CGPSINFO does not return the GPS info only AMPI/AMPQ. I have tried 2 GPS Active antennas with the same results. Is there something that I may have missed in setting it up. I have a solid GREEN LED and flashing RED LED. Not concerned about the DATA portion of the FONA at the moment, working on GPS.

I have searched the NET but came up with nothing.
Any ideas? Tests?
Thanks

Code: Select all | TOGGLE FULL SIZE
OK
AT+COPS?
+COPS: 0,0,"Ting",0

OK

AT+CBC
+CBC: 0,37,3.581V

OK
OK
AT+CGPS?
+CGPS: 0,1

OK
AT+CGPS=1

OK
AT+CGPS?
+CGPS: 1,1

OK
AT+CGPSINFO
+CGPSINFO:,,,,,,,,

AmpI/AmpQ: 430/411

OK

mustang65
 
Posts: 51
Joined: Sat Jan 26, 2013 9:29 pm

Re: GPS errors when entering AT commands

by rskup on Sat Sep 05, 2020 12:25 pm

Haven't tried gps yet, but have often read people not having luck with an active antenna because they didn't solder those "bias" pads near the antenna connector.

Also found this discussion, hope it helps:
https://stackoverflow.com/questions/342 ... gps-module

rskup
 
Posts: 60
Joined: Sat Aug 01, 2020 9:04 pm

Re: GPS errors when entering AT commands

by mustang65 on Sat Sep 05, 2020 7:11 pm

Thanks,
I soldered the pads with no luck. About ready to call it quits with the FONA GPS. Do not feel like trying it on the Arduino.
I tried!!

mustang65
 
Posts: 51
Joined: Sat Jan 26, 2013 9:29 pm

Re: GPS errors when entering AT commands

by mustang65 on Mon Sep 07, 2020 5:59 pm

Not sure if this is possible, but I am running out of time here. I have the FONA 3G with the GPS that no longer gives me readings. Although it can connect to the cell site and send text messages. So 50% of the module is working. I have an Ultimate GPS breakout board at my sons house and was wondering if it is possible to use both on the Pi? I would have the FONA connected to the USB port and the GPS breakout board connected to the GPIO pins on the Pi. I would get the GPS info from the Ultimate GPS breakout board and send the text message using the FONA. First thoughts are that I am going to have an issue on the serial communications part. Maybe a programming nightmare? Just may be to complicated. Unfortunately, I do not have time to order another FONA.
Your thoughts

mustang65
 
Posts: 51
Joined: Sat Jan 26, 2013 9:29 pm

Re: GPS errors when entering AT commands

by mustang65 on Mon Sep 07, 2020 8:02 pm

So as a last ditch effort, I pulled out another Pi 3-B. Made a new image. Connected everything up. Booted the Pi. Connected to the FONA. Able to send a text message. Unable to get sat data. Tried (2) active antennas and (1) passive, the only thing that changed with each antenna was the AmpI/AmpQ. I believe that the GPS portion of the FONA is not working properly

mustang65
 
Posts: 51
Joined: Sat Jan 26, 2013 9:29 pm

Please be positive and constructive with your questions and comments.