0

FONA with SIM900.
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

FONA with SIM900.

by SergioF_ on Tue Jan 26, 2021 4:16 pm

Hello,
my name is Sergio, fron Italy. I tried the "test.ino" example on the FONA library (the last version) with my SIM900 modem and Arduino, but on the serial monitor no or wrong response to the AT command, so the message "Couldn't find FONA" appear.
I tried the Modem with a simple sketch, that sends the same AT command and the Modem reponses is OK (see below). Using others libraries the modem works well, and sends and recieves SMS.
I need to use the FONA libray because Adafruit have a MQTT libray that I need to use it in order to send my data to adafruit IO. For now I have open jist three feeds, but I are planing to open / buy several feed.

simple test
...
mySerial.println("AT"); //send a AT command to modem with softserial
delay(1000); // wait one s
ShowSerialData(); //print the modem answer to the serial monotor with the hw serial
...
Thank a lot for your support and best regards,
Sergio

SergioF_
 
Posts: 2
Joined: Mon Jan 25, 2021 6:50 pm

Re: FONA with SIM900.

by mikeysklar on Wed Jan 27, 2021 5:48 pm

@SergioF,

Do you have a battery attached? It is required for the FONA to come up and the "Couldn't find FONA" is the message you would see if no battery were present.

mikeysklar
 
Posts: 4969
Joined: Mon Aug 01, 2016 8:10 pm

Re: FONA with SIM900.

by SergioF_ on Sat Feb 06, 2021 2:35 pm

Hi Mike,
thanks a lot for your reply. I see, the library requeres to store data on the MVM, so I have commented the to functions that did this. Noew it works also with no battery.

Best regards,
Sergio

SergioF_
 
Posts: 2
Joined: Mon Jan 25, 2021 6:50 pm

Please be positive and constructive with your questions and comments.