Please note: Friday June 18 is a holiday celebrating Juneteenth, please allow extra time for your order to arrive and plan accordingly.
0

FONA 3G(SIM5320E) - FTPS WITH ARDUINO
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

FONA 3G(SIM5320E) - FTPS WITH ARDUINO

by ahipolito on Sun Feb 21, 2021 3:12 pm

Hello,

I have bought Adafruit FONA - 3G (GPS/GSM) - model SIM5320E and I'm trying to send a text file to an ftps server through the ftps protocol. The Adafruit FONA - 3G is connected to an arduino mega.

First I turn on the modem, then I activate the GPRS (this works fine for me). But then, I try to do the ftps and I have the following problem:

I run the following AT commands:

- AT+CFTPSSTART: Response 0K
- AT+CFTPSLOGIN="IP",21,"User","pass",2: Response OK +CFTPSLOGIN=0 (I have selected the option explicit FTPS server with AUTH TLS. I have configured my ftp server with this option).
- AT+CFTPSTYPE=A: Response OK
- AT+CFTPSMKD="meteo": Response OK (I can create a directory on ftps server).
- AT+CFTPSPUT="data.txt", 10: The problem is that the symbol ">" does not appear (as indicated in the manual of AT commands) and I cannot insert the data string to send. After 30 seconds, response AT+CFTPSPUT=10.

Why doesn't the symbol ">" appear to insert the text string to send to the ftps server?

Do I need to load the SSL certificates before sending the data via ftps server?, But why can I create directories on the ftp server but it fails to transfer data?

Could you help me find a solution?

ahipolito
 
Posts: 1
Joined: Sun Feb 21, 2021 2:12 pm

Please be positive and constructive with your questions and comments.