0

Malfunctioning Adafruit FONA 3G Cellular Module
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Malfunctioning Adafruit FONA 3G Cellular Module

by Dineth on Mon Mar 22, 2021 6:38 pm

I ordered an Adafruit FONA 3G Module through Digikey and received it last week. Unfortunately, I've had several issues with the module I ordered. I tried running the FONAtest and GPS sketches in the Adafruit FONA Library (de-commenting the line for the 3G), and was unable to get the GPS functionality to work despite keeping the FONA outside for a long period of time.

When uploading the above test sketches, the Arduino often returned 'Couldn't find FONA' through the sketch. Recently, the board has stopped responding altogether and the green light does not turn on (as well as the red light). Only the yellow light for charging lights up. All other hardware I used were recommended by Adafruit (the Lipo Battery, Active GPS Antenna).

The only change I made to the board is that I soldered the solder jumper needed to bias the active antenna (as recommended by Adafruit). I was very careful when handling it and grounded myself while handling the module so I'm not sure what might be the happening. I've attached a picture of the circuit. Can anyone help me with this?

Thanks
Attachments
Adafruit FONA Set-up.jpg
Image of my Adafruit FONA 3G Set up
Adafruit FONA Set-up.jpg (510.03 KiB) Viewed 264 times

Dineth
 
Posts: 1
Joined: Mon Mar 22, 2021 6:11 pm

Re: Malfunctioning Adafruit FONA 3G Cellular Module

by rskup on Tue Mar 23, 2021 3:22 pm

Just a thought, but I'm kinda wondering if by having the USB connected, and the TX/RX lines connected at the same time, maybe that's causing the issue. Yes, you can send AT commands through the TX/RX pins, or through the USB, but if both are connected not sure what the FONA board thinks is going on.

Note the tutorial shows powering the FONA using the 5V pins when hooked up to an Arduino, rather than the USB.

https://learn.adafruit.com/adafruit-fon ... ino-wiring

rskup
 
Posts: 84
Joined: Sat Aug 01, 2020 9:04 pm

Re: Malfunctioning Adafruit FONA 3G Cellular Module

by rskup on Tue Mar 23, 2021 5:10 pm

Yep, me again. I realize the tutorial doesn't specifically say connect the 5V from the Arduino to the 5V pin on the FONA, but you'll see it in the tutorial picture in the link above.

Also, here's a (terrible) pic from a FONA setup I had months ago. It's hard to see, but I do have the 5V from the Uno going to the 5V pin on the FONA.

fonabb.jpg
fonabb.jpg (472.42 KiB) Viewed 246 times

rskup
 
Posts: 84
Joined: Sat Aug 01, 2020 9:04 pm

Please be positive and constructive with your questions and comments.