0

camera_feed dashboard not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

camera_feed dashboard not working

by vilovyh on Sat Dec 23, 2017 2:38 pm

Hello, I have followed this tutorial step by step.

https://learn.adafruit.com/cloud-cam-co ... dafruit-io

Everything is working, I have also created dashboard for camera_feed but it shows nothing.
when I click on home and next on monitor at https://io.adafruit.com/user/monitor. I get these errors every two second: 2017-12-23 18:25:17 error saving data on user/feeds/camera_feed, value cannot be larger than 1024 bytes (1 KB) when feed history is on.

I started camera with this command: adafruit-io camera start -f camera_feed -m false -r 2.

I am so hopeless, please help me.
Attachments
errors.png
errors at adafruit/user/monitor
errors.png (136.89 KiB) Viewed 381 times

vilovyh
 
Posts: 2
Joined: Sat Dec 23, 2017 2:15 pm

Re: camera_feed dashboard not working

by btreichel on Sun Dec 24, 2017 2:51 pm

Not knowing your project; it seems that the resolution on your camera is set too high. Are you using their suggested camera, etc. Presume that this is happening every time you publish (send) the feed, and that the sens rate is 2 seconds?

btreichel
 
Posts: 79
Joined: Tue Jul 25, 2017 3:00 pm

Re: camera_feed dashboard not working

by vilovyh on Sun Dec 24, 2017 3:15 pm

I am using Raspberry pi camera module V2 and resolution of my camera is set to 320x240. Yes send rate is set to 2 seconds.

vilovyh
 
Posts: 2
Joined: Sat Dec 23, 2017 2:15 pm

Re: camera_feed dashboard not working

by btreichel on Mon Dec 25, 2017 11:51 am

Try to find where to turn the feed save off, or change the image size. Basically play around with those to get something working and then go on from there.

btreichel
 
Posts: 79
Joined: Tue Jul 25, 2017 3:00 pm

Re: camera_feed dashboard not working

by abachman on Thu Dec 28, 2017 1:33 pm

Hi vilovyh!


You're on the right track, if you're seeing the error message it means data is being sent, but the "too large" error means you'll have to turn off "Feed History" to publish (which is expected for this tutorial).

You can find the feed history setting on the details page for the feed you're working with. You can get to the feed page by clicking on the feed's name from the "Feeds" list. The history setting can be changed by clicking on "Feed History" in the right hand area of the feed page, I've circled it here:
feed-edit-screen.png
feed-edit-screen.png (67.46 KiB) Viewed 295 times


And the actual edit dialog:
feed-history-edit.png
feed-history-edit.png (13.61 KiB) Viewed 295 times


From the feed history editor, you can set history to "Off". That will mean that only the most recent data point (image, in your case) is preserved and lets you use the higher 100KB limit.


- adam

abachman
 
Posts: 214
Joined: Mon Feb 01, 2010 12:48 pm

Please be positive and constructive with your questions and comments.