0

incompatible character encodings: UTF-8 and ASCII-8BIT
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

incompatible character encodings: UTF-8 and ASCII-8BIT

by engeeknyer on Wed Jan 10, 2018 5:18 am

I'm using Arduino + ETH.
When I'm publishing my data, I'm getting this error: "error saving data on engeeknyer/feeds/epsem.radiacio, incompatible character encodings: UTF-8 and ASCII-8BIT".

In despite this message, It seems the values are published, as if were no problem at all.
But I'm viewing the stream in my dashboard (https://io.adafruit.com/engeeknyer/dash ... a-radiacio) and it looks awfull !

Any ideas? Someone has found a similar problem?

Thanks!

engeeknyer
 
Posts: 4
Joined: Mon Jan 08, 2018 8:06 am

Re: incompatible character encodings: UTF-8 and ASCII-8BIT

by abachman on Wed Jan 10, 2018 11:58 am

hi engeenknyer,


We've seen this error pop up very occasionally in the past but haven't been able to trace the root cause. If I could write a test that triggers it, I am pretty sure we could clear it up.

I'm very curious what you were posting and how you were sending it, if you're able to share any code.


- adam

abachman
 
Posts: 131
Joined: Mon Feb 01, 2010 12:48 pm

Re: incompatible character encodings: UTF-8 and ASCII-8BIT

by engeeknyer on Wed Jan 10, 2018 12:18 pm

Hello Adam,

Thanks for reply. The program is based on "Adafruit MQTT Library Ethernet Example", and adapted for our (alpha and gamma) radiation measure. There's no problem to send the code, but I found the problem even feeding manual values, with the Actions>add Data menu.

I'm attaching a photo with this problem.

error.png
error.png (56.77 KiB) Viewed 67 times


Thanks!

engeeknyer
 
Posts: 4
Joined: Mon Jan 08, 2018 8:06 am

Re: incompatible character encodings: UTF-8 and ASCII-8BIT

by abachman on Wed Jan 10, 2018 12:22 pm

Oh interesting, this is helpful information. Thanks for the screenshot!

I'll let you know when/if we have a fix.


- adam

abachman
 
Posts: 131
Joined: Mon Feb 01, 2010 12:48 pm

Re: incompatible character encodings: UTF-8 and ASCII-8BIT

by abachman on Wed Jan 10, 2018 1:35 pm

engeeknyer, I've deployed an update to IO that should fix this issue for you. Before the fix I was seeing the same error when publishing to a feed named "Radiació" and now I'm able to publish without errors.

Can you check to see if publishing and MQTT subscriptions, if you're using them, are working properly for you now?


- adam

abachman
 
Posts: 131
Joined: Mon Feb 01, 2010 12:48 pm

Re: incompatible character encodings: UTF-8 and ASCII-8BIT

by engeeknyer on Thu Jan 11, 2018 3:06 am

Hi!

At this time I have no MQTT subscription. The published value of radiation is now uploaded without problems.

I'll like to test MQTT subscription too. If I have some time during this week I'll create a couple of new feeds and I will test it.

Thanks!

engeeknyer
 
Posts: 4
Joined: Mon Jan 08, 2018 8:06 am

Re: incompatible character encodings: UTF-8 and ASCII-8BIT

by engeeknyer on Thu Jan 11, 2018 8:10 am

Checked!
Subscription is working fine!

engeeknyer
 
Posts: 4
Joined: Mon Jan 08, 2018 8:06 am

Please be positive and constructive with your questions and comments.