0

Banned?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Banned?

by frank m on Thu Apr 26, 2018 12:43 pm

After using AIO for awhile, I'm not able to access my dashboard or anything else. Adafruit recognizes that I'm signed in but I only get error 404. On my profile page, billing just keeps loading forever. My AIO key also loads endlessly. Due to my inexperience, I may have caused my program to continuously call AIO. Have I been banned?
frank m
 
Posts: 4
Joined: Fri Apr 19, 2013 12:47 pm

Re: Banned?

by adafruit_support_carter on Thu Apr 26, 2018 7:22 pm

Have I been banned?

Possibly. But if you've stopped the endless request, it should reset after some period of time. If you wait a while and try again, are you still banned?

adafruit_support_carter
 
Posts: 6163
Joined: Tue Nov 29, 2016 2:45 pm

Re: Banned?

by abachman on Fri Apr 27, 2018 12:48 pm

Hi frank,


We don't have any[more] permanent username bans, so if you're being rate limited, it would be because there's an active device or process somewhere pushing messages too quickly. But like adafruit_support_carter mentioned, turning everything off and waiting at least a minute would let the rate limiting systems reset.

It's also certainly possible there's a bug in the system. If you are willing to share your Adafruit IO username I can take a look at your account and see if something is broken.


- adam b.

abachman
 
Posts: 228
Joined: Mon Feb 01, 2010 12:48 pm

Re: Banned?

by frank m on Fri Apr 27, 2018 11:36 pm

I have had everything off for a couple of weeks now. I did try publishing a few photos the other day and it seemed like that was successful. But I am not able to access my dashboard or AIO key. If I go to profile, under billing plan it constantly is loading but nothing ever happens. AIO key is the same, endlessly loading. Username is frank m.
frank m
 
Posts: 4
Joined: Fri Apr 19, 2013 12:47 pm

Re: Banned?

by frank m on Thu May 03, 2018 5:25 pm

Did you ever figure out why I cannot access my dashboard or AIO key? I would like to get AIO working again since the feeds are for cameras used in conjunction with my fire alarm to verify if there is actually a fire.
frank m
 
Posts: 4
Joined: Fri Apr 19, 2013 12:47 pm

Re: Banned?

by abachman on Thu May 03, 2018 5:49 pm

Hi,


Sorry about the delay, it looks like you carried an old username over from your Adafruit account and it was in a format that is not valid in Adafruit IO (usernames can't have spaces). We've been filtering usernames coming from accounts.adafruit.com for more than a year and none of the HTTP APIs on IO work with usernames with spaces, so I'm not sure how this one was transferred to IO.

I've changed your username on IO to "frank_m" for the time being so you can access to your account on the web again. If you visit https://io.adafruit.com/profile it should redirect you to your personal profile page. You can visit your account page at https://accounts.adafruit.com/ and set your username to any available username that fits the current rules for usernames: can contain numbers, upper or lowercase ASCII (us english) letters, and the "-", "_", or "." characters (dash, underscore, period).

Unfortunately, you'll need to update any MQTT clients since your feed topics and login information will have changed.


- Adam B.

abachman
 
Posts: 228
Joined: Mon Feb 01, 2010 12:48 pm

Re: Banned?

by frank m on Mon May 07, 2018 1:04 pm

Thank you abachman! The change in username solved the problem. Everything working now.
frank m
 
Posts: 4
Joined: Fri Apr 19, 2013 12:47 pm

Please be positive and constructive with your questions and comments.