0

Arduino stops receiving Adafruit IO data
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Arduino stops receiving Adafruit IO data

by W0810877 on Tue Oct 16, 2018 11:33 pm

Hi. I've got an Adarfruit Feather HUZZAH ESP8266 connected to a feed in Adafruit IO. The program receives data from the feed, in this case, an integer representing the temperature. The code seems to work properly, at first.

I add data points, one by one, into the feed. Each value is interpreted and a NeoPixel display changes based on some logic. I then print out the connection status, and that ends the handleMessage method.

My problem is that after 2-7 data points, the program stops receiving data points from Adafruit IO. I've had it happen randomly after 2, 5, 7 data points. After each data point, a message is printed saying connected to Adafruit. After the last data point before it hangs, no connection status is printed.

Any ideas what could be dropping the connection? I'm using Adafruit IO Arduino library version 2.7.19.

Here's some output from my Serial Monitor:
Connecting to Adafruit IOAdafruitIO::connect()
....
Adafruit IO connected.
received <- 68 Previous <- 0
I'm thawing!
Adafruit IO connected.
received <- 73 Previous <- 68
A pleasant temperature and warming!
Adafruit IO connected.
received <- 74 Previous <- 73
A pleasant temperature and warming!
Adafruit IO connected.
received <- 78 Previous <- 74
It's hot and getting hotter!
Adafruit IO connected.
received <- 100 Previous <- 78
It's hot and getting hotter!
Adafruit IO connected.
received <- 62 Previous <- 100
I'm freezing!


Here's the output from the Adafruit IO monitor page.
Live Data newest data at the top
2018-10-16 20:23:23nest-temp15
2018-10-16 20:23:17nest-temp25
2018-10-16 20:22:54nest-temp62
2018-10-16 20:22:45nest-temp100
2018-10-16 20:22:34nest-temp78
2018-10-16 20:22:26nest-temp74
2018-10-16 20:22:18nest-temp73
2018-10-16 20:22:08nest-temp68
2018-10-16 20:21:46nest-temp73
Connections only available while this page is open
2018-10-16 20:28:243f7d3707-13ae-4edc-99e8-1b43d297disconnected
2018-10-16 20:23:27io-browser-10947a60disconnected
2018-10-16 20:22:023f7d3707-13ae-4edc-99e8-1b43d297connected
2018-10-16 20:21:3105893bf3-2a9c-4cd0-b7b0-b4a5133ddisconnected
2018-10-16 20:21:06io-browser-10947a60connected


Thanks much!

W0810877
 
Posts: 2
Joined: Tue Oct 16, 2018 11:18 pm

Re: Arduino stops receiving Adafruit IO data

by brubell on Wed Oct 17, 2018 10:33 am

It doesn't look like (from the monitor) that you're getting timed out of IO.

Can you post your code?

brubell
 
Posts: 189
Joined: Fri Jul 17, 2015 10:33 pm

Re: Arduino stops receiving Adafruit IO data

by W0810877 on Mon Oct 22, 2018 10:46 pm

Attached.
Attachments
Project2.ino
(4.36 KiB) Downloaded 7 times

W0810877
 
Posts: 2
Joined: Tue Oct 16, 2018 11:18 pm

Please be positive and constructive with your questions and comments.